Annoyances with 2.63

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

juntunen
Posts: 5
Joined: Thu May 17, 2012 5:21 am

Annoyances with 2.63

Postby juntunen » Thu May 17, 2012 6:00 am

I am using windows 7, the new 2.63a blender, and the latest nvidia driver.

These problems started with 2.63 and did not exist in 2.55 through 2.62.

I did an uninstall and deleted the left over folders/files from the install directory before installing 2.63a.

My problem is that on all of the drop down menus the highlighting does not keep up with the mouse or even with the arrows keys when I try to select something. If I move the mouse until the highlighting is over what I want I get the item above or below what I wanted depending upon what direction I was moving the mouse.

Also, in edit mode when I rotate or slide the scene and then I try to select a vertice the whole scene jumps spoiling my selection. Even after I do select something (edge loop, vertice, edge, etc) the screen does not update and I have to just click some where off to the edge of the viewport to get the screen to update that what I clicked on was actually selected.

stiv
Posts: 3646
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Postby stiv » Thu May 17, 2012 8:19 am

Try playing with Window Draw Mode in User Prefs.

juntunen
Posts: 5
Joined: Thu May 17, 2012 5:21 am

Postby juntunen » Thu May 17, 2012 9:08 pm

didn't work. I even tried changing the mode saving preferences and restarting blender. Nothing changed.

CoDEmanX
Posts: 894
Joined: Sun Apr 05, 2009 7:42 pm
Location: Germany

Postby CoDEmanX » Sat May 19, 2012 3:39 pm

try running blender in compatibility mode, with desktop composition disabled (Aero off)
I'm sitting, waiting, wishing, building Blender in superstition...

juntunen
Posts: 5
Joined: Thu May 17, 2012 5:21 am

Postby juntunen » Mon May 21, 2012 10:09 pm

Just tried that CoDEmanX. Didn't help.

bill2reg
Posts: 108
Joined: Wed Feb 23, 2011 11:44 am

Postby bill2reg » Tue May 22, 2012 12:19 am

You said you're using Windows 7 but what about your system hardware? What CPU, RAM, etc.?

juntunen
Posts: 5
Joined: Thu May 17, 2012 5:21 am

Postby juntunen » Tue May 22, 2012 11:34 pm

The computer is a Toshiba Satellite p755-s5198

CPU: Intel core i7-2670qm
Installed memory: 6 GB
Video Card: Nvidia Geforce GT 540m

64 bit windows 7 w. service pack 1


Need any more info?

CoDEmanX
Posts: 894
Joined: Sun Apr 05, 2009 7:42 pm
Location: Germany

Postby CoDEmanX » Wed May 23, 2012 1:35 am

make sure you also got latest chipset and Intel GPU drivers

check Intel display settings, rather chose "quality" than "performance", as the latter can screw up text (e.g. blur it so it's not readable anymore, maybe yours is blurred that much that you can't see anything)

have you tried with Anti-Aliasing turned off (User prefs > System tab)? It usually smooths fonts, but may be problematic on your system
I'm sitting, waiting, wishing, building Blender in superstition...

bill2reg
Posts: 108
Joined: Wed Feb 23, 2011 11:44 am

Postby bill2reg » Wed May 23, 2012 6:13 pm

Some other possibilities could be if you have a scene with a large number of vertices, if you're using solid or rendered display mode (Cycles) as these can cause slow response.

juntunen
Posts: 5
Joined: Thu May 17, 2012 5:21 am

Postby juntunen » Wed May 23, 2012 8:18 pm

CoDEmanX I tried your suggestions yesterday and I got mixed results. Blender was snappier and reacted more quickly to my mouse input but the basic problem was still there.

Later however windows update downloaded the service pack 2 updates and after the reboot blender was working the way I expected it to.

So was it your suggestions and the reboot or a combination of the sp 2 updates added into the mix? I don't know.


But I want to thank you and bill2reg for the help. At the very least I learned more about the setting in the preferences.

frblack
Posts: 4
Joined: Thu Oct 25, 2012 6:39 pm

Postby frblack » Sat Oct 27, 2012 9:43 am

using 2.63 on x64 win7 (ASUS G75 laptop) i get the similar not updating issues. the complex models in 3D update really fast, so it cannot be the slowness/performance.

then i noticed the following:
- load blender (with default cube)
- enable "open on mouse over" in user settings. set it to fast 1s.
- now go to say "Add" menu, and wait until it drops box. Stay on menu title "Add".
- next, quickly move to mouse and stop on "Render" menu entry.
- voila, it keeps "Add" highlighted and render is not dropping.
- when you move a tiny bit again, it drops.

this is annoying because i am used to fast and precise mouse movements, where i do not move mouse much around after arriving to the spot.

stiv
Posts: 3646
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Postby stiv » Sat Oct 27, 2012 4:53 pm

Problems like this are due to poor OpenGL drivers or window manager settings. Usual fixes:

updated video driver from manufacturer's site

turn of eye candy like compositing window managers or transparent effects.

Sometimes it helps to turn down hardware graphics acceleration.

frblack
Posts: 4
Joined: Thu Oct 25, 2012 6:39 pm

Postby frblack » Sun Oct 28, 2012 7:50 am

i have latest (non-beta) Nvidia drivers. i have tried turning off transparency, that didn't help either.


Return to “Interface & Tools”

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests