SpaceNavigator 3D Connexion & Blender 2.5 ?

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Batty
Posts: 8
Joined: Fri Feb 03, 2012 9:14 am
Location: Germany

Postby Batty » Sat Jun 30, 2012 10:02 am

About panning with SpaceNavigator:

merwin_sigbit wrote:
Yeah, it's lame, but it's working as expected. This is the #1 complaint from blenderheads, so better one-handed navigation (without shift) is at the top of my todo list.



Thumbs up!!!
I'm used to professional navigation from most of the other 3D Programs and it's THE stumbling stone to me for using Blender. I need my other Hand for the Graphic Tablet at work. The haptik feels unnatural at the moment. I don't move my head in real life like that and it comes into play at least, when you have to work on wider models or many objects in whole scenes. This is, where it starts to consume time (using the shiftkey feels like hanging in ropes :p), summing up to a lot of time after a while.

Will this be in the coming release (I think it's 2.64) ?

Soelen
Posts: 2
Joined: Mon Jul 04, 2011 11:33 am

Postby Soelen » Sun Oct 14, 2012 9:45 am

I installed blender 2.64 today and I cannot work with the 3dconnexion mouse anymore, am I the only one?

- it wont zoom anymore when I switch do orthographic view

- the focus point (not sure it is called like that) is now moving too when I use that 3d moue (for example, when I use the middle mouse button, the focus point is always at the same place and it was like that on blender 2.62, 2.63 I think)

- now I am able to tilt/roll my viewport, great but, there is no option to turn this off again! Only when I go to flymode this tilt/roll thing is disabled, exactly there where I would need it

Is there any work around for my current problems with this mouse? Man, I really enjoyed to work with it

Tehrasha
Posts: 1264
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Postby Tehrasha » Mon Oct 15, 2012 9:21 am

Soelen wrote:- it wont zoom anymore when I switch do orthographic view


Yup, that appears to be broken. I know that zoom is handled differently in Ortho mode, so that might be part of the issue.

- the focus point (not sure it is called like that) is now moving too when I use that 3d moue (for example, when I use the middle mouse button, the focus point is always at the same place and it was like that on blender 2.62, 2.63 I think)


Correct, it has always been this way. IMHO, the center of 3D Mouse rotation should either be the same as what is already selected as the 'pivot center' or alternatively, the active selection, whether it is a single vertex or a group of objects.

- now I am able to tilt/roll my viewport, great but, there is no option to turn this off again! Only when I go to flymode this tilt/roll thing is disabled, exactly there where I would need it


At the bottom of the 3D Mouse Settings menu, deselect 'Lock Horizon'
and you will get your tilt/roll back in fly mode.

Is there any work around for my current problems with this mouse? Man, I really enjoyed to work with it


The only workaround I know of, would be to revert back to 2.63, unless you can figure out how to regress just the NDOF of the code and compile your own copy.
Spacemice Wiki -- Input devices for a 3D world.
Spacemice / Blender Compatibility

daviddarke
Posts: 1
Joined: Sun Nov 04, 2012 11:35 am
Location: United Kingdom

Postby daviddarke » Sun Nov 04, 2012 11:42 am

Soelen wrote:I installed blender 2.64 today and I cannot work with the 3dconnexion mouse anymore, am I the only one?

- the focus point (not sure it is called like that) is now moving too when I use that 3d moue (for example, when I use the middle mouse button, the focus point is always at the same place and it was like that on blender 2.62, 2.63 I think)


Hi all, yeah same issue really, I'm used to having the perspective orbit around the selection, this sudden change to being just constantly panning around - disregarding my selection - has stunted my workflow.

If anyone has any work arounds it would be great to hear them. I've moved back to 2.63 for now.

mooncaine
Posts: 20
Joined: Sat Dec 05, 2009 9:01 pm

Spacenavigator totally broken in 2.64

Postby mooncaine » Thu Nov 15, 2012 4:17 am

Are you the only one this is happening to? Maybe not. It might be happening to me.

What's definitely happening to me: Spacenav stopped working in blender 2.64.

Working well in 2.63.

mooncaine
Posts: 20
Joined: Sat Dec 05, 2009 9:01 pm

Re: Spacenavigator totally broken in 2.64

Postby mooncaine » Wed Nov 21, 2012 8:08 pm

mooncaine wrote:Spacenav stopped working in blender 2.64.


UPDATE: fixed, I think!

I don't know what fixed it, but I used Disk Utility to repair permissions today before using Blender. Maybe that's what fixed it.

Working great!

mooncaine
Posts: 20
Joined: Sat Dec 05, 2009 9:01 pm

Re: Spacenavigator totally broken in 2.64

Postby mooncaine » Thu Nov 22, 2012 12:57 am

Bummer, the lag came back. Unusable. Dunno why, but at least now we know that repairing permissions didn't fix it.

Meteo27
Posts: 3
Joined: Tue Aug 23, 2011 12:24 pm

Postby Meteo27 » Thu Dec 13, 2012 12:21 am

Why doesn't work the panning anymore without pressing <Shift>. Worked fine in 2.64, but in 2.65 you have to hold <Shift> again like in previous versions.
Or did I overlook something?

Meteo27
Posts: 3
Joined: Tue Aug 23, 2011 12:24 pm

Postby Meteo27 » Thu Dec 13, 2012 12:26 am

Meteo27 wrote:Why doesn't work the panning anymore without pressing <Shift>. Worked fine in 2.64, but in 2.65 you have to hold <Shift> again like in previous versions.
Or did I overlook something?


Ok, disregard my last post. I used setting files from an old version which mixed things up.

Works fine now.

Tehrasha
Posts: 1264
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Postby Tehrasha » Wed Feb 06, 2013 10:35 am

I am experiencing the same thing with the 2.65 that I just built.
Reverting to factory defaults did not fix it for me.
I can only pan while using SHIFT.
Last edited by Tehrasha on Mon Feb 25, 2013 11:44 pm, edited 1 time in total.

Tehrasha
Posts: 1264
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Postby Tehrasha » Mon Feb 25, 2013 11:44 pm

The Answer....

http://projects.blender.org/tracker/?fu ... group_id=9

You can re-enable the free-fly mode, but you cannot 'zoom/rotate around selection' at the same time. Not until someone takes up the reigns and continues to maintain the ndof code in Blender.
Spacemice Wiki -- Input devices for a 3D world.

Spacemice / Blender Compatibility

mxxrten
Posts: 1
Joined: Mon Apr 08, 2013 9:16 pm

Postby mxxrten » Mon Apr 08, 2013 9:17 pm

In the release note it says:
The previous default (free fly mode) is now behind modifier keys SHIFT+CTRL. Users can swap this default in our keymaps.

Could you please tell me how to set the settings to free fly mode? which keymaps exactly? I tried different combinations with: view3d.ndof_orbit_zoom, view3d.ndof_orbit, view3d.ndof_pan, view3d.ndof_all, but can't figure it out. I have rotate around selection and zoom to mouse position disabled.

martonfodor
Posts: 1
Joined: Fri May 17, 2013 11:54 am
Location: London

Re: Spacenavigator totally broken in 2.64

Postby martonfodor » Fri May 17, 2013 11:56 am

mooncaine wrote:Bummer, the lag came back. Unusable. Dunno why, but at least now we know that repairing permissions didn't fix it.


We are also experiencing this. It seems to be a performance issue as when Blender is used at a lower resolution (smaller window) it tends to work fine, but on 27" it almost always lags. Must be some python script struggling to keep up.

Any chance for a fix? Willing to donate for proper support.

Tehrasha
Posts: 1264
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Postby Tehrasha » Wed Oct 09, 2013 8:54 pm

mxxrten wrote:In the release note it says:
The previous default (free fly mode) is now behind modifier keys SHIFT+CTRL. Users can swap this default in our keymaps.

Could you please tell me how to set the settings to free fly mode? which keymaps exactly? I tried different combinations with: view3d.ndof_orbit_zoom, view3d.ndof_orbit, view3d.ndof_pan, view3d.ndof_all, but can't figure it out. I have rotate around selection and zoom to mouse position disabled.



I have added instruction for making 'Free-Fly Mode' (rotation & translation) the default behaviour, at the bottom of my Blender Compatibility page.
Spacemice Wiki -- Input devices for a 3D world.

Spacemice / Blender Compatibility


Return to “News & Chat”

Who is online

Users browsing this forum: No registered users and 0 guests