Previous Thread  Next Thread

chat icon Parent to bone

brianorca

Posted: Fri Dec 07, 2012 3:41 pm
Joined: 07 Dec 2012
Posts: 7
In 2.65RC, I can't parent an object to a bone.
I have an armature, with several bones. The skin object is parented to the armature, and deforms normally.
The second object is a solid bone (jaw bone with teeth, multiple objects grouped under an empty.) but Blender won't let me parent it to the appropriate bone. I don't want it to deform.

When I drag it to a bone, it does not parent at all. If I drag it to the armature, the menu has an option to "Parent to Bone" but nothing happens when I pick it. If select the object, and shift-click a bone, it won't allow both to be selected at the same time. I have tried it in Pose, Edit and Object mode. In pose mode, selecting the object changes the mode.

While researching this in Google, I see several old (2008-2010) release notes that say it's "working again" but I don't see any current issues related to this. What am I doing wrong?
Reply with quote


brianorca

Posted: Mon Dec 10, 2012 2:30 am
Joined: 07 Dec 2012
Posts: 7
Well, I figured out the "Child Of" modifier, but still confused why the "Parent to..Bone" doesn't work.
Reply with quote


brianorca

Posted: Mon Dec 10, 2012 3:53 am
Joined: 07 Dec 2012
Posts: 7
Finally got it. After using the "Parent to..Bone" option, you still have to find the "relations" section of the object data tab and set the bone name there. But it messes up the original transform of your object. Sad
Reply with quote


 
Jump to:  
Powered by phpBB © 2001, 2005 phpBB Group