Error on "import math"

Scripting in Blender with Python, and working on the API

Moderators: jesterKing, stiv

effeuno
Posts: 4
Joined: Thu Oct 17, 2002 11:58 pm
Location: Piacenza (IT)

Error on "import math"

Postby effeuno » Fri Feb 28, 2003 4:27 pm

I'm running Blender 2.26 on OSX 10.2 and I can't include the modules in the pyhton lib-dynload directory (math, time, zlib and the others). :(
I've built Pyhton 2.2.2 from scratch (I know the Pyhton embedded in Blender is version 2.2.2) and I've placed in the sys.path the full path to the modules but blender still say:
    ...
    ImportError: Failure linking new module

I can't understand what's wrong.
Any ideas :?:

Thank you,
Francesco

Bischofftep
Posts: 37
Joined: Thu Feb 06, 2003 11:01 pm
Location: Richmond, VA
Contact:

Same Boat

Postby Bischofftep » Wed Mar 05, 2003 2:15 pm

Heya:

Just adding my voice to the chorus calling for the ability to import precompiled objects (I'm guessing that's what ".so" means) into Blender on OS X. I have the exact same problem. IDLE under X11 runs just fine, but Blender's Python interperet is broken under OS X.

Anyone out there know anything about this??

-Bischofftep

Bischofftep
Posts: 37
Joined: Thu Feb 06, 2003 11:01 pm
Location: Richmond, VA
Contact:

Python 2.0 only?

Postby Bischofftep » Thu Mar 13, 2003 3:01 am

More news here:

Apparently Blender works with Python 2.0 only. This doesn't seem to be available to MacOS X, 2.1 and higher only.

Can anyone confirm?

-Bischofftep


Return to “Python”

Who is online

Users browsing this forum: No registered users and 2 guests