blender 2.5 and middle mouse botton

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

razvanab
Posts: 4
Joined: Mon Nov 23, 2009 9:56 pm

blender 2.5 and middle mouse botton

Postby razvanab » Mon Nov 23, 2009 10:02 pm

Hi

In blender 2.5 middle mouse option for rotate / pan doesn't work
you have to change it from Input keyboard shortcut to work

jwoelper
Posts: 2
Joined: Tue Nov 24, 2009 10:46 am
Location: Hamburg, Germany

Re: blender 2.5 and middle mouse botton

Postby jwoelper » Tue Nov 24, 2009 10:50 am

razvanab wrote:Hi

In blender 2.5 middle mouse option for rotate / pan doesn't work
you have to change it from Input keyboard shortcut to work


Hi!

I noticed that, too. The commmit message says: "removed mmb pan/rotate user preference - this is handled by key maps now".

I can set view3d.move to MMB, however that does not override the default MMB rotate. It only works when I set this to ALT-MMB, then i can pan.
Is there any way to override MMB (without modifier) with pan?

razvanab
Posts: 4
Joined: Mon Nov 23, 2009 9:56 pm

Re: blender 2.5 and middle mouse botton

Postby razvanab » Tue Nov 24, 2009 10:55 am

jwoelper wrote:
razvanab wrote:Hi

In blender 2.5 middle mouse option for rotate / pan doesn't work
you have to change it from Input keyboard shortcut to work


Hi!

I noticed that, too. The commmit message says: "removed mmb pan/rotate user preference - this is handled by key maps now".

I can set view3d.move to MMB, however that does not override the default MMB rotate. It only works when I set this to ALT-MMB, then i can pan.
Is there any way to override MMB (without modifier) with pan?


i think it's because both are set to use ALT key
just a guess

jwoelper
Posts: 2
Joined: Tue Nov 24, 2009 10:46 am
Location: Hamburg, Germany

Re: blender 2.5 and middle mouse botton

Postby jwoelper » Tue Nov 24, 2009 12:32 pm

i think it's because both are set to use ALT key
just a guess



Sorry if I was not very clear about this:
Nothing is set to ALT-MMB by default. View3d.move on MMB does not work, View3d.move bound to ALT-MMB does work. My guess is thet the default MMB=view3d.rotate overrides this.

_BigWings_
Posts: 25
Joined: Thu Mar 12, 2009 7:13 pm

Postby _BigWings_ » Wed Nov 25, 2009 12:45 am

I can't pan at all, whether its with alt or without. :(

aimozs
Posts: 1
Joined: Thu Sep 09, 2010 4:24 pm
Location: montreal

mac version

Postby aimozs » Thu Sep 09, 2010 4:27 pm

on the mac version u cant rotate or pan with the mouse either, but you can with the trackpad by pinching and rotate with two fingers...

that's cool, but it's not efficient :S
A mouse may be of service to a lion.

brett.zamora
Posts: 1
Joined: Sat Dec 18, 2010 12:50 am

Re: mac version

Postby brett.zamora » Sat Dec 18, 2010 1:04 am

aimozs wrote:on the mac version u cant rotate or pan with the mouse either, but you can with the trackpad by pinching and rotate with two fingers...

that's cool, but it's not efficient :S



Actually... this frustrated me too, but the truth is you can. Here is a link to a good article on changing User Preferences. Mine works great now after I set my preference to shift-LMB.

Also... if you are using a magic mouse, go into the Application, System Preferences, Mouse and un-check the Screen Zoom box.

Hope this helps.

ruffrabbit
Posts: 1
Joined: Wed Sep 07, 2011 3:47 pm
Location: United Kingdom

Re: mac version

Postby ruffrabbit » Wed Sep 07, 2011 6:06 pm

Here is a link to a good article on changing User Preferences. Mine works great now after I set my preference to shift-LMB.

How can I get the link?

Lamm
Posts: 1
Joined: Mon Dec 12, 2011 9:56 am

Postby Lamm » Mon Dec 12, 2011 10:02 am

_BigWings_ wrote:I can't pan at all, whether its with alt or without. :(


Drag with the middle mouse button pressed down, while keeping the Shift key down.

IAreWaffle
Posts: 1
Joined: Mon Jan 14, 2013 7:45 pm

Re: blender 2.5 and middle mouse botton

Postby IAreWaffle » Mon Jan 14, 2013 7:48 pm

razvanab wrote:Hi

In blender 2.5 middle mouse option for rotate / pan doesn't work
you have to change it from Input keyboard shortcut to work


The default is set to Ctrl, and the arrow keys on the Num pad (8462).

zaza
Posts: 2
Joined: Fri May 24, 2013 9:39 pm

Postby zaza » Thu Jun 06, 2013 2:29 pm

brett you forgot the link ... how do I do this ... :roll:
If you hear a voice that says 'Thou shall not spam' it may be an admin online and you will be silenced. Nope.


Return to “Testing Builds”

Who is online

Users browsing this forum: No registered users and 0 guests