blurred textures (turning off filter?)

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

lean
Posts: 7
Joined: Wed May 02, 2012 5:31 am

blurred textures (turning off filter?)

Postby lean » Wed May 02, 2012 5:50 am

hello. I'been using blender for a little more than a year now, and I feel really comfortable with it. However, some time ago I've updated from version 2.49 to 2.6. I often make pixel art textures for my models, and with this latter versions, I'm having trouble getting sharp renders.

I've setted off mimpmaps in the preferences panel, I've setted AA off in Render panel and setted mip maps off in the texture panel.

the last thing that seems to be blurring the texture is the filter at image sampling in the textures panel. I can't set this filter below 0.10 so I uncheck interpolation wich states "interpolate pixels using selected filter" but that doesn't work the filter is still interpolating the pixels.

this problem didn't happen to me with version 2.49.

lean
Posts: 7
Joined: Wed May 02, 2012 5:31 am

Postby lean » Sat May 05, 2012 9:03 pm

bump?

marksism
Posts: 16
Joined: Tue Aug 30, 2011 10:36 pm
Location: London

Postby marksism » Tue May 08, 2012 6:55 pm

Hi there

I had a similar a problem but solved it by switching on Premultiply and Fields in the Texture properties panel, setting the Fields to Upper First. I have absolutely no idea what either of these functions do but it worked for me, hope it does the same for you.

lean
Posts: 7
Joined: Wed May 02, 2012 5:31 am

Postby lean » Wed May 09, 2012 5:47 am

hi.
thanks for the reply. I just tried premultiply and fields, and the problem persists.

as I have mipmaps off in preferences, the texture show correctly in the 3d view, but when I render, blender antialiases the pixels.

marksism
Posts: 16
Joined: Tue Aug 30, 2011 10:36 pm
Location: London

Postby marksism » Wed May 09, 2012 7:02 pm

Hello again

Sorry my suggestions didn't work for you. I've just taken a look at the blend file that initially caused the problem for me and the important factor seems to have been the Fields setting. All I can suggest now is that you replicate the texture settings that worked for me and see what happens.

Fields and Premultiply set as in my previous post.

Image Sampling
Mip Maps- on
Mip Map Gaussian Filter- on
Interploation- on

The Filter type is set to Feline, with Probes at 23 and Filter size to 0.08.

I'm not sure what any of this actually means but my moto is 'If in doubt, switch things on and off at random.' but don't try it if you work in a nuclear power plant or the cardiac ward of a hospital.

Good luck

lean
Posts: 7
Joined: Wed May 02, 2012 5:31 am

Postby lean » Wed May 09, 2012 7:22 pm

hello

ok, so these last settings actually kinda made it worse haha. changing the filter to feline seems to work better but the problem is, as I said in the original post, that the filters can't be set at lesser values than 0.10.

how could you set it to 0.08?

marksism
Posts: 16
Joined: Tue Aug 30, 2011 10:36 pm
Location: London

Postby marksism » Wed May 09, 2012 9:27 pm

er...the 0.08 was a mistake on my part and you're correct, the filters don't go below 0.1. Sorry about that.

It has occurred to me that the problem might be with antialiasing on the the textures. The blend that gave me trouble was using an image map to put the characters on a model of a QWERTY keyboard. The original texture I created (through PhotoShop) used antialiasing on the keyboard characters and the result, when applied as a Texture in Blender, was a big blurry mess, regardless of the Texture settings used. I went back to PS and remade the texture with AA switched off and found that it worked fine with the Texture settings I suggested earlier.

That's all I can think of- and I'm sorry if it's of no use to you. It's obviously possible to get crisp Texture Mapping in Blender but I think it might take someone with more knowledge to provide the help.

Is there anybody out there?

lean
Posts: 7
Joined: Wed May 02, 2012 5:31 am

Postby lean » Wed May 16, 2012 8:37 pm

so, no one else has had this problem?

lean
Posts: 7
Joined: Wed May 02, 2012 5:31 am

Postby lean » Tue May 22, 2012 9:23 pm

so, should this be reported as a bug or suggestion?

MoonBeans
Posts: 1
Joined: Sat Nov 17, 2012 3:31 am

Postby MoonBeans » Sat Nov 17, 2012 3:35 am

Here's what I use (I get crisp, clear pixels):

Under image sampling:

[ ] Normal Map
[ ] Derivative Map
[ ] MIP Map
[ ] Interpolation
Filter:
[Box]
<Filter Size: 0.10>
[ ] Minimum Filter

I turned off all the check-boxes and set the filter to box.


Return to “Rendering”

Who is online

Users browsing this forum: No registered users and 0 guests