can't avoid fireflies

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Posts: 1
Joined: Wed Feb 29, 2012 9:35 pm

can't avoid fireflies

Postby steve4891 » Wed Feb 29, 2012 9:51 pm

Hello everybody...

i need an help to resolve a problem with light..

i have a room and i want to illuminate it with a lamp...

i bult a lamp with a cone in the upper side and a plane with emission material.

the problem is that this emission material gives me a lot of white dots pixels. even though i reduce the intensity to 20 the problem remain..

the strange thing is that if i put a plane (emisison) in the middle of the roof with example intenisty 50 the result is perfect... this second emission doens't provide white dots..instead the other one yes.

can someone tell me why this happen and how can this problem be solved?

thanks to all...


Posts: 544
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Postby ldo » Wed Mar 07, 2012 8:15 am

Tried increasing the number of samples?

Posts: 1
Joined: Thu Mar 08, 2012 1:51 pm

Same problemo

Postby Oippis » Thu Mar 08, 2012 2:07 pm

Hei, I assume you're using Cycles. I came to this Forum with the same problem. I've been working on a simple room scene (for my school project), and I'm losing my nerve because of these "fireflies".

I realise that Cycles has problems rendering glass, (the windows here for example) is there a solution?

First I tried 200 samples, then I lifted it to 600 (in the pic) but the result is equally shitty so I figured it's not the amount of samples. I also tried different light bounce settings with no difference.

What's really annoying is that the rest of the image looks somewhat sharp and noiseless (just some light default "cycles grain") except these big white dots.

Posts: 544
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Postby ldo » Thu Mar 08, 2012 6:52 pm

In one previous test I was able to get less noisy-looking results by going as high as 2000 samples. What version are you using? With a more recent (2.62+) build, it seems to look better with just the default values.

Posts: 2
Joined: Tue Mar 16, 2010 9:56 am

Postby stijntas » Sat Mar 17, 2012 8:54 am

Posts: 1
Joined: Fri Apr 27, 2012 3:04 am
Location: Blenderville

Postby iliketoblender » Wed Jun 20, 2012 2:00 am

I had the same exact problem for a long time. I had given up on all my cycles work that involved glass until I decided to spend some time troubleshooting. What I found to work was scaling up the light source (use a plane with the emission shader if you weren't already) and decreasing the emission level of the light source.

Posts: 8
Joined: Fri Feb 03, 2012 9:14 am
Location: Germany

Postby Batty » Thu Jul 12, 2012 3:37 pm

The only thing that helped hugely, as I found out by searching the Net, is to set "Clamp" to 1.
But this goes at the expense of having caustics. This made my fireflies vanish even in complex glass scenes. I hope this might help until there is hopefully a better solution. :)

kr Batty

Return to “Rendering”

Who is online

Users browsing this forum: No registered users and 1 guest