Blender file compatibility question

The interface, modeling, 3d editing tools, import/export, feature requests, etc

Moderators: jesterKing, stiv

Icophesis
Posts: 1
Joined: Tue Aug 21, 2012 7:35 pm

Blender file compatibility question

Postby Icophesis » Tue Aug 21, 2012 7:54 pm

Hello, I'm in the process of learning Blender so I can make some models for Skyrim, and I understand that as of right now, only Blender 2.49 supports nifskope plugins (a necessary medium to converting blender files into something the Bethesda engine uses) but the problem is that the Blender tutorials I follow on wikibooks use version 2.63. There are a lot of differences between these versions, and many of the hotkeys are different, and its been a chore trying to cross-reference and locate menus cited in the tutorial in version 2.49.

My question is, would I be able to create my model in the 2.63 version of the program, then load it in the earlier 2.49 version and use that to export to NifSkope, or will it not open because its an older version of the software? I wouldn't want to spend a lot of time painstakingly modeling something only for it to not be compatible, and while I can use 2.49, its clunkier and much more difficult to follow the tutorials with. And the Nifskope plugins are incompatible with the latest Blender versions for the foreseeable future.

Thanks in advance.

stiv
Posts: 3646
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Postby stiv » Tue Aug 21, 2012 11:07 pm

The .blend file format is generally forward and backward compatible between Blender version. However, if your .blend contains features with are not supported by an older version of Blender, they will not show up.

Trying to use the new blender interface tutorials with old blender sounds like a nightmare.

kredytyhipoteczne
Posts: 1
Joined: Wed Aug 22, 2012 1:02 pm

Postby kredytyhipoteczne » Wed Aug 22, 2012 1:03 pm

I agree with stiv. I think that you are getting yourself into lots of annoying work by using new blender interface thingy.

Tehrasha
Posts: 1264
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Postby Tehrasha » Wed Aug 22, 2012 11:17 pm

Use new version of Blender that matches tutorials so you can follow along.

Export model as a universal format (ex: .obj)

Import that file into older Blender and export as NifSkope.

Though it is probably a lot more complicated than that.
Spacemice Wiki -- Input devices for a 3D world.
Spacemice / Blender Compatibility

kredytkons
Posts: 1
Joined: Fri Oct 19, 2012 10:04 pm

Postby kredytkons » Fri Oct 19, 2012 10:07 pm

Thank you Tehrasha for posting solution to this.


Return to “Interface & Tools”

Who is online

Users browsing this forum: No registered users and 0 guests