GeForce previewing problem accidently created & resolved

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

LukeW
Posts: 64
Joined: Mon Mar 03, 2003 1:14 pm

GeForce previewing problem accidently created & resolved

Postby LukeW » Sat Mar 08, 2003 2:15 pm

(The problem I accidently created has now been resolved by Mel_Q in this thread...)

I just got a GeForce4MX440 to speed up the display of the preview animations. My old card (onboard SiS one) played back the animations quite slowly.
Well in my projects, in the shaded and solid views, the graphics look pretty good with little or no flaws.
- unless I switch to camera mode... then the z buffer flips around chaotically as the camera moves - or rotates. The surfaces of the objects turn inside and out and it looks even worse when the objects are made up of many intersecting objects - but if I'm not in the camera view those intersecting objects render quite flawlessly - well except when there are tiny intersecting details seen from a distance - then there are some minor problems.
I've heard that the GeForce card has problems in blender... so are people having the same problem?
Also, if I try and enable anti-aliasing in the nVidia control panel, blender doesn't really start up - well sometimes the buttons appear a bit when you move the mouse over them - but the blender window is basically blank.

http://www.ozemail.com.au/~wenke/blender/zbuffer.htm

This has some pictures of the problem, like this one:
Image
Last edited by LukeW on Mon Mar 17, 2003 1:07 pm, edited 1 time in total.

Mel_Q
Posts: 58
Joined: Wed Oct 16, 2002 12:00 am

Not permanent, but...

Postby Mel_Q » Sun Mar 16, 2003 7:01 pm

First off, I think questions of this nature are more suitable for
the forum at http://www.elysiun.com .
I have a quick answer that might help so...
:cry:
I get the same problem a lot (gf2mx200 w/det4 drivers works fair but det4's probably don't support gf4).
I can improve the visual quality some by tinkering with the clipping values
for both the camera and window.
Those wanting to know what I'm talking about check here: http://myweb.cableone.net/rigel/gforceclip1.htm

Keep in mind this: Adjusting the camera clipping also affects the clipping in the renderer- use with caution or you might see holes on close up objects, or distant objects will dissapear into an 'invisible wall'.

Again, it's my understanding that this forum is more about the development of blender's rendering code, so if that doesn't work please repeat your post at Elysiun.

LukeW
Posts: 64
Joined: Mon Mar 03, 2003 1:14 pm

Re: Not permanent, but...

Postby LukeW » Mon Mar 17, 2003 9:31 am

Mel_Q:
Thanks, that fixed it! I only had problems with the camera (screen 1 in your link) - in the window clipping settings (screen 2 in your link) Blender already had it set like that.

Mel_Q wrote:...it's my understanding that this forum is more about the development of blender's rendering code....

Well I thought it would involve the Z-buffer or something and rendering people might have some ideas about what the problem could be. I also wanted this to be fixed in future versions of Blender. This seems quite possible... it just involves the developers to change the default settings for "ClipSta" for the camera. I submitted a bug report earlier about this and now I'm going to explain how they can fix it.

....

Now I've realized that the default camera setting already IS 0.1! It was me who changed it to 0 for my projects! A setting of (near) 0 worked fine before I recently got my GeForce4 MX card. I hadn't started any big new projects since I got the card... so I had the ClipStart of the camera = 0.

dittohead
Posts: 122
Joined: Mon Oct 14, 2002 2:49 am

Postby dittohead » Fri Mar 21, 2003 10:50 pm

your not alone, i had the same problem, however it is non exsistent in linux, so convert to linux, it's better for blender anyway.
dittohead


Return to “Rendering”

Who is online

Users browsing this forum: No registered users and 2 guests