Please Help sumone

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

leinad13
Posts: 216
Joined: Wed Oct 16, 2002 5:35 pm

Please Help sumone

Postby leinad13 » Tue Mar 18, 2003 7:46 pm

Whoever compiled the windows version, should stop hiding in their hole and come out and help the community compile the source.

So far Blender Foundation have done a great job, but i think its about time, that they tell us how to compile. Or even start to develop new way of compiling using free tools, in my case i cant even attempt to change the code, cos whenever i try and load up a blender project file i get an error saying it wasnt created by Developer Studio, and from there my troubles spiral out of control.

There was someone who compiled the source before the official release for windows, i think it was nicolasta or sumthing like that. Where are u man. HELP US

Sorry for the rant im getting seriously frustrated. :x
-------------
Over to you boffins

L!13

Money_YaY!
Posts: 876
Joined: Wed Oct 23, 2002 2:47 pm

Postby Money_YaY! » Tue Mar 18, 2003 8:20 pm

He
is
gone
somewhere
??>?,

Sorry but I can not help, but I did try to help the comnu
I tried to compile OSX Tuhopuu . But I placed an out of date file
in my usr folder and now I can not get it out.

So I can not help the OSX peeps, So there are some creatures that
are doing stuff, they just do like like to share sometimes. Thats fine they
put the work in them self so they it's theirs and theirs only.

^v^ please share now and then, I get libcrypto.a is out of date , See ya.

Mats78
Posts: 155
Joined: Thu Oct 17, 2002 5:06 pm
Location: Vantaa, Finland

Postby Mats78 » Tue Mar 25, 2003 9:53 pm

Look at the sticky topic.. some ideas there. But in my opinion... and now I don't know if I'm just being lucky... it seems as Blender will compile quite easily.

Make sure you have the latest service pak for MSVC (<- I guess that's what you use) and you should be good to go. I'm not sure about the problems with the project files, but that might go away by installing the service pack.

Other than that it now works nicely for me. The things I do:

1) open \blender\intern\make\msvc_6_0\intern.dsw
-set active project to build_install_all and build it (might want to try
debug or release)

2) open \blender\projectfiles\blender\blender.dsw
-set active project to blender (again.. debug or release) and build it

..and that's all I have to do =) just make sure you have MSVC 6 with service pack 5 (I think it was 5) and that you have checked out both blender and the lib module. Also remember to tell MSVC where it should look for header files etc.

Hope I'm able to help, I've been a bit annoyed myself about not finding any help files regarding the build process as I'm completely new to this =) No knowledge on msvc either =)) but do ask if there's something more bothering you (keep in mind I can only tell you what I've done though)


Return to “Coding Blender”

Who is online

Users browsing this forum: No registered users and 0 guests