X Error of failed request: BadValue

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

BrianNickel
Posts: 3
Joined: Wed Oct 23, 2002 4:56 am

X Error of failed request: BadValue

Postby BrianNickel » Thu May 08, 2003 6:01 am

More often than not, on XFree86 4.3 with a Radeon 7000, Blender 2.26 crashes when I hit "Render":

Code: Select all

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  142 (XFree86-DRI)
  Minor opcode of failed request:  9 ()
  Value in failed request:  0x280002e
  Serial number of failed request:  2793
  Current serial number in output stream:  2793

This happens on binary installs (Redhat), and source installs (Gentoo).

Blender 2.23 works perfectly, but I would prefer 2.26.
Any insight/solutions?

freetz
Posts: 1
Joined: Mon May 12, 2003 11:00 am

Postby freetz » Mon May 12, 2003 11:13 am

I got the same problem:

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 145 (XFree86-DRI)
Minor opcode of failed request: 9 ()
Value in failed request: 0x18000a5
Serial number of failed request: 1429
Current serial number in output stream: 1429

I'm running Blender 2.27-cvs, Xfree86-4.3.0 with all possible drivers combinations for my Radeon 7200 32 DDR Build by ATI (snapshots from dri.sf.net, gatos drivers and of course drivers from 4.3.0).
Should I post it to xfree mailing list or this is a problem related to Blender?

tia and greets
freetz

Michel
Posts: 208
Joined: Wed Oct 16, 2002 7:27 pm
Location: Somewhere below the rivers in Holland (but not Limburg)

Postby Michel » Mon May 12, 2003 11:55 am

Hi,

today I saw a mail on the mailing list that had a solution in it. There seems to be a problem in the GHOST library of Blender. This person had already checked with the DRI guys, and they tracked the problem down to Blender :)
If this indeed is the solution to many of the crashes, then I guess this will make it in the 2.27 release :D
Unfortunately I cannot check this because I have a Radeon 9700. In XFree 4.3.0 only 2D accelleration is supported and no 3D :cry: . I hope this is resolved in the next version of X.

With regards,
Michel


Return to “Coding Blender”

Who is online

Users browsing this forum: Google [Bot] and 1 guest