VSE Plug-ins

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

mrmeebles
Posts: 2
Joined: Tue May 03, 2011 6:02 pm

VSE Plug-ins

Postby mrmeebles » Tue May 03, 2011 6:34 pm

Hello,

I use Blender exclusively to edit movies and I've written several plug-ins. With the new version of blender (2.57b x86_64 on Ubuntu Linux) I can't seem to add any plug-ins. Every time I get the same error:

var1: /video/HDV/48 Hour Film II/A cam footage I/, var2: /video/HDV/48 Hour Film II/A cam footage I/, var3: /video/HDV/48 Hour Film II/A cam footage I/: cannot read file data: Is a directory

(/video/HDV/48 Hour Film II/A cam footage I/ is the directory where the video clip was stored to which I was trying to add a plug-in)

When I try to load .blend files from a 2.4 version of Blender I get this error:

var1: , var2: plugin_seq_getversion, var3: ./blender: undefined symbol: plugin_seq_getversion

and the output of all the filters is just a black screen. Also in general, it's obvious the interface has changed and I assume I will have to change the code of all my plug-ins, but the new api doesn't seem to be documented anywhere. In fact it seems that nothing about the changes to the VSE has been documented anywhere. I've tried to search for this information with no luck. Thanks in advance for any help or suggestions.

skurdakov
Posts: 62
Joined: Thu Sep 02, 2010 12:23 pm

Re: VSE Plug-ins

Postby skurdakov » Wed May 04, 2011 8:08 pm

if your plugins are for 2.4 and did not work in any 2.5 beta - then the problem is
that python version in blender and API has changed.
so code should be rewritten.

in case you tested in 2.5 betas - then say which 2.5 version worked for you and then maybe someone will be more close to your problem, than I'm

mrmeebles
Posts: 2
Joined: Tue May 03, 2011 6:02 pm

Re: VSE Plug-ins

Postby mrmeebles » Wed May 04, 2011 8:21 pm

skurdakov wrote:if your plugins are for 2.4 and did not work in any 2.5 beta - then the problem is
that python version in blender and API has changed.
so code should be rewritten.


Thank you for replying. My plugins were all written for 2.4 and I didn't try them with any of the betas, this is my first try with 2.5. I realize that the api has changed, but I can't seem to find it documented anywhere. Do you know where I can find out (other than hunting through the source code myself)?


Return to “Coding Blender”

Who is online

Users browsing this forum: No registered users and 2 guests