Blender Game Engine EXE Question

Game Engine, Players & Web Plug-in, Virtual Reality, support for other engines

Moderators: jesterKing, stiv

lightstream22
Posts: 7
Joined: Mon Aug 15, 2011 5:32 pm

Blender Game Engine EXE Question

Postby lightstream22 » Tue Aug 16, 2011 11:04 pm

Hello All,

I am trying to make an EXE executable file of my game. I am using Blender 2.58.1, on a windows xp 64bit machine. I can save a game engine runtime file alright, and the exe file loads ok. However, when I load the exe, the environment that I created in blender does not match, or look the same, in the executable. For example, several buildings (that were in the .blend file) just up and disappeared in the executable!

I was wondering if this may have been due to appending (since I appended the building into my .blend file), but I'm not sure. Can anyone help me?

I can provide more info, if needed!

Trafulgoth
Posts: 5
Joined: Tue Aug 16, 2011 8:07 pm

Postby Trafulgoth » Tue Aug 16, 2011 11:12 pm

You need to pack all the data if you haven't already. The BGE doesn't support procedural textures, so if you used any they'll disappear whenever you run the game. Also, make sure everything has a material. I don't know if any of that was the problem but good luck.

EDIT: to pack the data, go to file->external data->pack into .blend

lightstream22
Posts: 7
Joined: Mon Aug 15, 2011 5:32 pm

Postby lightstream22 » Fri Aug 19, 2011 5:22 pm

Thanks Trafulgoth,

Unfortunately it is not a packing issue - just tried that. I have a feeling that it is related to objects disappearing at the edge of the camera. (See this post: http://blenderartists.org/forum/showthr ... +disappear).

Does anyone know what the solution might be to this?


Return to “Interactive 3d”

Who is online

Users browsing this forum: No registered users and 0 guests