Mysterious and Severe Crash on XUbuntu

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

darenw
Posts: 29
Joined: Sun Jan 17, 2010 7:37 pm

Mysterious and Severe Crash on XUbuntu

Postby darenw » Mon Nov 21, 2011 3:54 am

Dowloaded and ran 2.60, but it crashed on my current project. Saw 2.60a, hoped it fixed some bug my project was tickling, but it crashed. Tried 2.59, 2.58 - crashed.

So far, only my one .blend file (or copies of it) crash. This happens usually with a right mouse click after several seconds to minutes of switching between Edit and Object modes, switching objects between layers, and moving objects around. It's not reproducible in detail, but a fairly reliable crash after some fooling around doing just those operations. There's no editing of the mesh; I only go into Edit mode, maybe rotate the viewpoint, and go out. When it crashes, poof, it's all gone instantly about 3 out of 4 times. Other times, Blender's GUI totally freezes. Window manager can still do its usual things, but can't close the app.

The default cube scene doesn't crash, no matter how long I play with it.

Did svn checkout of trunk, built, and it crashed. I built this as a debug version (cmake, not scons) and ran in gdb. When it crashed, gdb only showed a backtrace of several hex addresses, no symbols. Couldn't tease any info out of it. I'm pretty experienced with C++ and gdb and such, but I'm not necessarily as smart as I usually am every day

What can I do to get more information from these crashes? Are there known bugs like this? The .blend file is about 560K bytes.

I'm running said versions of Blender on 64-bit XUbuntu, up to date. I don't have other machines or distros available to try.
DSW

darenw
Posts: 29
Joined: Sun Jan 17, 2010 7:37 pm

Re: Mysterious and Severe Crash on XUbuntu

Postby darenw » Mon Nov 21, 2011 4:05 am

I copied the offending .blend file to http://www.darenscotwilson.com/demo/ which should show a directory listing.
DSW

stiv
Posts: 3646
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Postby stiv » Mon Nov 21, 2011 5:02 am

I built this as a debug version (cmake, not scons) and ran in gdb. When it crashed, gdb only showed a backtrace of several hex addresses,


If this is actually a debug build, it will show symbols where it is crashing, UNLESS the fault is happening in a system lib, such as opengl. Even then, the backtrace would be interesting.

ldo
Posts: 544
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Postby ldo » Sat Feb 25, 2012 3:33 am

Downloaded your .blend file, tried switching several times between Object and Edit modes, lots of right-clicks all the while, no sign of any crash.

I’m running a 2.62+ build from a repo checkout about 5 days ago, my system is Debian Unstable AMD64.


Return to “Testing Builds”

Who is online

Users browsing this forum: No registered users and 1 guest