Bug? Export to OBJ fails with empty file.

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

rioki
Posts: 2
Joined: Tue Nov 20, 2007 4:49 pm

Bug? Export to OBJ fails with empty file.

Postby rioki » Fri Dec 30, 2011 5:35 pm

Hello,

I recently upgraded Blender from 2.46b to 2.61. (Yes, I am slow.) I uninstalled the old version and installed the new one afterwards.

I created some programmer art for my a little demo and I can't get it to export to OBJ. The OBJ file is created but empty; all it contains is the banner comment and the mtllib entry. I tried fiddling around with the settings but no success.

I can properly export the mesh to STL and ply. Oddly I when I import some meshes from OBJ I am able to export them back to OBJ.

Did something not so obvious change or is this a bug?

For reference the blend file can be found here:
http://files.rioki.org/bugs/blender/column.blend

rioki
Posts: 2
Joined: Tue Nov 20, 2007 4:49 pm

Working around with ply

Postby rioki » Sun Jan 08, 2012 12:51 pm

Nice to know that the blender community is still as responsive as 5 years ago...

I "solved" the problem by implementing a ply parser for my game engine. One more feature, for my engine; but not cool though!

ldo
Posts: 544
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Postby ldo » Thu Jan 12, 2012 12:28 pm

Works fine if I delete the object you included and insert another one.

ldo
Posts: 544
Joined: Sun Nov 07, 2010 11:30 pm
Location: Hamilton, New Zealand

Postby ldo » Fri Jan 13, 2012 12:30 pm

Solved it: your sample object has “Duplication: Faces” turned on for some reason. Turn that off and it exports OK.

Though I should note the normals look screwed up.


Return to “Coding Blender”

Who is online

Users browsing this forum: No registered users and 0 guests