Blender not using all 8 cores of my FX-8350

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

Posts: 2
Joined: Fri Dec 14, 2012 4:10 am

Blender not using all 8 cores of my FX-8350

Postby CrissCrow » Fri Dec 14, 2012 4:30 am

I upgraded my cpu to help reduce render time in blender buying the AMD FX-8350 having been using a amd 945 x4 cpu and it seems now blender is using just one core,

even though I have the threads set to 8, it was on auto it setting it to 8 but I read when you use 8 cores or more then one, blender should be rendering images, baked textures in 8 blocks at once, yet when I"m watching it render, its rendering it in one block,

Is there something else that needs to be set, checked or unchecked some where in the settings or how do I get blender to use all 8 of my cpu's cores?

Task manager says, while rendering, that only 15% to maybe 20% of my cpu is being used.

Thanks for the help!

Posts: 2
Joined: Fri Dec 14, 2012 4:10 am

Postby CrissCrow » Fri Dec 14, 2012 10:13 pm

Sorry, posted that late I guess I should of given more info

here is my system spec

Mobo: AsRock 990FX Extreme3
CPU: FX-8350 8x 4.0ghz
Ram: 8Gb ddr3
GPU: HD-6950 2gb
OS: Windows 7 64-bit

From what I understand when blender is using all 8 cores is suppose to be rendering 8 tiles at once but when ever I see it rendering in the uv window, rendering baked textures, its rendering the whole thing as one tile unless there are many faces on the unrwrap image but even then there are no speed improvements.

I've used a stopwatch to figure out how long my renders take and they take between 3 and a half minutes all the way to 16 minutes I know that's not a lot but I think I was rendering faster with my old 4 core cpu running at 3.0ghz.

Also I notice in my setting under compute device, my only option is CPU, I head most use GPU under that option but I don't have GPU as an option there and only get CPU as an option there. Oh and my drivers are up to date.

Also under performance, where you set the thread count, I have it all set as follow...

Threads: 8
Tile Size:
X: 256(Not sure what this should be set to, I'm rendering images at 1024 x 1024)
Y: 256( Not sure what this should be set to, I'm rendering images at 1024 x 1024)

Save Buffers [Unchecked]
Free Image Textures [Unchecked]
Free Unused Nodes [Unchecked]

Acceleration sturcture
Instances [Checked]
Local Coordinates [Unchecked]

Post Processing

Compositing [Checked]
Sequencer [Checked]
Dither: 0.000

Fields [Unchecked]
Edge [Unchecked]
Rest is greyed out

When I had my old cpu in and was rendering task manager always showed that 100% of it was being used but now when I'm rendering with my new cpu, it might jump to 22% for a second or two but usually stays at around 12 to 15% and its only the first core that seems to be running the closes to 100%, it does show that the other cores are active but no more then 10 to 20%

Posts: 1
Joined: Sun Jan 20, 2013 11:41 am
Location: Ukraine

Postby maxdudik » Sun Jan 20, 2013 11:55 am

According to Blender Cycles Benchmark it's seems an issue with multithreading in Windows 7. Find and compare rows of user Jonatas - and you'll see.
What about GPU - go to Blender User preferences (Ctrl+Alt+U), on tab System chose Compute Device (CUDA) then Save.

Return to “Rendering”

Who is online

Users browsing this forum: No registered users and 1 guest