Previous Thread  Next Thread

chat icon python not installed error.xplane2blender script not working

adamjedgar

Posted: Thu Aug 23, 2012 6:30 am
Joined: 13 Apr 2012
Posts: 5
hi guys,

I am using xplane2blender script.

when I attempt to run blender and import an object from xplane - planemaker, the aircraft doesn't show up.

I notice that when I try to install xplane2blender I get a message saying I don't have python installed. I installed python but im still not able to get the planemaker import function to work properly and the cmd window running in the background for blender still keeps saying I don't have python installed.

what am I doing wrong

running blender version 2.49b
python 2.7.3
xplane2blender 3.1r1
win8 x64 bit
Reply with quote


stiv

Posted: Thu Aug 23, 2012 5:45 pm
Joined: 05 Aug 2003
Posts: 3645
When old blender starts up, it prints a message to the console about which of python it was compiled with. (run from the command line if necessary). *THIS* is the version of python you need to install.

Any additional python modules you install for blender must use this version of python.

Note: new blender comes with its own copy of python 3.2, so no additional install is necessary.
Reply with quote


adamjedgar

Posted: Thu Aug 30, 2012 10:19 am
Joined: 13 Apr 2012
Posts: 5
stiv wrote:
When old blender starts up, it prints a message to the console about which of python it was compiled with. (run from the command line if necessary). *THIS* is the version of python you need to install.

Any additional python modules you install for blender must use this version of python.

Note: new blender comes with its own copy of python 3.2, so no additional install is necessary.


Ah i see. The python website seems to only show current version. How do i get old versions of python?
Reply with quote


stiv

Posted: Thu Aug 30, 2012 5:20 pm
Joined: 05 Aug 2003
Posts: 3645
Download old Python releases from python.org. They are around there somewhere.

You want the major version (like 2.6) to match. Don't worry about the minor number (like 2.6.x). just get the latest in that series.
Reply with quote


 
Jump to:  
Powered by phpBB © 2001, 2005 phpBB Group