BLUSTER: Blender + Clustering

An open space where people who use Blender in an academic environment can share progress and the typical problems and needs of academic environments.

Moderators: jesterKing, stiv

Posts: 3
Joined: Sun Jan 01, 2012 3:04 pm

BLUSTER: Blender + Clustering

Postby GrahamLeach » Sun Jan 01, 2012 4:16 pm


I am in the process of putting together a couple of Blender Clusters at the Multimedia Lab (M-Lab) connected to the School of Design at The Polytechnic University of Hong Kong (POLYU).

Right now we are playing with two clusters.

The small cluster is composed of four machines. It is being constructed and documented to help us understand how to get a basic Blender Cluster going. Why four? Because it is physically small enough to work on without too much walking around and because that's what's available at the moment.

The large cluster is going to be composed of a lot more machines. At the moment, it is composed of eight machines and is being configured as a video wall running MIT's PROCESSING language.

The large cluster project is called WALL:

I have rounded all of the required hardware from extra gear hanging around the lab: Computers, switches, power bars, cabling, far both clusters are physically implemented and both are running just fine. By this I mean that there were absolutely no problems with the physical installation of the machines except for a couple of very small and easily rectified incidents (mostly bad cables)

The smaller cluster was the focus today. I installed UBUNTU 11 on the constituent machines. I did this by downloading the UBUNTU 11 ISO directly from the UBUNTU website. Then I used a free tool called CDBURNERXP to create a bootable DVD from the .iso file. Yes, the CDBURNERXP tool burns DVD as well as CD.

The first DVD did not work right. The media was burned at too high a speed and the installation of the first machine failed with a media error. I didn't even try to diagnose the problem, I just burned another DVD at a slower speed. The second DVD was a success.

The UBUNTU 11 install went very smoothly with no real problems whatsoever except for the fact that the machines often needed a hard reset once the installation script had finished. It was a very rare event that any of the machines actually rebooted properly on <ENTER> once they had ejected their DVD.

During the install, I didn't bother to do anything but a really, really minimal installation. Once the machines had rebooted and loaded the UBUNTU desktop, I simply started a terminal session and executed the following instruction to update the machine

Code: Select all

sudo apt-get update

Once each of the machines had updated itself, I moved on. Later I may need to revisit the boxes to make sure I can SSH into them, but I'll worry about that later once it's been determined that they are inaccessible. The cluster is so small I just have a monitor + keyboard + mouse bundle that I swap from machine to machine if I want to get at the console.

The small cluster project is called EXTRA:

I would like to continue to document my experience with BLUSTER at this venue if such information is welcome here?

I personally welcome any hints, tips, tricks, HOWTO (no matter how old) that others who have already walked this path may have to offer to help smooth my way and those who will follow me.

I will also be documenting my experience at, just in case this venue ever ceases to exist.

Thank you,

Graham Leach

Posts: 3646
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Postby stiv » Sun Jan 01, 2012 4:45 pm

I would like to continue to document my experience with BLUSTER at this venue if such information is welcome here?

Feel free! It sounds like an interesting project and real-world experience is always valuable.

Posts: 3
Joined: Sun Jan 01, 2012 3:04 pm

Postby GrahamLeach » Tue Jan 03, 2012 4:51 am


I am happy to say that BLUSTER is up and running. The process was so simple, I'm almost embarrassed to describe the steps required.

Here they are:

- Install UBUNTU
(I used a bootable DVD)

- Update UBUNTU
#sudo apt-get update

- Assign STATIC IP
(I used the applet within UBUNTU desktop)

- Install SSH SERVER
#sudo apt-get install ssh-server

#sudo apt-get install jre

- Install BLENDER
#sudo apt-get install blender

- Install LOKI
(I downloaded the .zip from the Loki website)

That's it!

At that point I connected the machines together (all as grunts, one as master) then downloaded some test BLENDER files and started rendering.

I think that if I was asked to do this again I would be able to put a cluster together in a half day or short afternoon.

If anyone was hesitating about getting a BLUSTER together because of a perceived sense of complexity...hesitate no more!

I will be hosting a step-by-step discussing this project (EXTRA) at:

Graham Leach

Posts: 1
Joined: Thu Feb 02, 2012 4:56 pm
Location: Vienna

Postby peacememories » Thu Feb 02, 2012 4:58 pm

This sounds really interesting and I'd like to try that too (especially since a friend of mine has access to a 36 node cluster for the rest of the month)

I can't seem to find any info on Loki, though. Could you point me in the right direction?

Posts: 1
Joined: Tue Oct 02, 2012 5:54 pm

Loki Render

Postby cactipus » Tue Oct 02, 2012 5:55 pm

Loki can be downloaded from
Octopodes > Octopus
Cactipodes > Cactipus
It just makes sense.

Return to “Academic & Research”

Who is online

Users browsing this forum: No registered users and 2 guests