Emission Shader in Cycles seems to clamp Strength Value

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

aliasguru
Posts: 2
Joined: Mon Oct 29, 2012 5:06 pm

Emission Shader in Cycles seems to clamp Strength Value

Postby aliasguru » Mon Oct 29, 2012 5:12 pm

Hello all,

First of all greetings to everyone here in the forum and thanks for developing this great tool!

I stumbled across an issue which is somewhat strange: I create an arbitrary scene, add a plane and assign an emission shader to it. When I change the strength value to something between 0 and 2, I see an immediate effect, just as it should be. But if I increase the strength to 500 or even 50000000, I can't see any difference any more, the lighting in the scene remains too weak. It seems like cycles is clamping the input value.

I'm rendering with cycles and confirmed this with Blender versions between 2.63 and the latest OpenMP branch (2.64.6).

Any suggestions?

aliasguru
Posts: 2
Joined: Mon Oct 29, 2012 5:06 pm

*solved*

Postby aliasguru » Mon Oct 29, 2012 9:08 pm

Hey there,

A classic case of PEBKAC (problem exists between keyboard and chair):

In my Render Settings under the "sampling" tab, I had "clamp" set to a non-zero value. Thus, any color value in the image above a certain value would of course be clamped. Accidentally I had also saved this to my user profile. I was not aware of the fact that this also applies to the emission shader, as the clamp option is normally used to reduce artifacting.

Thanks anyways,

Rainer


Return to “Rendering”

Who is online

Users browsing this forum: No registered users and 2 guests