Previous Thread  Next Thread

chat icon Help to compile on windows 7 x64 VS2010

zsnow

Posted: Wed Nov 21, 2012 1:01 pm
Joined: 21 Nov 2012
Posts: 2
Hi . I'm a newbie for blender dev.
If anyone could point me how to successfully compile a build on win7 x64 with vs2010?

Here is what i did:
1:svn the latest code from https://svn.blender.org/svnroot/bf-blender/trunk/blender.
2:svn the latest lib from https://svn.blender.org/svnroot/bf-blender/trunk/lib/win64
3:it seems the boost missing a few libs. so I downloaded the boost_1_49_0, extracted, and copy lib\win64\boost folder over it. run build.bat. to recompile boost to get all the boost libs and move it to the "lib\win64\boost\vc2010\lib" folder
4:use cmake-gui to make a build directory. configure it and generate. I use default.
5:open the blender.sln in vs2010 and build.
6:the missing boost lib error seems gone after i recompile the boost on step 3, but now it give me several errors on openimageIO.lib
something like
Code:
OpenImageIO.lib(image input.cpp.obj) : error LNK2001: unresolved external symbol


Does blender support vs2010 to compile? anyone could give a tutorial on how to compile the code on vs2010?

thank alot.

Yang
Reply with quote


stiv

Posted: Wed Nov 21, 2012 6:09 pm
Joined: 05 Aug 2003
Posts: 3645
As I understand, VS 2010 is not as well supported as 2008. You may need to either install the libs yourself, or turn off the missing features.

The 2010 libs are not in SVN because they are HUGE.
Reply with quote


zsnow

Posted: Fri Nov 23, 2012 2:04 pm
Joined: 21 Nov 2012
Posts: 2
stiv wrote:
As I understand, VS 2010 is not as well supported as 2008. You may need to either install the libs yourself, or turn off the missing features.

The 2010 libs are not in SVN because they are HUGE.


thanks , I will try compile in vs2008.
Reply with quote


 
Jump to:  
Powered by phpBB © 2001, 2005 phpBB Group