Blender, Python and Nif scripts

Scripting in Blender with Python, and working on the API

Moderators: jesterKing, stiv

amd908
Posts: 2
Joined: Fri Nov 30, 2012 8:08 am
Location: Philippines

Blender, Python and Nif scripts

Postby amd908 » Fri Nov 30, 2012 8:26 am

Ok, so I'm very new to using blender(I started using it just 3 days ago). One of the reasons I wanted to use it is for making mods in Skyrim like custom armors. I discovered that I needed to install Python, PyFFI and Nif scripts but I can't install the Nif scripts because I think it wants me to use Blender 2.49b which I tried to install but I'm unfamiliar with the interface because I started to use version 2.64 and I hated the old interface. Can someone please tell how to fix this problem. Does the latest version of blender come with python and if not what version of python should I get for blender 2.64? what version of PyFFi should I get? Is the Nif scripts even compatible with Blender 2.64? Please help me :(

CoDEmanX
Posts: 894
Joined: Sun Apr 05, 2009 7:42 pm
Location: Germany

Postby CoDEmanX » Fri Nov 30, 2012 8:46 am

Blender 2.6x comes with its own python, version 3.2 (have a look at the blue text in PyConsole, Scripting view!)

PyFFI seems to be compatible with Python 3.x: https://github.com/amorilia/pyffi/blob/develop/setup.py

Dunno anything about Nif...
I'm sitting, waiting, wishing, building Blender in superstition...

amd908
Posts: 2
Joined: Fri Nov 30, 2012 8:08 am
Location: Philippines

Postby amd908 » Fri Nov 30, 2012 9:07 am

CoDEmanX wrote:Blender 2.6x comes with its own python, version 3.2 (have a look at the blue text in PyConsole, Scripting view!)

PyFFI seems to be compatible with Python 3.x: https://github.com/amorilia/pyffi/blob/develop/setup.py

Dunno anything about Nif...



Thanks for the reply but what exactly is the version of PyFFI that I should download?


Return to “Python”

Who is online

Users browsing this forum: No registered users and 6 guests