Python script error: Check console.

Scripting in Blender with Python, and working on the API

Moderators: jesterKing, stiv

Astra
Posts: 2
Joined: Wed Jan 02, 2013 1:04 am

Python script error: Check console.

Postby Astra » Wed Jan 02, 2013 1:11 am

I have Blender 2.49b and Python 26

i need help.

http://i46.tinypic.com/2zj04yf.png

Tehrasha
Posts: 1264
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Postby Tehrasha » Wed Jan 02, 2013 1:27 am

Given the 'bad version' in the error message, my guess is that your elu_import script is not made for your version of Blender.
Spacemice Wiki -- Input devices for a 3D world.
Spacemice / Blender Compatibility

Astra
Posts: 2
Joined: Wed Jan 02, 2013 1:04 am

Postby Astra » Wed Jan 02, 2013 1:51 am

[quote]
Given the 'bad version' in the error message, my guess is that your elu_import script is not made for your version of Blender.[/quote]


http://www.gamerzneeds.net/forums/gunz- ... files.html
I did everything they said. im using windows 7 with x86. is that a problem?

Tehrasha
Posts: 1264
Joined: Wed Apr 21, 2010 6:21 am
Location: Iowa

Postby Tehrasha » Wed Jan 02, 2013 2:47 am

Ah... the error refers to this line in the script...

Code: Select all

        if version not in ELU_VERSIONS and version not in ANI_VERSIONS:
            raise VersionError, "Bad version number %d" % version


Looks like it is looking for a specific version value within the .elu/.ani file.
It is quite possible that Gunz has made changes since 2009 which make the script fail.
Spacemice Wiki -- Input devices for a 3D world.

Spacemice / Blender Compatibility


Return to “Python”

Who is online

Users browsing this forum: No registered users and 2 guests