bf-blender / Windows (2004/01/12)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

bf-blender / Windows (2004/01/12)

Postby jesterKing » Sun Jan 11, 2004 11:38 pm

Todays CVS Build:

This CVS build has been obsoleted by a newer build

Virus warning removed For a while there has been a potential virus warning, but reports of scans by other users convinced me there is no virus in the build. So go ahead and enjoy as before :)

http://www.letwory.net/cvsbuilds/bf_blender_windows_20040112.zip

Again, this is build with the SCons, using MSVC7 as the compiler. It has TTF, International, Quicktime and OpenAL support compiled in. There is still no game-engine, but we hope to get it enabled at some point, though (keep the faith! and test/explore other features in the meantime).

Number of commits since previous build:
* 8+3 commits
* last commit 2004/01/11 23:15:24 CET +
2004/01/12 03:46:14 CET


Tthe relevant parts from the CVS commit logs:

* (bug fix) interface DELKEY fixed for text input buttons .
* (progress) interface Changed headerprintf for wrap transform.
* (bug fix) subsurf Potential bug in simple subsurf.
* (progress) source Clean up of edge select code.
* (bug fix) interface Stop artifacts in displace preview.
* (bug fix) texture Fixed weird behaviour when using lamp textures with material textures.
* (bug fix) interface Fix for cubemap, rendered without render face (preview render and displaylist).
* (bug fix) file loading Fix bug in file loading, where text would be grey (according to Ton a historical commit!)
* (bugfix) posing Fix for the "blender's bone constraints don't work in pose mode when you merely move the parent of a constraint subtarget" bug.

This CVS build has been obsoleted by a newer build

Enjoy!

/jesterKing
Last edited by jesterKing on Mon Jan 12, 2004 11:24 pm, edited 6 times in total.

blinblin
Posts: 6
Joined: Fri Dec 12, 2003 2:42 am
Location: france

Re: bf-blender / Windows (2004/01/12)

Postby blinblin » Mon Jan 12, 2004 1:25 am

jesterKing wrote:This build was a little late,


12:38 am, by 'little' late you mean 38 minutes late ? :D
thanks again.

Caronte
Posts: 521
Joined: Wed Oct 16, 2002 12:53 am
Location: Valencia-Spain-Europe

Postby Caronte » Mon Jan 12, 2004 1:25 am

It's just me or the specular highlight is lost with displacement activated? :?
Caronte.
"Some Day, All Will Be Digital"
http://www.nicodigital.com

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Mon Jan 12, 2004 6:22 am

Eh, the build being late was a c&p bug :) Which shows it was late for me. (And now it's a little early :D

Anyways, build updated with no less than two bug fixes!

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Potential virus warning!!

Postby jesterKing » Mon Jan 12, 2004 8:42 am

potential virus warning

A user in #blenderchat told me that a zip provided by me might contain a virus, as during a scan he found one.

I'm pretty sure I have no viruses, but as I'm now at work I have no means to check on that (zip originated from my homecomp) right now. I use a virus scanner on that machine and I check in the morning and evening/night for virus updates.

Until now my machine has not been infected.

If you have dl'ed one of my zips, please check for viruses. If you do find one, please report in this thread. State in your reply what .zip (CVS build) you found the virus in, and what virus it is. Don't bother to report if blender.exe is not infected (the virus was probably already there).

I still leave the CVS build online, but be sure to scan it, and ditch it whenever you find it infected. And please, report.

I'm terribly sorry for the (potential) inconvenience, I'll be checking the build machine in the evening!

/jesterKing

PS. This may be also a false alarm, but I want to be sure

dotblend
Posts: 72
Joined: Thu Oct 17, 2002 2:18 pm

Postby dotblend » Mon Jan 12, 2004 9:38 am

i scanned it and it contained no virus (norton)

but i think also discovered a bug...
displacement mapping does not work with meta balls!

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Mon Jan 12, 2004 9:44 am

Thanks dotblend for reporting! A relieve to see that. I leave the warning up, though. I want to get more reports like yours! :) About metaballs, I don't know, but I asked in IRC, now waiting for response.

/jesterKing

lucasgg
Posts: 1
Joined: Mon Jan 12, 2004 10:43 am

Postby lucasgg » Mon Jan 12, 2004 11:03 am

jesterKing wrote:Thanks dotblend for reporting! A relieve to see that. I leave the warning up, though. I want to get more reports like yours! :) About metaballs, I don't know, but I asked in IRC, now waiting for response.

/jesterKing


I've not found any viruses in this build.

--
regards
Lukasz G.

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

virus warning removed - false alarm

Postby jesterKing » Mon Jan 12, 2004 11:11 am

Thanks for the reports. I am removing the virus warning. I'm now pretty sure that there are no virus in the .zip!

/jesterKing

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Mon Jan 12, 2004 11:49 am

Dotblend: confirmed, metaball displacement doesn't work (crashes for me when rendering). It has been told to the developers. Thanks for the report.

/jesterKing

dotblend
Posts: 72
Joined: Thu Oct 17, 2002 2:18 pm

Postby dotblend » Mon Jan 12, 2004 1:38 pm

another displacement bug
http://www.dotblend.com/blenderbugs.htm

scenefile included

Guest

Postby Guest » Mon Jan 12, 2004 5:45 pm

Is there any place I can get a text file for translation like:

subsurface = subsur
animate = anim
raytrace = ray
etc ...

There's few languages I wanted to include ...

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Mon Jan 12, 2004 11:25 pm

This CVS build has been obsoleted by a newer build


Return to “Testing Builds”

Who is online

Users browsing this forum: No registered users and 2 guests