bf-blender / Windows (2004/01/21)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

bf-blender / Windows (2004/01/21)

Postby jesterKing » Wed Jan 21, 2004 10:30 am

Todays CVS Build:

This CVS build has been obsoleted by a newer build

http://www.letwory.net/cvsbuilds/bf_blender_windows_20040121.zip

Again, this is build with the SCons, using MSVC7 as the compiler. It has TTF, International, Quicktime and OpenAL support compiled in. The ODE-powered gameengine is now available, no Solid yet. The build has been scanned for viruses and is found to be clean.

Number of commits since previous build:
* 7 commits
* last commit 2004/01/21 10:05:17 CET

The relevant parts from the CVS commit logs:

* (bug fix) Python API fixed script hanging Blender, when a script fails
* (bug fix) render fixed displacement hollow vs. solid.
* (bug fix) layer/bones Fixed the "bones on invisible layers, that are constrained to objects on
visible layers, don't move during transform()" bug.
* (progress) Python scripts The default location for scripts has changed to ~/.blender/scripts, and the userpref dir will be searched, too, if set.
* (bug fix) Python scripts Trailing slash peculiarity fixed.

This CVS build has been obsoleted by a newer build

Enjoy!

/jesterKing
Last edited by jesterKing on Fri Jan 23, 2004 9:34 am, edited 2 times in total.

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Scripts update

Postby jesterKing » Wed Jan 21, 2004 10:40 am

Hups, I forgot to update the scripts, fixed now.

/jesterKing

blendix
Posts: 133
Joined: Wed Oct 16, 2002 1:00 pm

Postby blendix » Wed Jan 21, 2004 12:48 pm

I think it's great your providing these builds here daily (altough I build my own), but I have a suggestion to make. You only post the changes since the last build, but if you don't follow up the builds day by day, they don't say much. Would it be possible to also list the most important new features since the last blender release (raytracing, displacement mapping, python scripts in menu's, ...). The information provided now is kind of technical, and expects quitte some familiarity with the internal blender development.

Erufailon
Posts: 28
Joined: Wed Jan 07, 2004 11:48 am

Postby Erufailon » Wed Jan 21, 2004 1:06 pm

The whole point is to make available the new stuff since yesterday as development speeded up big time, and also to have them tested. I wouldn't expect him to write lengthy posts everyday for those who are new to this.

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Wed Jan 21, 2004 1:08 pm

@ blendix: I'll take it in consideration. The first time for me to include a more extensive list would be fridayish, but I think it is a nice idea.

/jesterKing

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

python scripts

Postby jesterKing » Wed Jan 21, 2004 1:15 pm

Contrary to what was meant, it seems that Blender now expects the scripts to be in installdir/.blender/.blender/scripts. This is obviously wrong, so it'll be addressed as soon as possible.

/jesterKing

Monkeyboi
Posts: 561
Joined: Tue Nov 26, 2002 1:24 pm
Location: Copenhagen, Denmark
Contact:

Postby Monkeyboi » Wed Jan 21, 2004 3:05 pm

Contrary to what was meant, it seems that Blender now expects the scripts to be in installdir/.blender/.blender/scripts. This is obviously wrong, so it'll be addressed as soon as possible.

/jesterKing



Yes it didn't work for as expected either. Even when I inserted some registered scripts into the scripts folder, they don't appear inside Blender when I execute it.


PS
By the way, does anyone know which (if any) scripts will be available in the official release version? I hope an improved version of the .obj import script will get in (so that you can just use it by going to File>>Import).

soletread
Posts: 83
Joined: Fri Jan 10, 2003 7:11 pm

Postby soletread » Wed Jan 21, 2004 7:42 pm

The NLA is still not working.

(The BLENDIN is not working as it should. A 20 frame blendin on an action strip will not register at all and the action will only begin after these 20 frames have passed...)

cheers

gabio
Posts: 618
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Postby gabio » Thu Jan 22, 2004 2:50 am

Monkeyboi wrote:
PS
By the way, does anyone know which (if any) scripts will be available in the official release version? I hope an improved version of the .obj import script will get in (so that you can just use it by going to File>>Import).


I hope The official release will have a lot of python script in it. What a great thing to install an application and every feature is in there ready to run. A good example: the script-fu of gimp. In blender for Example Beast will be such a major feature...
Hope. :roll:

Ghost
Posts: 20
Joined: Wed Nov 12, 2003 2:56 pm
Location: Copenhagen, Denmark

Postby Ghost » Thu Jan 22, 2004 11:48 am

soletread wrote:The NLA is still not working.

(The BLENDIN is not working as it should. A 20 frame blendin on an action strip will not register at all and the action will only begin after these 20 frames have passed...)

cheers


I don't have any problems with the blendin on NLA's. Could you post a .blend with the problem?
BTW: Have you tried motionblender.blend from the old NAN demofiles. You can find it here:

http://download.blender.org/demo/demo225.zip

Regards
Kasper

Hos
Posts: 215
Joined: Wed Oct 16, 2002 12:06 am

Postby Hos » Thu Jan 22, 2004 4:13 pm

I think this would be a good time to remind folks that
this forum is *not* the bug tracker.

Also, reports like 'The NLA is still not working' is
not very helpful ... does 'still' mean since Blender 2.31?
Since 2.25? Since Tuesday? Don't forget to
mention what OS and graphics card you are using
... now go to the tracker!

Chris

soletread
Posts: 83
Joined: Fri Jan 10, 2003 7:11 pm

Postby soletread » Thu Jan 22, 2004 9:06 pm

Ghost:

Thanks for the lead. I downloaded the demos and yes, the motionblender.blend file works fine. However there IS a problem in the NLA. I have a blend file that works with 2.31 official realease and in tuhopuu. I need webspace to post unfortunately.

Hos wrote:

I think this would be a good time to remind folks that
this forum is *not* the bug tracker.


This is what I got from this forum intro:

If you have feedback, problems, bug reports or any other information that's relevant, please post it as a reply to the topic that you downloaded the build from.


I am confused and I thought the bugtracker was for official releases only? And that would make sense because bugs can be applicable to this build only.

This forum is slightly different to the others on this site in that individual topics are actually connected and posts in one actually follow in the next. Hence comments like this:

'The NLA is still not working'


Should be acceptable due to the fact that a more detailed post was submitted twice before this one.

Now where do I go to get this problem seen to?

Cheers

Hos
Posts: 215
Joined: Wed Oct 16, 2002 12:06 am

Postby Hos » Thu Jan 22, 2004 10:16 pm

soletread wrote:Ghost:
This is what I got from this forum intro:

If you have feedback, problems, bug reports or any other information that's relevant, please post it as a reply to the topic that you downloaded the build from.


I am confused and I thought the bugtracker was for official releases only? And that would make sense because bugs can be applicable to this build only.

This forum is slightly different to the others on this site in that individual topics are actually connected and posts in one actually follow in the next. Hence comments like this:

'The NLA is still not working'


Should be acceptable due to the fact that a more detailed post was submitted twice before this one.


Fair enough, but please know that I do not read this
forum every day to see every post in every thread.

soletread wrote:Now where do I go to get this problem seen to?
Cheers


Maybe here:

http://www.amazon.com/exec/obidos/tg/de ... 33-2233600

Chris

gabio
Posts: 618
Joined: Thu Jan 15, 2004 6:41 am
Location: Canada - Québec - Sherbrooke
Contact:

Postby gabio » Fri Jan 23, 2004 5:45 am

I don't know how you are doing you daily compile with scons.
(edit) But it's a great idea and Big thank you for that.
I tried some much but it always retourn the same error:

blender_FTF.lib(FTF_TTFont.obj) : error LNK2001: unresolved external symbol "__d
eclspec(dllimport) public: int __thiscall FTFont::Error(void)const " (__imp_?Err
or@FTFont@@QBEHXZ)
blender.exe : fatal error LNK1120: 1 unresolved externals
scons: *** [blender.exe] Error 1120
scons: building terminated because of errors.

I know it's the ftgl but the lib are already in the source doesn't it? and scons is supposed to work first hand. or is something i forgot to do?
-python 2.2.3
-scons for windows
-qtdevwin move to lib\windows
-The daily checkout with winCVS.
-msvc 6.0 sp5 (i don't know if it's used anyway)

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Fri Jan 23, 2004 8:39 am

blender_FTF.lib(FTF_TTFont.obj) : error LNK2001: unresolved external symbol "__d
eclspec(dllimport) public: int __thiscall FTFont::Error(void)const " (__imp_?Err
or@FTFont@@QBEHXZ)
blender.exe : fatal error LNK1120: 1 unresolved externals
scons: *** [blender.exe] Error 1120
scons: building terminated because of errors.


I had this same problem when building with msvc 7.0. I got it resolved by remving the const from the Error- fucntion from the ftgl lib. You could try this: ftgl package.

/jesterKing


Return to “Testing Builds”

Who is online

Users browsing this forum: No registered users and 1 guest