Crash under Linux

Blender's renderer and external renderer export

Moderators: jesterKing, stiv

neoneurone
Posts: 2
Joined: Mon Mar 01, 2004 7:17 pm

Crash under Linux

Postby neoneurone » Mon Mar 01, 2004 7:20 pm

Hello,

When I push the "render" or "anim" button, blender crashes with the following messages:

------------------------------------------------------------
[neurone@Neo blender-2.26-linux-glibc2.2.5-i386]$ ./blender
Loading required GL library /usr/X11R6/lib/libGL.so.1.2
blender: r200_vtxfmt.c:1083: r200VtxfmtUnbindContext: Assertion `vb.context == ctx' failed.
Aborted
------------------------------------------------------------

And I have the same problem with the following versions:
blender-publisher-2.25-linux-glibc2.1.2-i386
blender-2.30-linux-glibc2.2.5-i386
blender-2.32-linux-glibc2.2.5-i386

Here are some hardware & software informations:
------------------------------------------------------------
[neurone@Neo blender-2.26-linux-glibc2.2.5-i386]$ XFree86 -version
XFree86 Version 4.3.0
Release Date: 9 May 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.18-23mdksmp i686 [ELF]
Build Date: 10 September 2003
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present

[neurone@Neo blender-2.26-linux-glibc2.2.5-i386]$ uname -a
Linux Neo 2.4.22neo #2 jeu nov 27 16:43:30 CET 2003 i686 unknown unknown GNU/Linux

[neurone@Neo blender-2.26-linux-glibc2.2.5-i386]$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS645DX Host & Memory & AGP Controller
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS 530 Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513 (rev 04)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:06.0 Communication controller: Intel Corp. 536EP Data Fax Modem
00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0c.0 CardBus bridge: O2 Micro, Inc. OZ6912 Cardbus Controller
00:0d.0 FireWire (IEEE 1394): Lucent Microelectronics FW323 (rev 04)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [Radeon Mobility 9000 M9] (rev 01)
------------------------------------------------------------


However, when I try the windows version, blender can render images without any problem. (The Gus image from the user manual for example)


Thank you for your help.

stiv
Posts: 3646
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Postby stiv » Wed Mar 03, 2004 9:22 pm

Since no one else has waded into the swamp, I'll give it a go.

You are having problems with the driver for your graphics card:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [Radeon Mobility 9000 M9] (rev 01)

This is why you see the problem with every version of blender but not under Windows.

Other people have had difficulty with ATI cards under both windows and linux. The usual solutions were turning off options like FSAA or trying newer/older drivers. Possibly there is a different XFree driver for this version of your card.


Doing a bit of googling turned up this:
> > blender: r200_vtxfmt.c:1083: r200VtxfmtUnbindContext: Assertion `vb.context == ctx' failed.
>
> This is fixed in current DRI CVS. In XFree86 4.3 you can work around it by
> setting the environment variable RADEON_NO_VTXFMT before running your
> application.

Make that R200_NO_VTXFMT for the r200 driver.


All I can suggest is to try setting that environment variable. I don't have a way to test this, so all I can do is wish you luck.

neoneurone
Posts: 2
Joined: Mon Mar 01, 2004 7:17 pm

Postby neoneurone » Fri Mar 05, 2004 11:08 am

Hi there,

Thank you very much man ! You really saved my life ! :D

I was feeling so bad working under M$ WinXP. :evil: Here is the command which set the environment variable under Bash. I put it here in case someone has the same problem.

Code: Select all

[neurone@Neo blender-2.32-linux-glibc2.2.5-i386]$ export R200_NO_VTXFMT=


After setting this variable, I can render and anim as usual. Hmm, I didn't even think about doing some googling :D

Thank you again :P


Return to “Rendering”

Who is online

Users browsing this forum: No registered users and 1 guest