Game engine testing files

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

ton
Site Admin
Posts: 525
Joined: Wed Oct 16, 2002 12:13 am
Contact:

Game engine testing files

Postby ton » Wed Mar 31, 2004 2:32 pm

Hi,

From the NaN content database: (10 Meg)
http://download.blender.org/demo/test/2 ... _demos.zip

The next few days testing builds for upcoming 2.33 will be posted here as well. These files can all serve as 'conformance' suite for it.

Have fun,

-Ton-

BTW: also a good one:
http://download.blender.org/demo/old_demos/secoac.zip
the sensor-controller-actuator tests.

(All content credits go to Joeri, WP, Randall, Reevan, Freid, Strubi and Carsten!)
Last edited by ton on Fri Apr 02, 2004 11:25 am, edited 1 time in total.

calli
Posts: 63
Joined: Wed Oct 16, 2002 10:59 am
Contact:

Postby calli » Wed Mar 31, 2004 5:48 pm

Somehow the textures are missing Ton ...

as quick help (I guess Ton will fix the zip) make a textures/ folder alongside with the *.blends and put the images into...

Same with the samples/ folder.

Regards
Carsten.
Last edited by calli on Wed Mar 31, 2004 6:03 pm, edited 1 time in total.

jd-multi
Posts: 123
Joined: Thu Mar 13, 2003 11:29 pm

Postby jd-multi » Wed Mar 31, 2004 5:56 pm

Ton :shock: that sounds awesome, I mean, great blender 2.33 is comming and the game engine users would be happy about seeing this (included me)
Thanks For Ton and the coders.

Dracarys
Posts: 39
Joined: Sun Dec 21, 2003 5:57 am

Postby Dracarys » Fri Apr 02, 2004 1:34 am

YES! Finally! Thank you Ton, and all the other coders! I think I can speak for all of #gameblender saying that.

/me hugs blender

ideasman
Posts: 1000
Joined: Tue Feb 25, 2003 2:37 pm

Postby ideasman » Fri Apr 02, 2004 4:06 am

Sorry to be a twit but does this mean that Blender 2.33 will have the functionality that until recently only 2.25 had?
as in a full game engine? That works on the net and within blender???
Wasnt there some problem with solid? WHat happened, was it replaced with an older solid lib, or did it get released and I just missid it.

- Cam

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Fri Apr 02, 2004 8:34 am

ideasman wrote:or did it get released and I just missid it.


It got released under a GPL license, there has been quite much talk about it, so my guess is that you missed it.

The Solid library has undergone some improvements and changes, so the gameengine needed also changes. Concerning the physics alien-xmp did a fantastic job to restore most if not all of it.

/jesterKing

ton
Site Admin
Posts: 525
Joined: Wed Oct 16, 2002 12:13 am
Contact:

Postby ton » Fri Apr 02, 2004 11:25 am

calli wrote:Somehow the textures are missing Ton ...

as quick help (I guess Ton will fix the zip) make a textures/ folder alongside with the *.blends and put the images into...

Same with the samples/ folder.

Regards
Carsten.


The files should have it all packed in... which specific files are wrong?
I only tested it in 2.25 though.

calli
Posts: 63
Joined: Wed Oct 16, 2002 10:59 am
Contact:

Postby calli » Fri Apr 02, 2004 12:25 pm

They are all "pink". Nothing packed (they all use only one texture!)

I remember I prepared these files, and unpacked all to get relative pathes to textures/ and samples/ (to save space).

So I guess you just did not zip with folders. The texture is there just not in a folder "texture/"

Carsten.

OTO
Posts: 430
Joined: Wed Oct 16, 2002 8:51 pm
Contact:

Postby OTO » Fri Apr 02, 2004 3:34 pm

Hello

The textures are ok in my downloaded zip.
Thank you
Bye

calli
Posts: 63
Joined: Wed Oct 16, 2002 10:59 am
Contact:

Postby calli » Fri Apr 02, 2004 4:31 pm

STRANGE!

No folder information in my *.zip.

Ok.

Carsten.

jd-multi
Posts: 123
Joined: Thu Mar 13, 2003 11:29 pm

Postby jd-multi » Fri Apr 02, 2004 5:53 pm

Well, it seams that the NaN games works prefect, like the textures are with it, but the logic brick testing file scenes shows pink. It means that the texture isn't in a folder where it has to be because the textures are with it. The thing you need to do, is just find out how the folder was called, and place the texture in a folder with the same name and it's fixed. :D

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Fri Apr 02, 2004 6:16 pm

jd-multi wrote:Well, it seams that the NaN games works prefect, like the textures are with it, but the logic brick testing file scenes shows pink. It means that the texture isn't in a folder where it has to be because the textures are with it. The thing you need to do, is just find out how the folder was called, and place the texture in a folder with the same name and it's fixed. :D


metalting and metalting.wav should go in a dir, under the .blend called sounds, and the texture.jpg should go to a directory called textures.

/jesterKing

ton
Site Admin
Posts: 525
Joined: Wed Oct 16, 2002 12:13 am
Contact:

Postby ton » Sun Apr 04, 2004 1:12 pm

Ah. the logic bricks files are wrong... didn't look at these yet.
Main testing still is with the NaN files:

http://download.blender.org/demo/test/2 ... _demos.zip

Doogs
Posts: 69
Joined: Wed Oct 16, 2002 1:16 am

Postby Doogs » Sun Apr 04, 2004 8:11 pm

Okay kester please keep in close touch with saluk and I.

the true test will be if crescent dawn works.

RonC

jd-multi
Posts: 123
Joined: Thu Mar 13, 2003 11:29 pm

Postby jd-multi » Sun Apr 04, 2004 10:41 pm

If Cresent Dawn works? Lol, I already saw that some rotation movements didn't work, I don't know if it was Rot or Torque. But I'll make a bug report on my website where I keep a list of bugs, and maybe it's handy for the coders to take a look at it when it's done. I do this to seperate the normal blender bugs with the game engine bugs. :)

Anyways the Dracolith tests works almost perfect, only the camera zooming didn't works, but further no problems :P


Return to “Testing Builds”

Who is online

Users browsing this forum: No registered users and 0 guests