bf-blender Linux-glibc2.2.5-python2.3 (20040413)

User-contributed CVS development builds. Please test and give feedback!

Moderators: jesterKing, stiv

Michel
Posts: 208
Joined: Wed Oct 16, 2002 7:27 pm
Location: Somewhere below the rivers in Holland (but not Limburg)

bf-blender Linux-glibc2.2.5-python2.3 (20040413)

Postby Michel » Tue Apr 13, 2004 9:36 pm

Hi,

Another test build. All latest cvs commits are available in this one. Many bug fixes.
I still don't have an explanation for the crashes people experience. My only guess would be an incompatible Python version (prior to version 2.3).

You can find the latest builds here.

With regards,
Michel
Last edited by Michel on Wed Apr 21, 2004 10:13 pm, edited 1 time in total.
You can have one of two things: Progress or Progress Reports.

basse
Posts: 22
Joined: Tue Oct 15, 2002 11:10 pm

Postby basse » Thu Apr 15, 2004 9:10 am

well, I am running older python version... I haven't upgraded it because I am not sure what would happen... lot of tools in Fedora rely on python,.. and I am a bit afraid what would happen if I just go and download new python.

is 2.3 backwards compatible to 2.2 ?
if not, will 2.3 overwrite 2.2 upon istallation?
if I install python 2.3, can I still run old blender versions too?

these are the things I worry.. I need to work with my machine, it's not just testing ground, so I need to be careful :)

and finally, why 2.2 doesn't work with blender anymore?

.b

raphael
Posts: 34
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Postby raphael » Thu Apr 15, 2004 6:40 pm

Segmentation fault on linux mandrake 10 (blender static)

raphael
Posts: 34
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Postby raphael » Thu Apr 15, 2004 6:51 pm

The same on slackware 9.0 : Segmentation fault

Erufailon
Posts: 28
Joined: Wed Jan 07, 2004 11:48 am

Postby Erufailon » Thu Apr 15, 2004 8:04 pm

I tried to build one myself, but I haven't posted it, because as soon as I start to play sg with the game engine I get a segmentation fault. Other than that everything works fine. (Debian)

OTO
Posts: 430
Joined: Wed Oct 16, 2002 8:51 pm
Contact:

Postby OTO » Thu Apr 15, 2004 9:29 pm

Hi

well...again, a segmentation fault... too
Mandrake 10
Bye

mox
Posts: 8
Joined: Wed Oct 16, 2002 4:01 pm

Postby mox » Fri Apr 16, 2004 12:28 pm

segmentation fault in Mandrake 9.2
:(

Michel
Posts: 208
Joined: Wed Oct 16, 2002 7:27 pm
Location: Somewhere below the rivers in Holland (but not Limburg)

Postby Michel » Fri Apr 16, 2004 1:48 pm

Hi,

thank you all for all the response on the segfaults. Unfortunately with no additional information, I can't fix any problem.
I have to make the following assumptions:
- The segfault occurs when starting blender.
- You have Python 2.3 installed

Please, provide a little more information.

By the way: Python 2.3 is not binary compatible with Python 2.2. Blender links in Python 2.3 support. This means modules compiled for Python 2.2 will not work. Scripts are supposed to be compatible within versions.
We were expecting the Python version problems. In the past there was a group who had trouble starting blender because they had Python 2.3 installed, now there will be a group who will have trouble starting blender because they have Python 2.2 installed. This is a problem that is worked on. The goal is to have this fixed before the Blender 2.33 release, but it all depends on the amount of time we have available.

With regards,
Michel
You can have one of two things: Progress or Progress Reports.

mox
Posts: 8
Joined: Wed Oct 16, 2002 4:01 pm

Postby mox » Fri Apr 16, 2004 2:01 pm

OK, you are right;

MDK 9.2;
Python 2.3 after deinstall 2.2;
segmentation at blender's start
:?

OTO
Posts: 430
Joined: Wed Oct 16, 2002 8:51 pm
Contact:

Postby OTO » Fri Apr 16, 2004 3:42 pm

Hello Michel

Mandrake 10 Comunity ships with Python 2.3.3
And you're wright the seg fault is at start up

Thank you for the effort
Bye

raphael
Posts: 34
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Postby raphael » Fri Apr 16, 2004 5:49 pm

Hello,

The same as OTO for me ..

"Mandrake 10 Comunity ships with Python 2.3.3
And you're wright the seg fault is at start up "

And, on my Slakware 9.0 , Blender "seg fault" at start up to. ( i have Python 2.2 on this system).

But there's something i don't understand...
Blender should start even if you don't have python on your machine ?
Am i wrong ?
So, what is the problem if i have py 2.2 or 2.3 ?

raphael
Posts: 34
Joined: Mon May 26, 2003 10:18 pm
Location: france
Contact:

Postby raphael » Fri Apr 16, 2004 6:35 pm

Hello MIchel,

Iv'e tried to run blender with xxgdb under MDK 10.0, and here's the output message:



run
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 5901)]
(no debugging symbols found)...(no debugging symbols found)...'import site' failed; use -v for traceback

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 5901)]
0x0851f28d in PyObject_GC_Del ()
(xxgdb) next
Single stepping until exit from function PyObject_GC_Del,
which has no line number information.
Cannot find user-level thread for LWP 5901: generic error
(xxgdb) next



Hope it will help you

blendix
Posts: 133
Joined: Wed Oct 16, 2002 1:00 pm

Postby blendix » Fri Apr 16, 2004 7:12 pm

Here's a backtrace:
#0 0x085112bd in PyObject_GC_Del ()
#1 0x084c1bd5 in PyDict_Values ()
#2 0x08510b6e in Py_GetPath ()
#3 0x085110ff in _PyObject_GC_Malloc ()
#4 0x085111a5 in _PyObject_GC_New ()
#5 0x084c2baa in PyCFunction_NewEx ()
#6 0x08508940 in Py_InitModule4 ()
#7 0x0829c57a in Mathutils_Init ()
#8 0x082914d4 in M_Blender_Init ()
#9 0x0827cf14 in initBlenderApi2_2x ()
#10 0x0827a116 in BPY_start_python ()
#11 0x080e6dce in main ()
#12 0x40371dcc in __libc_start_main () from /lib/libc.so.6

Using python 2.2.3. If you provide a debug build I can try to find out what exactly what goes wrong.

xhyldazhk
Posts: 6
Joined: Mon Oct 28, 2002 3:25 am

Postby xhyldazhk » Sun Apr 18, 2004 9:46 pm

[achernar@altair achernar]$ gdb ./blender
GNU gdb Red Hat Linux (5.3post-0.20021129.18rh)
Copyright 2003 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(gdb) run
Starting program: /home/achernar/blender
[New Thread 16384 (LWP 16821)]
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 16821)]
0x0850f53d in visit_decref ()
(gdb) bt
#0 0x0850f53d in visit_decref ()
#1 0x084bfe55 in dict_traverse ()
#2 0x0850edee in collect ()
#3 0x0850f37f in _PyObject_GC_Malloc ()
#4 0x0850f425 in _PyObject_GC_New ()
#5 0x084c0e2a in PyCFunction_NewEx ()
#6 0x08506bc0 in Py_InitModule4 ()
#7 0x0829c76a in Mathutils_Init () at Mathutils.c:1184
#8 0x08291284 in M_Blender_Init () at Blender.c:226
#9 0x0827cc34 in initBlenderApi2_2x () at EXPP_interface.c:60
#10 0x08279e36 in BPY_start_python ()
#11 0x080e689e in main (argc=1, argv=0xbffff504) at creator.c:417
#12 0x40375c17 in __libc_start_main () from /lib/i686/libc.so.6
(gdb)

Redhat Linux 9.0 on an Athlon 750 with a GeForce4 440 SE
Python 2.2.2

jesterKing
Site Admin
Posts: 1848
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Postby jesterKing » Mon Apr 19, 2004 8:50 am

xhyldazhk wrote:Python 2.2.2


As Michel_ told in the beginning of the thread, you'll be needing Python 2.3

/jesterKing


Return to “Testing Builds”

Who is online

Users browsing this forum: No registered users and 0 guests