Previous Thread  Next Thread

chat icon CVS 21/11/02

VelikM

Posted: Fri Nov 22, 2002 4:12 am
Joined: 14 Oct 2002
Posts: 80
This is the output from the cvs01 updated 21/11/02. OS X 10.2.2
Autoscan:
[PowerBookG4 5:46:31pm michaelv] ~/Desktop/blender% autoscan
./aclocal.m4:46: error: Autoconf version 2.54 or higher is required for this script
./aclocal.m4:46: the top level
autoconf: tracing failed
autoscan: cannot close:

./bootstrap:
[PowerBookG4 5:48:26pm michaelv] ~/Desktop/blender% ./bootstrap
configure.ac:122: installing `./py-compile'
automake: source/blender/avi/Makefile.am: `libblender_avi.la' is not a standard library name
automake: source/blender/blenkernel/Makefile.am: `libblender_blenkernel.la' is not a standard library name
automake: source/blender/blenlib/Makefile.am: `libblender_blenlib.la' is not a standard library name
automake: source/blender/blenloader/Makefile.am: `libblender_blenloader.la' is not a standard library name
automake: source/blender/blenpluginapi/Makefile.am: `libblender_blenpluginapi.la' is not a standard library name
.............. you get the idea.

make:
[PowerBookG4 5:53:11pm michaelv] ~/Desktop/compile% make
cd ../blender && /bin/sh /Users/michaelv/Desktop/blender/missing --run autoheader
touch ../blender/config.h.in
cd ../blender && /bin/sh /Users/michaelv/Desktop/blender/missing --run autoconf
configure.ac:191: error: possibly undefined macro: AC_FUNC_REALLOC
*** Error code 1


The autoscan error: ./aclocal.m4:46: error: Autoconf version 2.54 or higher is required for this script.
OS X 10.2 development tools ships with 2.52, I like keeping up on the front of the tools, but not everyone does, it would be nice to keep the scripts backward compatible.
Please don't take this as a criticsim, it's an observation based on my understanding of the goals of this project. I personally think the developers are doing an outstanding job.
Reply with quote


the_razor

Posted: Fri Nov 22, 2002 9:18 am
Joined: 15 Nov 2002
Posts: 5
VelikM wrote:


./bootstrap:
[PowerBookG4 5:48:26pm michaelv] ~/Desktop/blender% ./bootstrap
configure.ac:122: installing `./py-compile'
automake: source/blender/avi/Makefile.am: `libblender_avi.la' is not a standard library name


That is because the current Makefile.am:s are suposed to build a static library instead of a dynamic one which .la extension denotes, you should wait until the Makefile.am:s are fixed before retrying(or you could just try to modify them yourself).

VelikM wrote:

The autoscan error: ./aclocal.m4:46: error: Autoconf version 2.54 or higher is required for this script.
OS X 10.2 development tools ships with 2.52, I like keeping up on the front of the tools, but not everyone does, it would be nice to keep the scripts backward compatible.


That error should not occur once ./bootstrap script is functioning... or then it is because you haven't run ./configure after the ./bootstrap.

-the_razor-
Reply with quote


 
Jump to:  
Powered by phpBB © 2001, 2005 phpBB Group