Slackware 8.0 current status cvs01 Dec 13, 1300 HST

Compiling, libraries, modules, coding guidelines and porting

Moderators: jesterKing, stiv

lholt
Posts: 18
Joined: Tue Oct 29, 2002 1:48 am

Slackware 8.0 current status cvs01 Dec 13, 1300 HST

Postby lholt » Sun Dec 15, 2002 2:35 am

Wiped out my /blender cvs tree and updated. No Makefile so I ran ./bootstrap which used the autoconf stuff. Had to copy acinclude.m4 to the blender dir.

ran configure and make from a parallel dir (b.build) and I got a blender executable

entered the blender dir and did another configure/make and got the same.
Don't know which way is best. Both seem to work. I'm under the imperssion that they use different Makefiles or something.

Both still crash on any TEXT entry. Variable fakepos from ps.font.c runs away and segfaults trying to read the font stuff. Haven't figured out why yet, but I'm looking. At least I{'m trying to look. I have little experence chasing through large amounts of C and any pointers on how to go about it would be appreciated.

I haven't seen anybody else mention a crash on TEXT. Am I alone here?

The blender is truly an amazing peice of work. I would like to understand it better.

SirDude
Posts: 941
Joined: Sun Oct 13, 2002 7:37 pm
Location: University of Minnesota (USA)
Contact:

Postby SirDude » Sun Dec 15, 2002 3:32 am

I'm pretty sure its a bug on all platforms that needs to be worked out.

Weve been focusing on the build process though right now so
we can get more people involved.

The seperate build system is you edit source/nan_definitions.mk
Then cd blender/intern/
make
cd blender/source
make

using configure inside or outside of the blender dir is the same
if you do it inside of the blender dir however you wipe out the old
makefile system.


Return to “Coding Blender”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests