Previous Thread  Next Thread

chat icon python_freeze with windows MSVC 6.0?

nothings

Posted: Sat Jan 11, 2003 2:22 am
Joined: 11 Jan 2003
Posts: 1
First I tried the October source downloads from the 'downloads' link. The US mirror URL was bad; the Dutch mirror seemed incomplete (it was missing certain files, it didn't include the external libraries).

So I switched to a full current CVS download. I was able to build most of the internal libraries, but even after installing Python and adding it to the MSVC path as described in the readme, the freeze_python part of the build still failed:

Code:

--------------------Configuration: python_freeze - Win32 Debug--------------------
Compiling...
dummy.cpp
Linking...
Freezing Blender Python
parsesetup.py:3: DeprecationWarning: the regex module is deprecated; please use the re module
  import regex
Error: needed directory c:\app\python22\lib\python2.2\config not found
Use ``freeze.py -h'' for help
Error executing c:\winnt\system32\cmd.exe.

python_freeze.exe - 1 error(s), 0 warning(s)


I also tried installing Python 2.1 but got the same outcome.
Reply with quote


pgregory

Posted: Tue Jan 14, 2003 10:39 am
Joined: 16 Oct 2002
Posts: 43
Does anyone have any ideas on this, it is the same thing stopping me compiling under Windows too. I have tried various versions of Python, to no avail.

Cheers

PaulG
Reply with quote


dinklebrow

Posted: Tue Jan 14, 2003 8:35 pm
Joined: 14 Oct 2002
Posts: 8
you will have to make a new directory called python2.2 then subdir config under lib. also make a python2.2 directory under include.
I'm getting stuck at:
Code:
generating table of frozen modules
parsesetup.py:3: DeprecationWarning: the regex module is deprecated; please use the re module
  import regex
No definition of module zlib in any specified map file.
Warning: unknown modules remain: zlib

python_freeze.exe - 0 error(s), 1 warning(s)


I compiled blender before, but I can't remember how I got around this.
Reply with quote


threegame

Posted: Wed Jan 15, 2003 7:14 am
Joined: 14 Jan 2003
Posts: 1
I made a new directory called python2.2 under Lib folder of Python22,
and then subdir config under python2.2.
Also I made a python2.2 directory under include.
But, I obtained warning messages like below.

////////////////////////////
generating table of frozen modules
parsesetup.py:3: DeprecationWarning: the regex module is deprecated; please use the re module
import regex
WARNING: extensions_win32.ini can not be found - standard extensions may not be foundNo definition of module zlib in any specified map file.
Warning: unknown modules remain: zlib

python_freeze.exe - 0 error(s), 2 warning(s)
////////////////////////////
Reply with quote


 
Jump to:  
Powered by phpBB © 2001, 2005 phpBB Group