Search found 51 matches

by Jens
Wed Oct 28, 2009 9:26 pm
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

Hi From your errors it looks like you miss something essentially. The needs: - checkout blender trunk - checkout libs, have the in the same dir as blender-source ( so the Blender-folder and Lib-folder are in the same level !!!) -have xcode installed - have scons installed So starting without any use...
by Jens
Wed Oct 28, 2009 6:10 pm
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

Sorry if this is a dumb question but does this mean that there is a user-config.py in trunk that I can't find or that we don't need one? and if we don't need one which file do we edit to change those flags? If you read the darwin-config.py there is mentioned how to handle that. # # Note : if you wa...
by Jens
Wed Oct 28, 2009 2:46 pm
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

OSX-compiling !!!!

Hi You may have noticed i removed the patches and such. It is all in trunk now !!!!! Instructions: WITH_GHOST_COCOA = True/False MACOSX_ARCHITECTURE = 'arch' # valid archs: ppc, i386, ppc64, x86_64 ..is the only decision to be done for out-of the box-compiling now. All flags are set automatic by thi...
by Jens
Mon Oct 26, 2009 8:19 pm
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

dunno what you set up yourself, but log shows you try to compile carbon 64bit, which is not possibe. Use my patch, btw latest: http://www.jensverwiebe.de/Blender/Blender25_scons_cocoa_patch4.zip patch with: patch -p0 < OSX_cocoa_scons4.txt and use the user-config as it is for 64bit_cocoa. The new on...
by Jens
Wed Oct 21, 2009 5:43 pm
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

Hi ..almost done now. I finished the patch for compiling all OSX-architectures including new cocoa-stuff now. We should think about reorganizing the darwin-config.py, maybe setup the -arches more automatic, but due OSX is always multi-arch, this is a tricky task. Here´s the patch and a user-config s...
by Jens
Tue Oct 20, 2009 7:43 pm
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

Re: user-config.py repost?

Wait a few days, i haven´t finished the new adaptions for scons yet. I´ve put together now: -64bit capable ( universal), libs ( in trunk ) -patch for building with cocoa -user-config prepared for 10.5sdk TODO: -setup a choice for OSX_ARCHITECTURE in scons for unzipping the right arch only ( saving d...
by Jens
Wed Sep 16, 2009 11:39 pm
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

Hey
Take simply my config --> http://www.jensverwiebe.de/temp/user-config.py.zip

Put it in maindir of trunk.

Edit: removed broken trunk note, all fine again, just built B 2.5


Jens
by Jens
Tue Sep 15, 2009 3:55 pm
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

Just do as advised. You missed simply to install 10.4u-sdk when installing xcode. It is not default, just additional install for crosscompiling. Use option 2: Change config : else: MAC_MIN_VERS = '10.5' MACOSX_SDK='/Developer/SDKs/MacOSX10.5.sdk' and add the flags, no problem, just a change. 10.6 is...
by Jens
Tue Sep 15, 2009 9:41 am
Forum: Coding Blender
Topic: Building troubles on osx 10.6
Replies: 28
Views: 20501

mats If you use 10.4u.SDK it is mandatory to use gcc-4.0 !! set: CC and CXX to gcc-4.0/g++-4.0 or use gcc-4.0/g++-4.0 along with 10.5.SDK ( toolchain automatic 32bit ) or Set SDK to 10.5 and gcc(-4.2) , but then you´ll have to add: -m32 and -march=i386 to the c,cc ad linkflags, cause the standart-to...
by Jens
Sun Jun 01, 2008 4:01 pm
Forum: Coding Blender
Topic: OSX Compile Errors
Replies: 4
Views: 3890

Hi Yeah indeed, this is a very old thread !!!! Best is to checkout the newest SVN and make sure to have the actual darwin-config.py used. It is completely overhauled, compiles fine with ffmpeg too and is universal to get either an Intel or PPC-build. (inclusive platform-spezific optimize-flags) The ...
by Jens
Sat Apr 26, 2008 12:23 pm
Forum: Coding Blender
Topic: Building x86_64 on Leopard
Replies: 8
Views: 7615

Hi nobulart

Do the following:

1. In terminal goto : /blender/extern/xvidcore/build/generic

2. type: ./configure --disable-assembly --disable-mmx ( + press enter )

3. do make ( type make + press enter )

After that you are able to compile as usual, cause the xvid is pre-build

Cheers...Jens
by Jens
Thu Mar 06, 2008 3:59 pm
Forum: Coding Blender
Topic: Intel Compiler 10 Success!
Replies: 2
Views: 4924

Hi Mike Started builing with ICC on OSX now. Good results. The builds are around 20% faster than with GCC ( 4.0.1 Apple ). OMP gives a good boost for fluids and cloth, speed is more than doubled on a 4-core. 2 questions: 1. Is it o.k. to publish builds made with the evaluation-copy of ICC at GRAFICA...
by Jens
Mon Jan 21, 2008 2:03 pm
Forum: Coding Blender
Topic: OSX Compile Errors
Replies: 4
Views: 3890

Hi forTis I did not do anything other installing dev-tools, scons and svn. I think your problem is you enabled ffmpeg, this will not work yet. Iconv is in usr/lib already and should work normally, but is build dynamic every time, cause it is used by gettext too and is linked somewhere in the deep. s...
by Jens
Mon Nov 05, 2007 9:11 pm
Forum: Coding Blender
Topic: Compiling Blender on Intel Mac tutorial?
Replies: 2
Views: 3184

Do a serach !!! I described it in this forum + published the whole config.py. http://www.blender.org/forum/viewtopic.php?t=11940&sid=d93eb6acd1bc3d3a7a9a51f0e601f465 and http://www.blender.org/forum/viewtopic.php?t=12348&sid=d93eb6acd1bc3d3a7a9a51f0e601f465 Should be enough. Jens P.S. Don´t try it o...
by Jens
Sat Oct 20, 2007 11:27 pm
Forum: Coding Blender
Topic: Compiling latest SVN on OSX intel
Replies: 2
Views: 3332

Hi Igor As far as i know, iconf is not in the LIB but resides in OSX. But compiling should be no problem, i do it succesful with the following configuration, no x-tra dependancies nessesary. It´s configured for building against Python 2.5 !!! To use it with Python 2.3, change the lines with: BF_PYTH...