Search found 24 matches

by thru2trot
Sun Jul 03, 2011 10:59 pm
Forum: Coding Blender
Topic: Error During SVN Update!!
Replies: 11
Views: 7374

Hello Stiv, Again, i thank you for the clarity. And once again you're right, /usr/lib/python3.2 is where python should be installed and I can confirm this is where I have it installed. The question seems to be whether or not CMAKE knows that. I have tried to set up a symbolic link in the past only w...
by thru2trot
Sun Jul 03, 2011 4:48 am
Forum: Coding Blender
Topic: Error During SVN Update!!
Replies: 11
Views: 7374

Hello Stiv, Thank you much for the response, the: sudo make install seems to have done the trick, however, now I'm getting a different error: CMake Error at source/creator/cmake_install.cmake:96 (FILE): file INSTALL cannot find "//python3.2". Call Stack (most recent call first): cmake_install.cmake:...
by thru2trot
Sat Jul 02, 2011 7:46 pm
Forum: Coding Blender
Topic: Error During SVN Update!!
Replies: 11
Views: 7374

Hello all, I know this definitely has something to do with not having permissions to opt, however I tried changing the permissions to the opt folder in root by typing: sudo chmod +x opt , but this did not work. Again, I thank everyone for their help in helping me resolve this. Best Regards, thru2trot
by thru2trot
Sat Jul 02, 2011 7:38 pm
Forum: Coding Blender
Topic: Error During SVN Update!!
Replies: 11
Views: 7374

Error During SVN Update!!

Hello everyone, I am trying to update blender via SVN by running this command: cd ~/blender-svn/build; svn up ../blender; make -j3; make install Everything seems to run with no issues, however, at the very end of the update I get this error: Install the project... -- Install configuration: "Debug" -...
by thru2trot
Sun Apr 03, 2011 4:02 am
Forum: Coding Blender
Topic: Error After Updating SVN!!
Replies: 2
Views: 1528

Hello Stiv, Well, what is the correct way to enable write permissions to /opt I thought I could simply do: sudo cd ~/blender-svn/build; svn up ../blender; make -j3; make install however, I received the error that this command was not found. I know that I'm able to just simply type su - prior to ente...
by thru2trot
Sat Apr 02, 2011 2:37 am
Forum: Coding Blender
Topic: Error After Updating SVN!!
Replies: 2
Views: 1528

Error After Updating SVN!!

Hello all, I ran the following script: cd ~/blender-svn/build; svn up ../blender; make -j3; make install I get this error after it finishes compiling: Install the project... -- Install configuration: "Debug" -- Installing: /opt/blender/bin/blender CMake Error at source/creator/cmake_install.cmake:40...
by thru2trot
Fri Jan 21, 2011 2:52 am
Forum: Coding Blender
Topic: Creating Symbolic Link!1
Replies: 2
Views: 2484

Hello Stiv, Thanks so much for the quick reply. If I add the path to the blender executable in my .bashrc file, how do I differentiate between blender2.49b and blender2.5? Both executable files are named blender. I guess it wouldn't matter if one of the files were named differently but in this case ...
by thru2trot
Fri Jan 21, 2011 12:17 am
Forum: Coding Blender
Topic: Creating Symbolic Link!1
Replies: 2
Views: 2484

Creating Symbolic Link!1

Hello all, I am desperately trying to learn Python3 in context of blender 2.49 and 2.5. Although it isn't practical, the only books that are available for scripting in blender are for version 2.49 and have yet to be written for python3. Anyway, I noticed in having installed both 2.49 on Ubuntu 10.10...
by thru2trot
Fri Jan 14, 2011 8:21 pm
Forum: Coding Blender
Topic: No module named Blender!!
Replies: 4
Views: 12568

DDDoooppppeee!!It's right in the Terminal print out!!

OHHH Gosh, I think I see it, Updated external to revision 1399 Updated to revision 34324.. I guess it would be nice to see it logged in a file, I'm sure it exists. Best Regards, freesparks P.S. I also saw it on the blender splash screen picture right after I run it in QT. Best Regards, thru2trot
by thru2trot
Fri Jan 14, 2011 7:50 pm
Forum: Coding Blender
Topic: No module named Blender!!
Replies: 4
Views: 12568

You're absolutely right jesterKing!!

Hello Stiv, I can't thank you much for your help and expertise. Well, in literally taking a stab at building python2.56a from source using the instruction on these 2 very helpful links: http://wiki.blender.org/index.php/Dev:2.5/Doc/Building_Blender/Linux/Ubuntu/CMake http://wiki.blender.org/index.ph...
by thru2trot
Fri Jan 14, 2011 2:33 am
Forum: Coding Blender
Topic: No module named Blender!!
Replies: 4
Views: 12568

No module named Blender!!

Hello all, I purchased a book that I am trying to follow along with, however it is a bit dated. I know that Blender2.56 is built entirely on python3.1. Here is the script I am trying to run in the blender python console: import Blender from Blender import Scene, Text3d, Window hello = Text3d.New("He...
by thru2trot
Thu Jan 13, 2011 7:31 am
Forum: Python
Topic: The Infamous Environment Variable Issue!!
Replies: 10
Views: 3803

Thanks much for the explanation stiv, Well, I am trying to learn how to script. So here goes, in lieu to all of this, in the interactive console in the latest blender 2.56a, I am trying to run this: #!BPY import Blender from Blender import Scene, Text3d, Window hello = Text3d.New("HelloWorld") hello...
by thru2trot
Thu Jan 13, 2011 5:37 am
Forum: Python
Topic: The Infamous Environment Variable Issue!!
Replies: 10
Views: 3803

For whatever reason, the profile file located in /etc/ is what was breaking the installation. Once I went in and erased this portion the code, which is located at the end of the file, that seemed to have taken care of everything: This is what I erased: PATH="$PATH:/opt/blender" export PATH if [ -x /...
by thru2trot
Thu Jan 13, 2011 3:34 am
Forum: Python
Topic: The Infamous Environment Variable Issue!!
Replies: 10
Views: 3803

Now this is the error that I get in the Terminal when I launch blender2.56a: myname@mycomputer:~$ blender found bundled python: /home/myname/source/blender-2.56a-beta-linux-glibc27-i686/2.56/python Fatal Python error: Py_Initialize: can't initialize sys standard streams Traceback (most recent call l...
by thru2trot
Thu Jan 13, 2011 3:29 am
Forum: Python
Topic: The Infamous Environment Variable Issue!!
Replies: 10
Views: 3803

Thanks for the reply Ido,

I'm using it because I'm using Komodo IDE 6.0.3. I'm sure I didn't need to use it but it just seems o make things easy as it relates to learning python in context of finding preconfigured modules!!

Best Regards,

thru2trot