Search found 8 matches

by EvilEngel
Sat Oct 04, 2008 4:25 am
Forum: Coding Blender
Topic: Blender under VS2008 - unresolved external symbol
Replies: 13
Views: 14527

fixed for me: python VS version

My issue was resolved in a similar way as the posts above, but with a different library. I'm building with cmake and visual studion 2005 in debug mode. I had to tweak my cmakelists.txt to link against the python25_d library from the lib25_vs2005 sub folder. Also tweaked the post build command for th...
by EvilEngel
Sat Oct 04, 2008 2:38 am
Forum: Coding Blender
Topic: Blender under VS2008 - unresolved external symbol
Replies: 13
Views: 14527

Same problem, any solution?

I also have exactly the same problem. I'm using VC 2005 and my library directory is set to 2005 (I tried all of the other options just in case, but they're obviously worse). Was anyone able to work around this?
by EvilEngel
Sat Aug 09, 2003 4:38 am
Forum: Coding Blender
Topic: Problems compiling blender with MS Visual Studio .NET
Replies: 13
Views: 7033

nyoxi. I got the 'blender' project to compile, with many library/include directories changed, I saw the issues you mentioned. The fact that you mentioned the .tlb tells me that you're trying to rebuild the whole solution. The .tlb is only generated in the ActiveX plugin for Blender, I believe, which...
by EvilEngel
Wed Aug 06, 2003 1:46 am
Forum: Coding Blender
Topic: Problems compiling blender with MS Visual Studio .NET
Replies: 13
Views: 7033

heh, heh. No, it's not easy. :) I want to help you 'cause I went through a lot of headache to get it to compile just a few days ago. Basically, MANY include/lib paths in the project files have to be changed. All the SND_*.h files are now in $(SolutionDir)intern\SoundSystem, but they used to be in th...
by EvilEngel
Tue Aug 05, 2003 8:45 pm
Forum: Coding Blender
Topic: Problems compiling blender with MS Visual Studio .NET
Replies: 13
Views: 7033

It seems to me that you opened the blender.vcproj directly, instead of the blender.sln in the base directory. It's hard to tell, could you tell me exactly what you did? If you want to talk on AIM or Yahoo Messenger, let me know.
by EvilEngel
Mon Aug 04, 2003 1:50 pm
Forum: Coding Blender
Topic: compile trouble DNA.C not found
Replies: 7
Views: 4491

I had the same "problem" when I first tried to compile blender. DNA.c does not exist in the source tree. It is generated by the makesdna program. If you look in the makesdna makefiles you'll see some notes about that. It is supposed to be created by the build process, but until you figure out why it...
by EvilEngel
Fri Aug 01, 2003 4:17 pm
Forum: Coding Blender
Topic: Unsuccessful builds with Visual Studio .NET
Replies: 3
Views: 2529

I'm also trying to compile using Visual Studio .NET. It seems straightforward, but incredibly tedious to make all projects work. I still have about 7 projects that won't compile, and my biggest headache is a duplicate struct definition (UserStructType) in blender\source\blender\readstreamglue\BLO_ke...
by EvilEngel
Thu Jul 31, 2003 12:09 am
Forum: Foundation and Websites
Topic: Too many different logins in blender.org!
Replies: 1
Views: 4747

Too many different logins in blender.org!

I'm confused by the number of accounts needed in the blender web sites. I have an account in the blender foundation, one here in blender.org, and apparently I need a different one in projects.blender.org? I've been using blender on and off for the past few years, and I'm interested in becoming a dev...