Search found 51 matches

by Jens
Mon Sep 17, 2007 5:23 pm
Forum: Coding Blender
Topic: multithreading limited to one core in blender's python?
Replies: 3
Views: 4834

Hi Kai ( Hallo )
Did you include openmp ?
Which system are you on?
I just szarted to find out about multithreading with openmp,
cause there is also an experimental approach in the "Cloth"-branch
made by genscher.

Greetz...Jens

P.S. kannst mich sonst auch mal anmailen....
by Jens
Sun Sep 16, 2007 8:15 pm
Forum: Coding Blender
Topic: @ Jean Luc - Bug still there...API-mismatch in 2.45intel
Replies: 0
Views: 2065

@ Jean Luc - Bug still there...API-mismatch in 2.45intel

Hi In OSXintel release still API mismatch errors !!! sys:1: RuntimeWarning: Python C API version mismatch for module Blender: This Python has API version 1013, module Blender has version 1012. sys:1: RuntimeWarning: Python C API version mismatch for module Blender.Armature: This Python has API versi...
by Jens
Tue Sep 04, 2007 3:09 pm
Forum: Coding Blender
Topic: Blender 2.45rc2Py2.5 / OSXintel - Bug : api-mismatch
Replies: 0
Views: 1980

Blender 2.45rc2Py2.5 / OSXintel - Bug : api-mismatch

Hi In official Macintel 2.45 i get a console-warning lots of lines: sys:1: RuntimeWarning: Python C API version mismatch for module Blender: This Python has API version 1013, module Blender has version 1012. I do my own builds too and found out how to avoid this. In darwinconfig.py, change the line:...
by Jens
Sun Aug 26, 2007 6:03 pm
Forum: Testing Builds
Topic: Testing builds for OSXintel
Replies: 0
Views: 4755

Testing builds for OSXintel

Hi As requested on the last sunday-meeting, i will provide builds for testing the new features. Having enough time, i try to do an actual SVN-build nearly every day to get rid of eventual bugs. Concentrating on the standard-version now. I hope this will bring the bugfixing any further. The builds ar...
by Jens
Mon Jul 16, 2007 10:51 pm
Forum: Coding Blender
Topic: Building out of XCode possible? OSX / solved: scons instead
Replies: 26
Views: 15951

Hi william
Iám happy you got it working.
Didn´t hurt too much, eh ? :?
After doing this once, it becomes more clear then.
OSX is a little bit different but not too much.
I too had to dig in the libraries
for the first attempt.
Please share your experiences to other people as well....

Greetz...Jens
by Jens
Mon Jul 16, 2007 11:24 am
Forum: Coding Blender
Topic: Building out of XCode possible? OSX / solved: scons instead
Replies: 26
Views: 15951

Hm I installed other Python versions first, they reside : /Library/Frameworks/Python.framework/Versions/ There is 2.4 + 2.5 and current, which points to 2.5 in my case. There is my scons also. In:/System/Library/Frameworks/Python.framework/Versions/ there is 2.3 and current, that points to 2.3. Mayb...
by Jens
Sun Jul 15, 2007 5:35 pm
Forum: Coding Blender
Topic: Building out of XCode possible? OSX / solved: scons instead
Replies: 26
Views: 15951

Hm, unsure what happend there, seems missing lib´s. You have all the libs? They are not a part of the branch !!!! /usr/local/bin/svn checkout https://svn.blender.org/svnroot/bf-blender/trunk/lib/ That contains: freetype, gettext, jpeg, openal, openexr, png, sdl, tiff, and is nearly 300MB. Did you ex...
by Jens
Sun Jul 15, 2007 12:58 pm
Forum: Coding Blender
Topic: Building out of XCode possible? OSX / solved: scons instead
Replies: 26
Views: 15951

Hi william I will do a hole description in time, now just the short version. 1. Install Appel-Dev-Tools from DVD or download. 2. Get SVN: http://downloads.open.collab.net/binaries.html it is a binary, so no prob.Installs at: /usr/local/bin/svn 2a. Get scons, has to be compiled on Mac too. http://www...
by Jens
Mon Jul 09, 2007 11:08 pm
Forum: Coding Blender
Topic: Compling blender SVN on mac os x 10.4 PPC
Replies: 3
Views: 3546

Hi Same Jens as at Graficall :shock: There are in fact different sources of coding guides around, that all describes the coding a bit different and never a full way. Especially on OSX it seems to be no well documented. The way with cmake and GCC seems to be somewhat buggy, someone told me there are ...
by Jens
Mon Jul 09, 2007 11:57 am
Forum: Coding Blender
Topic: Building out of XCode possible? OSX / solved: scons instead
Replies: 26
Views: 15951

Hi all Yes, it is unsatisfying. I did an "cmake -G "xcode" ../blender "first to have the xcode projektfiles. Found out xcode must have "" around. But the result is not working. There must be a better way. My hope was to have os-specific optimisation more easy with xcode, ´cause it is very tricky to ...
by Jens
Sun Jul 08, 2007 7:38 pm
Forum: Coding Blender
Topic: Building out of XCode possible? OSX / solved: scons instead
Replies: 26
Views: 15951

Hi Stiv First of all, after reading a lot about compiling blender, i was not sure if i can use xcode in generally. This is my first attempt, so i downloaded the bf 2.44 and the libs to checkout if it works. Just to compile a working source with nothing experimental in it. I started the xcode-project...
by Jens
Sun Jul 08, 2007 6:56 pm
Forum: Coding Blender
Topic: Building out of XCode possible? OSX / solved: scons instead
Replies: 26
Views: 15951

Building out of XCode possible? OSX / solved: scons instead

Hi To be able to checkout the newest development i would like to have blender as an xcode-projekt. But when trying to compile, i hit some strange problems. Is it generally possible to use xcode and gcc 4 ? Does someone have some tips ? Would be nice to use this easy to handle apple-dev-tools. Greetz...
by Jens
Mon Jan 29, 2007 7:44 pm
Forum: News & Chat
Topic: Blender OSX-Intel, Python 2.5
Replies: 6
Views: 4146

Hi stiv I used the packages from Python.org to install Py 2.4.4 and Py 2.5. ( Installer ) This was a supersimple prozess. I don´t know why someone should have a problem with this. Just download, mount .dmg, open installer, type passwd...., as simple as every sw-install. I suppose someone who can´t m...
by Jens
Mon Jan 29, 2007 6:22 pm
Forum: News & Chat
Topic: Blender OSX-Intel, Python 2.5
Replies: 6
Views: 4146

Blender OSX-Intel, Python 2.5

Hi I just wanted to let you know, im testing an CVS-build with new particels and python 2.5 dependency now.( from graphicall). I experienced an around 20% speedboost in nearly all prozesses when using Py 2.5 instead of the defaullt 2.3 Py. I´ve encountered no further troube/incompatibilities so far....
by Jens
Wed Jan 03, 2007 11:30 am
Forum: News & Chat
Topic: Osx 10.2.8 help meeee
Replies: 2
Views: 2746

10.2. ? Oooh...long time ago..... :roll:

You should check if Python is included in 10.2.8. and what version.

Aniway it should be possible to install x-tra Python 2.4 and use

Blender 2.4.2a PPC for Python 2.4 !!!! It´s clearly described in the

downloads section.

Greetz...Jens