Search found 217 matches

by alien-xmp
Wed Apr 16, 2003 2:10 pm
Forum: Coding Blender
Topic: AAARRRGH!!! So close.
Replies: 11
Views: 5779

Are you using version 2.26 or CVS? There have been some recent auto* patches in CVS.
by alien-xmp
Tue Apr 15, 2003 2:41 pm
Forum: Coding Blender
Topic: Tried compiling blender in cygwin using Hos' instructions
Replies: 9
Views: 4226

In file included from STR_String.cpp:42: ../STR_String.h:48: vector: No such file or directory The compiler can't find the 'vector' header. This is part of the standard c++ library and should be installed... On my cygwin system it is in /usr/include/c++/3.2 directory. It came in the gcc package, wh...
by alien-xmp
Sun Apr 13, 2003 8:39 am
Forum: Coding Blender
Topic: Slackware 9.0 compile -- not quite there
Replies: 10
Views: 6503

Works like a charm. The only problem is that it didn't find libGLU. The problem is configure couldn't find it because it is an X11 lib. configure couldn't find some other libraries either (Xext, Xxf86dga, X11, GL, GLU). This patch should fix it: Index: configure.ac ==================================...
by alien-xmp
Sun Apr 13, 2003 6:36 am
Forum: Coding Blender
Topic: Slackware 9.0 compile -- not quite there
Replies: 10
Views: 6503

Thanks Michel,

Doing a compile now... :)
by alien-xmp
Thu Apr 10, 2003 4:41 am
Forum: Coding Blender
Topic: Slackware 9.0 compile -- not quite there
Replies: 10
Views: 6503

I think it is more likely a problem with ld (ie binutils) I have 2.13.1 (not up to date...) Other information: glibc 2.3.1, gcc 3.2.2. The thing is -lc & -lgcc_s do not need to be explicitly specified, gcc will pull them in automatically. -lm & -ldl don't need to be linked more than once. So, if you...
by alien-xmp
Sun Apr 06, 2003 2:43 pm
Forum: Coding Blender
Topic: Why don't use glib/gtk?
Replies: 5
Views: 6158

I'm no expert, but I think the problem with doing this is that blender is using opengl, ie widgets and everything are drawn w/ opengl. To use gtk you would have to write a gtk wrapper around opengl so that gtk uses opengl for drawing. This is probably a lot of hard work, but would be an interesting ...
by alien-xmp
Sun Apr 06, 2003 2:33 pm
Forum: Coding Blender
Topic: Slackware 9.0 compile -- not quite there
Replies: 10
Views: 6503

I had the same problem. A work around is to remove all -lc -lgcc_s -lm and -ldl from the line starting with dependency_libs= in some of the .la files: ./intern/libblender_intern.la ./source/libblender_source.la etc. The fix would be to stop these libs getting added from libtool/autoconf etc, but I h...