Page 1 of 1

2 could-be-considered-bugs in the new blender

Posted: Wed Feb 26, 2003 4:45 pm
by gsusfreek
Windows users of blender 2.23 and 2.25 may have noticed this first could-be-considered-a-bug. Before 2.25 the render window that popped up was a simple window, i.e. the window had no controls such as minimize, maximize, or close. 2.25 and 2.26 have a new popup render window that has these controls. In doing so, however, something quit registering with windows during rendering and the screensaver will come on. I have to disable the screensaver every time I render an animation. If this could be fixed in the next release, I'd be much obliged!
The second could-be-considered-a-bug, I just noticed a few days ago. In a large scene, when I try to move, size, or rotate an object, the mouse buttons sometimes won't register. I have to click sometimes three times before blender recognizes the click. If this is fixable, pleeeeeease do something about it! Thanx!

Re: 2 could-be-considered-bugs in the new blender

Posted: Fri Feb 28, 2003 1:34 am
by ray_theray
gsusfreek wrote:Windows users of blender 2.23 and 2.25 may have noticed this first could-be-considered-a-bug. Before 2.25 the render window that popped up was a simple window, i.e. the window had no controls such as minimize, maximize, or close. 2.25 and 2.26 have a new popup render window that has these controls. In doing so, however, something quit registering with windows during rendering and the screensaver will come on. I have to disable the screensaver every time I render an animation. If this could be fixed in the next release, I'd be much obliged!
I don't know how your computer works, but my computer normally goes on a screensaver if I don't move the mouse or use the keyboard. If you want to do other stuff while rendering, you might want to do background rendering (try using Theeth's background rendering script. Just load it in Blender's text window and change the "BlenderPath" variable to point to your blender executable. Save your Blend file before using the script.)
gsusfreek also wrote:The second could-be-considered-a-bug, I just noticed a few days ago. In a large scene, when I try to move, size, or rotate an object, the mouse buttons sometimes won't register. I have to click sometimes three times before blender recognizes the click. If this is fixable, pleeeeeease do something about it! Thanx!
This could be a system bottleneck. What's your graphics card and how much memory do you have? I think those would be the first culprit.

Posted: Fri Feb 28, 2003 2:28 am
by gsusfreek
The problem isn't with getting the screensaver to come on during rendering. The problem is stopping it from coming on! The screensaver would be disabled during rendering on older blender versions, but since 2.25, the screensaver DOES come on during the rendering process which, of course, dramatically slows rendering down. Blender needs to disable the screensaver during rendering.

Anyway... I figured the mouse button probem was low ram on my video card. I have a TNT2-m64 with 32MB of RAM, so I guess with a lot of IK solving and a WHOLE lot of subdivision surfaces being calculated, it would overload?

GLUT to GHOST

Posted: Fri Feb 28, 2003 2:30 pm
by jasontally
The first thing that you mentioned probably is because starting in blender 2.25 they switched windowing libraries from GLUT to a modified version they call GHOST that adds some features that were needed to make the OS X port look right (I think, there are probably other reasons to). Not turning on the screen saver sounds like it would have been a hack in the first place so they will need time to figure out how to do that with the new lib. Personally I don't use screen savers anymore just use the power settings button under the screen savers tab to have it turn your monitor off after 20 min.