Blender is being SLOW

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
shortybiker5
Posts: 0
Joined: Fri Dec 08, 2006 6:23 pm

Blender is being SLOW

Post by shortybiker5 »

Hello, i was wondering if anyone new why blender would run really slow. Its fine when you just open it but when you get into a project changing from edit mode to object or scale or anything like that it just takes forever to do it. Any help would be great

z3r0_d
Posts: 289
Joined: Wed Oct 16, 2002 2:38 am
Contact:

Post by z3r0_d »

because 1) blender uses opengl for everything
2) not all opengl drivers and graphics cards are perfect

I would be incredibly surprized if the system you're having these problems on has an nvida card. My guess is that you have an ati card, but I think other people said they had similar problems on SiS graphics chipsets or something.

z3r0_d
Posts: 289
Joined: Wed Oct 16, 2002 2:38 am
Contact:

Post by z3r0_d »

Okay, I need to calm down...

so, what version of blender, what operating system, and what graphics card do you have?

also, can you be more specific about the problem you are having?

Older versions of blender used to get slower and slower with use, it would take several seconds after rotating the view to be usuable again for example. I belive this was fixed [several times], but I can't be sure since I've not had that problem since I got an nvidia graphics card a couple years ago.

shortybiker5
Posts: 0
Joined: Fri Dec 08, 2006 6:23 pm

Post by shortybiker5 »

Im not totally sure what my card is how can i find out??

but im usiing blender 2.42 and my computer i just bought in the last month so really it shouldnt be doing this
but yeah let me know how to find out what my chipset is

z3r0_d
Posts: 289
Joined: Wed Oct 16, 2002 2:38 am
Contact:

Post by z3r0_d »

in display properties [in the control panel, or right click on the desktop and choose properties], on the settings tab, the combo box in the center will say something like:
"1. Default Monitor on RADEON X600 Series"

shortybiker5
Posts: 0
Joined: Fri Dec 08, 2006 6:23 pm

Post by shortybiker5 »

my card is a ATI RADEON EXPRESS 200 seires

elander
Posts: 0
Joined: Sun Dec 19, 2004 4:30 pm

Post by elander »

I have the same problem with a Radeon card. Usualy Blender starts very fast and the slows down over time.

Running the game engine and then quiting (just pressing P and ESC i think) brings the program back to it's normal speed.

This is the kind of thing that unfairly harms Blender reputation. Isn't it possible to solve this problem?

stiv
Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

Blender is talking OpenGL. The problem is with ATI's drivers and cards. Not using them is the easiest solution.

Some people have had success with switching to software rendering - the replace the ati opengl .dll method.

elander
Posts: 0
Joined: Sun Dec 19, 2004 4:30 pm

Post by elander »

"The problem is with ATI's drivers and cards. Not using them is the easiest solution. "

That would not be the easiest solution to a new user who is trying the program. He would just forget about it and try a new modeler.

"Some people have had success with switching to software rendering - the replace the ati opengl .dll method."

A software rendering option would be a good solution for people with very old cards. But this Ati bug must be well documented in their site and a workaround may be possible.

This problem has an easy solution as i mentioned above and it doesn't bother me but for people who are new to Blender who don't know the tricks it's an hugly problem.

z3r0_d
Posts: 289
Joined: Wed Oct 16, 2002 2:38 am
Contact:

Post by z3r0_d »

elander wrote:... But this Ati bug must be well documented in their site and a workaround may be possible.
If it were a known bug it'd either be fixed in blender, or ati's drivers.

ATI did send some blender developers some of their graphics cards, and I could have sworn this bug went away for several users around 2.37...
meh

LetterRip
Posts: 0
Joined: Thu Mar 25, 2004 7:03 am

Post by LetterRip »

It is a known bug with ATI graphics drivers - it is fixed in their more recent drivers I believe but the drivers shipped with laptops don't use their driver instead each laptop vendor ships their own tweaked version. So the driver for ATI laptops can only be upgraded if the laptop vendor updates their driver, which practically never happens.

You can either try and find an unsupported driver which some people find to have worked, turn down or off your graphics acceleration (which mostly works for me and works for most individuals), or get a new laptop :)

For that graphics chip the 'turn down or off graphics acceleration' works well for me, I think though that some have found unsupported drivers that work as well.

You will still have a problem with the file browser occasionally, but other than that it works okay.

LetterRip

Post Reply