Blender Freezing Up

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Mon Jul 23, 2007 9:11 pm

Blender Freezing Up

Post by Sesshomaru »

I am currently new at Blender and have had some troubles lately with Blender freezing up. If I were to press the space bar in the 3D viewport window, go to Add, then Mesh, and choose an object, it seems that whatever object I work with makes my computer freeze up. The two objects that have froze up my computer the most are the objects UVSphere (in working with the tutorial "Penguins From Spheres" from Wikipedia) and also the Cylinder (in working with the tutorial "Model a Silver Goblet From a Cylinder"). In working with the tutorial with the Cylinder, when I add the cylinder, it asks how many vertices you want (which is 16 for this tutorial). But in the tutorial it says that you are supposed to change the radius, the depth, and that the cap ends should stay the same. There are no options that come up for the radius, depth, and cap ends.

Now when I worked with the cylinder, my computer freezes up all the time (especially if I were to change views on the cylinder such as going into front view which would immediately freeze up my computer in which the crosshair in the 3D viewport window does not change into an arrow when I go towards the bottom of the window). Also, in working with the tutorial "Modeling a Silver Goblet" just from the default cube, when I was scaling in creating the knobs for this goblet, the object (knobs) in the 3D viewport window just vanished.

Now here's something that will immediately freeze up my computer which is that when I start Blender, the MS DOS prompt comes up and stays and that if I were to click on the minus button in the upper right hand corner of the screen in Blender which would result in Blender being a tab at the bottom of the screen and the MS DOS prompt being brought up, that's when my computer immediately freezes up. I even tried reducing my Hardware Acceleration, but that didn't help any.

Now here's some other information which is that if I were to render something, whatever I have rendered has outlines that are wavy/bumpy. I have Blender version 2.43 and my operating system is Windows ME. I do not know much when it comes to computers, though here is some additional information:

When I go to Control Panel and go to System, under the Performance tab it says I have 248.0 MB of RAM. My hard drive Local Disk (C) has a capacity of 18.6 GB and there is 8.16 GB of used space and 10.4 GB of free space.

Now when I go to Display Properties, under the Settings tab I have True Color (32 bit) and my screen area is 800 by 600 pixels. Also, the Display shows "Plug and Play Monitor on VIA Tech VT8361/VT8601 Graphics Controller"

Finally, when I click Advanced and under the Adapter tab it says that the Manufacturer is VIA Technologies, Inc. The Chip Type is KLE/PLE, the DAC Type is Integrated RAMDAC, the Memory is 8 MB, the Features is DirectDraw 1.00, the Software Version is, the current files are trid_p3d.drv,*vdd,*vflatd,trident.vxd,trid_p3d.dll. And finally, the Refresh rate is at Adapter default.

Posts: 0
Joined: Thu Mar 25, 2004 7:03 am

Post by LetterRip »

This is probably a graphics card issue, try updating your drivers and turning off antialiasing.


Site Admin
Posts: 207
Joined: Fri Oct 18, 2002 12:48 pm
Location: Finland

Post by jesterKing »

Also try turning down (or off) hardware acceleration.


Posts: 0
Joined: Mon Jul 23, 2007 9:11 pm

Post by Sesshomaru »

I tried all those things and they don't work. Also, when continuing working with Blender and following all the tutorials in Wikipedia, I have encountered a new problem that I can't get past. ... _Dimension

When doing this step of adding a 3rd dimension, whenever I change the value of either the Bevel Depth or BevResol, I recieve the following error message every time:

"Blender has caused an error in TRIDICDP.DLL. Blender will now close. If you continue to experience problems, try restarting your comptuer."

I tried restarting my computer many times and that did nothing at all. Also, having no choice but to click "close" when the error message comes up which closes Blender, when I open up Blender again, that freezes up my computer. I just know it has to do something with my operating system which is Windows ME.
Last edited by Sesshomaru on Fri Sep 14, 2007 9:38 pm, edited 1 time in total.

Posts: 0
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv »

Windows ME...248 MB memory
Via graphics (onboard?) with 8 MB memory

Sorry, but Blender is simply not going to run well on that machine. It sounds like most of your problem is graphics related. Blender needs good OpenGL support.

So, what to do? Having the latest driver for your card might help (yeah, I know...ME is obsolete and poorly supported.) Reducing the color depth might help a little. Do not run any other apps along with Blender.

Even the cheapest NVidia card would make a big difference if you have any cash at all.

Posts: 63
Joined: Wed Oct 16, 2002 3:08 pm

Post by kAinStein »

Sesshomaru wrote: "Blender has caused an error in TRIDICDP.DLL. Blender will now close. If you continue to experience problems, try restarting your comptuer."
They already told you: The graphics driver is the problem and if updating it doesn't help then the only solution I can come up with is getting a graphics card with good OpenGL support.

Post Reply