Page 1 of 1

Graphics Card Issue With Vista

Posted: Sat Jan 05, 2008 6:58 am
by Sesshomaru
I have just bought a brand new HP computer with Windows Vista Home Premium. I have looked at the Blender system requirements and it does meet all of the optimal system requirements because I went to system properties and it does have at least 2 Ghz dual CPU (it's an AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ 2.60 Ghz and the processor is rated a 5.2 in the Windows Experience Index). As for RAM, it says I have 1918 MB, but is rated a 5.9. As for my display, I have an HP w2007 Wide LCD Monitor with 1680 x 1050 resolution.

Now as for the graphics card, I have a NVIDIA GeForce 6150SE nForce 430. The total available graphics memory is 831 MB with 703 MB of shared system memory and 128 MB of dedicated video memory. This graphics card does support all versions of OpenGL (all the way up to OpenGL version 2.1), but blender doesn't do too well because if I were to subsurf at a level higher than 1 or 2 on a basic model such as basic mountains, navigating the viewport becomes very slow and blender crashes.

Now I have the latest driver installed from Windows Update (which is a driver on July 6th) , but I then installed the latest driver from the NVIDIA website for the GeForce 6 series (which is a driver on December 20th), but Windows Update keeps telling me I need to install the driver for this graphics card (which is that same driver way back on July 6th). Also, when I looked into Windows Experience Index, my graphics (desktop performance for Windows Aero) was rated a 3.2, my gaming graphics (3D business and gaming graphics performance) was rated a 3.0. And finally, my primary hard disk (disk transfer rate) was rated a 5.7, leaving a base score of 3.0. Therefore, is my graphics card and this Windows Update issue and my score in the graphics area being low have to do with my performance issues with blender? I mean, I have met all of the optimal system requirements. Therefore, shouldn't blender fully function with all its features anyway?

Posted: Sat Jan 05, 2008 7:23 am
by stiv
As far as I can tell from your description, you are using an on-board graphics chip with 128M video memory. These are usually not particulary speedy performers.

The other, probably greater, problem is Windows Aero. If you can use something without all the eye candy you will be better off when running Blender.

Posted: Sat Jan 05, 2008 10:53 am
by jesterKing
Aero can be turned off (by disabling all effects). Also, try turning down any hw acceleration if just the less eye candy doesn't cut it. And make sure you have absolutely the latest driver.

/Nathan

Posted: Sun Jan 13, 2008 9:42 pm
by Sesshomaru
Now I have the latest driver installed from Windows Update (which is a driver on July 6th) , but I then installed the latest driver from the NVIDIA website for the GeForce 6 series (which is a driver on December 20th), but Windows Update keeps telling me I need to install the driver for this graphics card (which is that same driver way back on July 6th). Therefore, could this be causing my problem?

Finally, I don't know anything when it comes to graphics cards, but I am considering on buying a new one. Therefore, what would be the best non-integrated graphics card for blender that I should buy (which would be a graphics card that will increase my low scores in the graphics and gaming graphics area all the way up to 5 point something and is a graphics card that will run blender and all its features PERFECTLY and would enable me to easily navigate the viewport even at the highest level of subsurf which is level 6)?

Posted: Wed Feb 06, 2008 10:58 pm
by macfan777
First, don't concern yourself with the "Windows Experience Index" - it's just a completely pointless toy Microsoft threw in with Vista. Second, your hardware is fine for most Blender work - I found mine worked quite well with a 2.6 GHz Pentium 4, 256 MB of RAM, and a 64 MB integrated graphics card (this was on an XP machine without the resource-hogging Aero interface!). The key with subsurf lies with just what kind of model you're trying to subsurf. Subsurfing takes a HUGE amount of resources, and you need a VERY fast computer to handle it effectively. I will say from experience that when I tried to subsurf to a level of 3 even on a small, relatively simple model, it choked up and ran VERY slowly. (Until I got my Mac, which sped things up tremendously!) Realistically, what you should do is turn all the Vista Aero eye-candy off, make sure no other programs are running, then retry the subsurfing. Other things you could try are disabling additional viewports so the view you're working in is the only 3D view, changing view types (some views, like shaded and textured, run more slowly), changing the view to only the element you're working on at the moment so power isn't wasted rendering the background elements, or what I do most of the time, disabling subsurfing in the 3D view and have it active only while rendering. If none of this is satisfactory, then a graphics card update is probably a good idea. Hope this helps!