Page 3 of 3

Posted: Sun Apr 27, 2003 3:37 am
by iluvblender
Skelet wrote:
iluvblender wrote:Hi Hos.

I compiled blender on windows. thank you very much for your tips/instructions. :D
Can you share with it ? Please
Image
Hi.

I just followed the instructions found here.

http://projects.blender.org/viewcvs/vie ... ot=tuhopuu


i installed cygwin (all the stuff during the setup, about 700mb of it).
and just followed Hos's instructions. Took about 30 mins to compile.

not a single glitch. btw, i did this on a windows 2000 machine.

hope this helped. good luck on the compile.


- Satish.

Posted: Mon Apr 28, 2003 8:50 am
by Skelet
You see, blender is not just my hobby, and I actualy have'nt time to find all components and just compile blender , so I hoped some one coud upload somewhere allready compiled tuhopuu...

Posted: Mon Apr 28, 2003 4:50 pm
by iluvblender
Skelet wrote:You see, blender is not just my hobby, and I actualy have'nt time to find all components and just compile blender , so I hoped some one coud upload somewhere allready compiled tuhopuu...
Hi Skelet.

okay. but today i am at home. and the stuff is at my lab. i will upload it asap.


cheers.

Posted: Mon Apr 28, 2003 6:02 pm
by dinklebrow
Skelet wrote:You see, blender is not just my hobby, and I actualy have'nt time to find all components and just compile blender , so I hoped some one coud upload somewhere allready compiled tuhopuu...

You can download it from here. Compiled 28 April.

http://www.crosscannon.com/modules.php? ... load&cid=1

Compiled with WinXP, works with Win2k. I haven't tried it yet with Win9x yet.

Posted: Mon Apr 28, 2003 11:15 pm
by IngieBee
Oh boy, I'm gonna be in trouble. Decided to try compiling on my 650 mhz laptop 1 1/2 hours before quitting time, LOL. I'll be here all night. Hope it doesn't mind being shut down prematurely :wink: or maybe it just won't compile :D

Hee hee hee, thanks Hos, you're amazing, really!!!

Posted: Mon Apr 28, 2003 11:18 pm
by iluvblender
dinklebrow wrote:
Skelet wrote:You see, blender is not just my hobby, and I actualy have'nt time to find all components and just compile blender , so I hoped some one coud upload somewhere allready compiled tuhopuu...

You can download it from here. Compiled 28 April.

http://www.crosscannon.com/modules.php? ... load&cid=1

Compiled with WinXP, works with Win2k. I haven't tried it yet with Win9x yet.
i just tried it on a windows 98 machine. no problems at all. like the new font. :D

Good job!!!

Posted: Tue Apr 29, 2003 11:07 am
by thorax
Maybe I will get it compiled myself, but until then I can now play
with it!!

Thanks!!

Posted: Tue Apr 29, 2003 12:03 pm
by Bab
Hello, I download the windows release and all function works great but in fileselector the wheelmouse doesn't works.

Comiles Great

Posted: Tue Apr 29, 2003 4:21 pm
by leinad13
Compiled great on my XP box with debug and without, nice size of about 5.5mb without. HOS THIS IS AMAZING.

Sorry i was trying to get it compiled with MSVC6 and after about 30 attemps i jst gave up, wouldnt even start, damn project files.

Anyway ye works, great at the moment but i havnt really given it a full workout. Now all we need is for some better documentation of the source because it seems to me at the moment a few people know whats what. And arnt sharing :x

Ah well Hos, u are great, any plan for helping some nearly new coders to get their hands dirty, or would it be better for me to wait until the source is much neater. (Will it ever be :S)

Thanks Again

Re: Comiles Great

Posted: Tue Apr 29, 2003 5:45 pm
by iluvblender
Anyway ye works, great at the moment but i havnt really given it a full workout. Now all we need is for some better documentation of the source because it seems to me at the moment a few people know whats what. And arnt sharing :x
check this forum out.

http://projects.blender.org/forum/forum.php?forum_id=23

and also, Ton has translated dutch comments to english.

http://projects.blender.org/viewcvs/vie ... bf-blender

hope this will get you started.

have fun.

Posted: Thu May 01, 2003 12:36 am
by Jamesk
Woah!

OK, I did actually promise myself not to start doing this, but then I had to install Cygwin for other purposes... and since it was already there, I figured 'what the heck' and... well, huge thanks to Hos, da man!

Built the Blender in around one hour (a bit strange since I'm on this poor old 466 MHz) without any serious glitches. The only thing not working seems to be the new freetype-stuff - I only get the "old" font. There is probably some very good explaination for that, and most likely caused by something I did wrong or didn't do at all.

Now let's see if I can actually code something too, and of course see if there is some little thing I can actually understand about it all... But I really don't have the time... I would like to add a gaussian blur texture preprocessor, or a Photoshop filter adapter for the sequence editor, or maybe something else. But that'll have to wait until I finish my short.

Thanks again, Hos. This was an important thing to solve, and you did it!

Posted: Thu May 01, 2003 2:47 am
by NateTG
NateTG is *n00b* to this stuff. Please forgive him if he is stupid.

I got to this step:
6. to prepare the build system to use only free tools we must
set some environment variables. This is done by issuing the
command:
source free_windows-env.sh
but when I try I get:

Code: Select all

BASH: free_windows-env.sh: No such file or directory
I am guessing I need to get the free_windows-env.sh file from somewhere.

whats the problem? everything seemed to work up till now.

Posted: Thu May 01, 2003 2:57 am
by NateTG
nevermind, after an hour of trying to figure it out myself, i realized I skipped a step. :oops: :oops: :oops:

/me kicks himself.

sorry.

Posted: Fri May 02, 2003 3:37 pm
by Hos
Bab wrote:Hello, I download the windows release and all function works great but in fileselector the wheelmouse doesn't works.
Got to the user preferences window and set
WLines to something other than 0.

Chris

Posted: Wed May 07, 2003 7:32 am
by AndyDavis
I had the same issue that Dani was having at the start of the thread. Turns out I did not have the gnu make package in my cygwin. Not sure what make it was using, but installing that one package seems to have done the trick. The build is rolling right now.

-Andy

Update
8) My build completed successfully! From yesterday's source I have a lot of text not showing up (menus, etc), but I'll see if I can work that out tonight.