Easy compiling of tuhopuu under RedHat

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Hos
Posts: 185
Joined: Wed Oct 16, 2002 12:06 am

Easy compiling of tuhopuu under RedHat

Post by Hos »

Compiling blender under RedHat Linux has always been a chore,
but not anymore! The main problems have been: problems with the
openal sound libs, problems with the netscape libs, and problems
with missing symbols in libcrypto. Here's how to make it easy for
yourself:

1. Create a directory to put your sources and then enter that
directory, e.g.:

Code: Select all

     mkdir tuhopuu
     cd tuhpuu
2. checkout the tuhopuu tree using cvs (use password anonymous):

Code: Select all

     cvs -d:pserver:anonymous@cvs.blender.org:/cvsroot/tuhopuu login
     cvs -z3 -d:pserver:anonymous@cvs.blender.org:/cvsroot/tuhopuu \
          co blender
3. Enter the blender directory:

Code: Select all

     cd blender
4. Open up Makefile in your favorite text editor and uncomment the
following lines by removing the '#' mark:

This:

Code: Select all

# export NO_SOUND=true
# export JUST_BLENDERDYNAMIC=true
# export REDHAT_WEIRDNESS=true
becomes this:

Code: Select all

export NO_SOUND=true
export JUST_BLENDERDYNAMIC=true
export REDHAT_WEIRDNESS=true
5. The final step, time to build... issue the command:

Code: Select all

     make
Upon success the executable will be in the
directory obj/linux-{glibc version here}/debug

Chris

sten
Posts: 177
Joined: Sun Oct 13, 2002 7:47 pm

Post by sten »

hmm, I got error anyway, no binary output,
can be if I have Red Hat 9, don't know if it is any
difference...

sten
Posts: 177
Joined: Sun Oct 13, 2002 7:47 pm

Post by sten »

Now it works !!!

to all other, Hos made a update to the CVS and now it works
with no errors for Red Hat users, 8 as 9 :-D

YAY!

my very first comple!

André
Posts: 6
Joined: Mon Oct 14, 2002 6:26 am
Location: Switzerland
Contact:

Post by André »

ztonzy wrote:hmm, I got error anyway, no binary output,
can be if I have Red Hat 9, don't know if it is any
difference...
same problem here...

*help*

:?

ox
Posts: 50
Joined: Sat Nov 02, 2002 11:01 pm

Post by ox »

Thanks Hos, I'm upgrading to PinkTie 9 this week and I'll give it a try. I appreciate your time.

slikdigit
Posts: 133
Joined: Wed Oct 16, 2002 3:52 am
Location: Northampton, MA (US)

Post by slikdigit »

thanks Hos- I'm not running redhat, but following your instructions (minus the redhat weirdness comment ) plus disabling quicktime allowed me to build tuhopuu for the first time (on gentoo)

Hos
Posts: 185
Joined: Wed Oct 16, 2002 12:06 am

Post by Hos »

André wrote:
ztonzy wrote:hmm, I got error anyway, no binary output,
can be if I have Red Hat 9, don't know if it is any
difference...
same problem here...

*help*

:?
Please post the error you encountered.

Regards,
Chris

André
Posts: 6
Joined: Mon Oct 14, 2002 6:26 am
Location: Switzerland
Contact:

Post by André »

i just try to compile it again and... :D :D :D :D

alien-xmp
Posts: 0
Joined: Sun Apr 06, 2003 2:22 pm
Location: Wellington, New Zealand
Contact:

Post by alien-xmp »

Also, if you have compiled tuhopuu and someone adds a new feature you don't have to checkout the complete source again (step 2)

6. Update the sources

Code: Select all

cd blender
cvs -z3 update -Pd
7. Goto step 4 and recompile.

ylai
Posts: 0
Joined: Mon May 26, 2003 3:55 am

Re: Easy compiling of tuhopuu under RedHat

Post by ylai »

Hos wrote:Compiling blender under RedHat Linux has always been a chore,
but not anymore! The main problems have been: problems with the
openal sound libs, problems with the netscape libs, and problems
with missing symbols in libcrypto. Here's how to make it easy for
yourself:

[...]
For my attempt enhance the font rendering, I just had to recompile Blender 2.27 on Red Hat Linux 8, and later also Tuhopuu. Without noticing this guide, I managed to compile Blender 2.27 with all modules. These are my rough steps:

1. Download, build and install OpenAL and FTGL (which should not be a problem on Red Hat Linux). The linking will still not work, but it makes a lot easier if you just have those headers in the include path. Do not forget to patch FTGL according to README.

2. Download and install the RPM packages mozilla-devel and mozilla-nspr-devel. You can use up2date for this, if you are registered with the Red Hat Network.

3. Go into blender-2.27/source/nan_definitions.mk, after the ifeq conditional with linux as the 2nd argument, uncomment the lines defining INTERNATIONAL and WITH_FREETYPE2.

4. If you do not have a static version of libGL (you can check its existence by locate libGL.a), go into the file blender-2.27/source/Makefile, look again for ifeq ($(OS),linux), comment out the line BINTARGETS += blenderstatic in your architecture (usually i386 for IA-32).

5. In the file blender-2.27/intern/keymaker/Makefile, add -ldl after the line containing libcrypto.a.

6. If you have only dynamical libGL/libGLU (like users of Nvidia drivers),go into blender-2.27/source/nan_link.mk, again after ifeq ($(OS),linux), comment out the line defining SADD.

7. Do make. This time, it will abort somewhere when it tries to link against the Mozilla NSPR headers.

8. Go into blender-2.27/lib/linux-glibc2.x.xx-i386 (replace "2.x.xx" with your Glibc version), create the directory nspr/include, and symbolically link /usr/include/mozilla-1.0.1/nspr/* and /usr/include/mozilla-1.0.1/xpcom/* into it (you will have a big mess of files, but there will be no file name collision).

9. Again in blender-2.27/lib/linux-glibc2.x.xx-i386, create the directory ftgl/lib and symbolically link (or copy) your libftgl.a from whereever you installed FTGL into this directory.

10. Make sure (possibly by an additional symbolic link) that libopenal.a can be found as /usr/lib/libopenal.a.

11. Do make again in the the root blender directory. This time, make should run through (or if you skipped 4 and you actually do not have a static libGL, at least it should compile until a dynamical binary is being built).

If you have built 2.27, building Tuhopuu from CVS should be really easy. What Hos did not have is the OpenAL library. If you have this, all you have to install in addition to the above (at the moment) is SMPEG. Then, uncommenting INTERNATIONAL, JUST_BLENDERDYNAMIC and REDHAT_WEIRDNESS in Makefile should be enough and make should run through.

I know that these are awfully much steps, but it will give you a complete Blender, including OpenAL and font smoothing (which was what I want to modify). Steps like 9 are just necessary due to the very strange configuration done to the source tree (who would link against a library in /usr/lib by writing its name explicitly?).

I will look again into these steps, maybe providing a script doing these automatically.

Smerity
Posts: 10
Joined: Wed Mar 19, 2003 10:48 am

New folders

Post by Smerity »

Just another thing, since tuhopuu2 came in the CVS is seperated into these two instead of just co blender

Code: Select all

 cvs -z3 -d:pserver:anonymous@cvs.blender.org:/cvsroot/tuhopuu \
co tuhopuu1

OR

co tuhopuu2
Hope that helps out some newbies like me =) Not hard to figure out, but takes a little time

lilyogi1
Posts: 0
Joined: Sun Nov 16, 2003 11:10 pm

Post by lilyogi1 »

Hi, I've recently tryed to compile Tuhopuu2 under RedHat9, with the new building system (using autoconf), I'm not a developer and I'm a newbie in both using linux and blender.
So if the game engine is disabled, Tuhopuu compiles gently (I had to manually modify the Makefile generated by autoconf : I had to edit path to libjpeg and libpng).
Tuhopuu also compiles nicely with the kesterji engine ("configure --enable-gameblender=kesterji --with-ode=/home/kristof/tuhopuu2/source/kesterji/ode/linux ", same problem with libjpeg and libpng).
I had problems compiling tuhopuu with solid game engine: first of all I had to mkdir lib in the extern/ode/dist/ directory in order to compile ode libs, I had to copy SND headers in /source/gameengine/BlenderRoutines and /source/gameengine/Ketsji directories. Then I had problems at linking time, I've managed to eventually compile the program by editing dependency_libs section in libblender_sources.la and in libblender_player.la, I know this is not a clean work but as I said I'm no developer.
I hope this post can be useful for anyone.
Regards
Kristof

lilyogi1
Posts: 0
Joined: Sun Nov 16, 2003 11:10 pm

Post by lilyogi1 »

Hi, I've recently tryed to compile Tuhopuu2 under RedHat9, with the new building system (using autoconf), I'm not a developer and I'm a newbie in both using linux and blender.
So if the game engine is disabled, Tuhopuu compiles gently (I had to manually modify the Makefile generated by autoconf : I had to edit path to libjpeg and libpng).
Tuhopuu also compiles nicely with the kesterji engine ("configure --enable-gameblender=kesterji --with-ode=/home/kristof/tuhopuu2/source/kesterji/ode/linux ", same problem with libjpeg and libpng).
I had problems compiling tuhopuu with solid game engine: first of all I had to mkdir lib in the extern/ode/dist/ directory in order to compile ode libs, I had to copy SND headers in /source/gameengine/BlenderRoutines and /source/gameengine/Ketsji directories. Then I had problems at linking time, I've managed to eventually compile the program by editing dependency_libs section in libblender_sources.la and in libblender_player.la, I know this is not a clean work but as I said I'm no developer.
I hope this post can be useful for anyone.
Regards
Kristof

lilyogi1
Posts: 0
Joined: Sun Nov 16, 2003 11:10 pm

Post by lilyogi1 »

Hi, I've recently tryed to compile Tuhopuu2 under RedHat9, with the new building system (using autoconf), I'm not a developer and I'm a newbie in both using linux and blender.
So if the game engine is disabled, Tuhopuu compiles gently (I had to manually modify the Makefile generated by autoconf : I had to edit path to libjpeg and libpng).
Tuhopuu also compiles nicely with the kesterji engine ("configure --enable-gameblender=kesterji --with-ode=/home/kristof/tuhopuu2/source/kesterji/ode/linux ", same problem with libjpeg and libpng).
I had problems compiling tuhopuu with solid game engine: first of all I had to mkdir lib in the extern/ode/dist/ directory in order to compile ode libs, I had to copy SND headers in /source/gameengine/BlenderRoutines and /source/gameengine/Ketsji directories. Then I had problems at linking time, I've managed to eventually compile the program by editing dependency_libs section in libblender_sources.la and in libblender_player.la, I know this is not a clean work but as I said I'm no developer.
I hope this post can be useful for anyone.
Regards
Kristof

lilyogi1
Posts: 0
Joined: Sun Nov 16, 2003 11:10 pm

Post by lilyogi1 »

Hi, I've recently tryed to compile Tuhopuu2 under RedHat9, with the new building system (using autoconf), I'm not a developer and I'm a newbie in both using linux and blender.
So if the game engine is disabled, Tuhopuu compiles gently (I had to manually modify the Makefile generated by autoconf : I had to edit path to libjpeg and libpng).
Tuhopuu also compiles nicely with the kesterji engine ("configure --enable-gameblender=kesterji --with-ode=/home/kristof/tuhopuu2/source/kesterji/ode/linux ", same problem with libjpeg and libpng).
I had problems compiling tuhopuu with solid game engine: first of all I had to mkdir lib in the extern/ode/dist/ directory in order to compile ode libs, I had to copy SND headers in /source/gameengine/BlenderRoutines and /source/gameengine/Ketsji directories. Then I had problems at linking time, I've managed to eventually compile the program by editing dependency_libs section in libblender_sources.la and in libblender_player.la, I know this is not a clean work but as I said I'm no developer.
I hope this post can be useful for anyone.
Regards
Kristof

Post Reply