Page 1 of 18

Graphics card compatibility - post your specs here!

Posted: Mon May 12, 2003 12:23 pm
by matt_e
The Graphics card compatibility page on blender3d.org is way out of date, and not very cross-platform. So, let's fix it by creating a new 'database' of information to find out what graphics cards work well, what cards don't, and to isolate any potential bugs or problems.

All you need to do is post your system specs here and how well they work. Let's keep this thread as a nice clean database, so please don't use this thread for discussion. If you want to discuss the results or add suggestions, please use this other thread here (I'll delete any 'chatty' posts from here and repost them in the other thread).

Please provide your:
  • Operating system (and version)
  • Graphics card (manufacturer, chipset, etc.)
  • Driver/OpenGL version
  • Functionality or problems (please note the Blender version if functionality differs between versions)
  • Any additional notes
For information on how to find out your graphics card chipset, driver versions, etc. in Windows, read this page on blender3d.org.

I'll get things started..

Posted: Mon May 12, 2003 12:25 pm
by matt_e
Operating system: Windows XP, SP1
Graphics card: Hercules 3D Prophet II MX(NVidia GeForce2 MX)
Driver/OpenGL version: v41.09 NVidia driver
Functionality: Blender works perfectly in all versions tested

Graphics card compatibility

Posted: Mon May 12, 2003 12:49 pm
by xfer
Machine 1 :
Operating system: Windows XP Home SP1 (Brazilian Portuguese)
Graphics card: onboard GeForce 4MX (64mb, shared)
Driver/OpenGL version: v43.45 nVidia
Functionality: Blender works perfectly in all versions tested (2.25, 2.26)

Machine 2 :
Operating system: Debian Linux (Woody)
Graphics card: onboard GeForce 4MX (64mb, shared)
Driver/OpenGL version: v1.0-4363 nVidia
Functionality: Blender works perfectly in all versions tested (2.25, 2.26)

Machine 3 :
Operating system: Windows XP Home SP1 (Brazilian Portuguese)
Graphics card: Creative Labs GeForce 2GTS (32mb, AGP 4x)
Driver/OpenGL version: v43.45 nVidia
Functionality: Blender works perfectly in all versions tested (2.25, 2.26)

Machine 4 :
Operating system: Debian Linux (Woody)
Graphics card: Creative Labs GeForce 2GTS (32mb, AGP 4x)
Driver/OpenGL version: v43.45 nVidia
Functionality: Blender works perfectly in all versions tested (2.25, 2.26)

Graphics card compatibility

Posted: Mon May 12, 2003 12:58 pm
by Michel
Operating system: Gentoo Linux 1.4 beta. (Kernel 2.4.20)
Graphics card: ATI Radeon 9700
Driver/OpenGL version: built-in XFree 4.3.0
Functionality: Blender only runs in software rendering.
Additional notes: Video card not yet supported with 3d acceleration, 2d acceleration only. ATI seems to be working on a driver for X 4.3.0 though.

Posted: Mon May 12, 2003 1:46 pm
by Puchacz
Operating system: Windows XP, SP1 (MDK 9.1)
Graphics card: GeForce2 MX 400
Driver/OpenGL version: v43.45 NVidia driver (v1.0-4363 nVidia)
Functionality: Blender works perfectly in all versions tested

Posted: Mon May 12, 2003 2:10 pm
by mavos
Operating system: Gentoo Linux (Kernel 2.4.20)
Graphics card: GeForce2 GTS (64 MB, AGP 4x)
Driver/OpenGL version: nVidia 4363
Functionality: Blender works perfectly (2.23, 2.25, 2.26, 2.27 CVS)

Posted: Mon May 12, 2003 2:51 pm
by Eric
Operating system: Gentoo Linux (Kernel 2.4.20)
Graphics card: GeForce2 GTS 64 MB
Driver/OpenGL version: nVidia 4363
Functionality: Blender works perfectly (2.23, 2.25, 2.26, 2.27 CVS, tuhopuu CVS, whatever)

Posted: Mon May 12, 2003 3:02 pm
by kattkieru
- Redhat 9.0, Pentium II 450 with GeForce2 GTS (32 meg, agp 2x)
Runs flawlessly with most current NVIDIA drivers, all blender versions so far (including many versions from CVS)

- iBook 800 MHz, OSX 10.2.6, ATI Radeon 7500 32 meg
Runs well, though with all the problems inherent in the OSX build. ^_^;;
No problems with Blender releases or CVS versions.

- iBook 500MHz, OSX 10.2.4, ATI Rage Mobility ?? 8 meg
Ran fine when I used it, up to Blender v2.26.

Posted: Mon May 12, 2003 3:18 pm
by Pablosbrain
* WindowsXP
* ATI Radeon 9700 Pro
* Latest ATI Catalyst Drivers
* All versions of blender work great

Posted: Mon May 12, 2003 5:16 pm
by IoN_PuLse
Win98SE, Win2K, WinXP, Blender 2.26

NVIDIA Geforce 5200 (128 meg), driver version 43.63

Runs flawlessly.

Win2k, Debian Linux (unstable), Blender 2.26

NVIDIA Geforce 2 GTS(32 meg), driver version 43.63

Runs flawlessly, please note sw_cursor must be commented out and hw_cursor should not be commented in the XF86Config-4 file.

For reference I've never seen Blender not work on a NVIDIA card, ever.

Posted: Tue May 13, 2003 2:57 am
by theeth
Win XP
S3 SuperSavage *shudder*
Latest MS drivers *double shudder*
Redraw problem after minimized and restored, or crash.

Martin

Posted: Tue May 13, 2003 6:14 am
by meestaplu
Operating system: Windows 2000 Service Pack 2
Graphics card: 3dlabs Wildcat VP 760
Driver/OpenGL version: 3.01.0422 beta; all release drivers work too
Functionality: Eats vertices for breakfast; works in all versions
Notes: The driver allows forcing a 32-bit zbuffer, which increases Blender's overall usability (small objects are shown more precisely)

Posted: Tue May 13, 2003 8:01 am
by env
Operating system: Windows 98 second edition (with backup!)
Graphics card: ATI radeon 7500
Driver/OpenGL version: latest from ATI; earlier release drivers work too
Functionality: Perfectly working.

Posted: Tue May 13, 2003 6:58 pm
by teachtech
Operating system: Windows XP Professional
Graphics card: Intel 82845G/GL
Driver/OpenGL version: 6.13.1.3095
Functionality: Blender runs well, some graphics glitches in shade mode, program crashes when selecting objects when you have many objects on screen, especially when selecting empties.

Posted: Tue May 13, 2003 7:58 pm
by Mats78
Operating system: WinXP Prof SP1 & Mandrake Linux 9.1
Graphics card: GeForce2 MX 400 (32 MB)
Driver/OpenGL version: NVidia 43.45
Functionality: Blender works perfectly (2.23, 2.25, 2.26, CVS, Tuhopuu)