Blender RENDER WINDOW is (Black) OR (Crashes Everything)

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
Posts: 0
Joined: Sat Oct 24, 2009 7:20 pm

Blender RENDER WINDOW is (Black) OR (Crashes Everything)

Post by quantass » Sat Oct 24, 2009 7:35 pm

I own a Sony Vaio VGN-NR498D Laptop containing the following specs:

CPU: Intel Centrino Core 2 Duo T5750 @ 2.0GHZ
Chipset: Intel GM965 (Intel 965 Express Chipset)
RAM: 2GB PC2-5300 DDR2-667 @ 333MHZ, 1GB PC2-5300 DDR2-667 @ 333MHZ
Graphics: Intel X3100 (however, Device Manager >> Display Adapter shows: Intel 965 Express Chipset)
Network: Intel Wireless WiFi Link 4965AGN (802.11a/b/g/n), Ethernet

I'm using Blender 2.49 on my Windows 7 Ultimate OS (I used to have it installed on Windows Vista SP1). Aero settings is ON. When i run the terrific app it works fine:

+ The Blender window has the Aero glass effect applied

+ The render window opens and renders (?) and i can close the window without it crashing Blender

+ The UI within Blender reacts fine (?)

The nuisances i do see within Blender using my current Windows settings are:

x When i go to split a window and expect to see the XOR divider, there is none. However when i click to use the split location, it works fine. So it works, it is just there is no XOR divider indicating where it is going to split

x When rendering, the render window ONLY shows a black screen. I have to left-click within the render window to display the output.

x The refresh of on-screen button graphics after a tooltip appears doesn't occur leaving behind black rectangles where buttons are supposed to be.

The ONLY way to correct the above nuisances is to "Disable Desktop Composition" within Windows 7 (or Vista). This appears to disable the glass Aero effect. The ONLY problem with this is when i go to close the render window it COMPLETELY CRASHES blender!! WTF!

Again i can live with the first approach (leave Aero ON) but if there is an easy solution to resolve my Windows 7 problem OR annoying non-aero problem I will take it.

Yes, I've updated my chipset driver from Intel through Windows Update & I've updated the graphics driver with the latest GMA driver.


Posts: 96
Joined: Fri Jan 10, 2003 6:41 pm

Post by joeri » Sat Oct 24, 2009 10:21 pm

As far as I know 7 was released here yesterday...
Pretty daring of you to expect opensource software to work on that the very next day.

Posts: 0
Joined: Sat Oct 24, 2009 7:20 pm

Post by quantass » Sun Oct 25, 2009 6:32 am

I have the EXACT same problem on my Windows Vista install too, not just Windows 7. I was hoping for a slight difference but there is none. So if it makes things easier scratch Windows 7 and think Windows Vista.

Posts: 0
Joined: Tue Nov 03, 2009 12:30 pm

Post by aussie114 » Tue Nov 03, 2009 1:14 pm

I believe I may have a fix for you

I had the same problem with blenders render screen turning black after I bought a new GFX card and got Windows 7,


problems were Blender render window was turning black once render had complete and I was have a few problems with the 3D window not refreshing when I pressed B twice to enter the selection tool, meaning that when in that tool and I moved the mouse there would be a trail of cursers were my mouse had been,


Its all because of openGL, so I right clicked on my desktop selected "nVidia Control panel" then went to "Manage 3D settings" clicked the program settings tab" added a new program profile "Blender 64-bit" and set "Conformant texture clamp" to "use openGL specification"

note: now I know you wont have the same settings as mine having an intel GPU but if I remember correctly there is intel graphics control panel, also google search your laptop to find the manufactures website and download the right drivers for you card.

Posts: 0
Joined: Tue Nov 03, 2009 12:30 pm

Post by aussie114 » Tue Nov 03, 2009 1:24 pm

I found the drivers for your laptop ... iv_pos_107 seems there are only windows vista drivers, I can tell you right now that your problem is a graphics related issue now if it can be fixed as of yet I don't know, but if I were you I will still give getting those drivers a go and going threw your intel graphics control panel.

Posts: 0
Joined: Sun Oct 17, 2010 11:22 pm

Post by ibid49 » Mon Oct 18, 2010 3:16 pm

For what it's worth, either to the OP or for posterity, if you run into this problem, as I did, there is a work-around. If, instead of closing the render preview window, you hit Esc, it will return to the main Blender Window without crashing, albeit while still leaving the render window open and on your taskbar. You can also use any form of application switching (alt-tab) to go back and forth between them.

If you do accidentally close the render window, (for me "crashing" meant that it wouldn't redraw the screen in the main Blender window - just black), you can still get back by hitting F12 again for another render, which will work, and then hit Esc or Alt-Tab to get back to the main window, which will redraw now.

Or at least, that's how it works for me.

Post Reply