How to access CVS?

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
Posts: 9
Joined: Wed Oct 16, 2002 2:37 pm

How to access CVS?

Post by vicmmi »

Hi, I'm not a programmer, so how do I access the CVS? Can't understand the login instruction specified here.


Posts: 10
Joined: Sat Oct 19, 2002 1:36 pm

Post by H_xNaN »

Then I assume you're a windows user. Get WinCVS, enter the pserver settings from the unix instructions and off you go :)

Posts: 111
Joined: Sun Oct 13, 2002 8:26 pm

Post by IngieBee »

I'm gonna post a more detailed how to, since Devas73 was so kind enough to clue me in when I was totally clueless. Not that you wouldn't bee much faster at figuring it out, but in case, why struggle?

OK, first download winCVS and install it.

2. Next, open the program,
3. go to Admin--> preferences and in the CVSROOT field, enter
This will automatically fill in all the other fields, except the top one, which is a pull down menue,
4. pull down to pserver
5. go to Admin-->login then you'll get a popup as well as a DOS window
and you enter anonymous as your password

The pop up and the Dos windows disappear.... no worries, you've logged on.

6. Now go to Admin --> command line
7. Enter cvs co blender AND
8. Click on the box below which browses to the file location you want it
put in.
9. Click OK and it should start to download the goods, it will take a while
and they will be organized per the CVS project tree. To learn what
else you need to compile it, go to that thread, but you'll need to add
other libraries that Blender uses, like python, opengl, etc... that's not

Did I forget anything? Just ask, I'm happy to send you down another dead end road anytime :wink: :twisted: :P

Love Ingie

Posts: 71
Joined: Mon Oct 21, 2002 12:53 am
Location: Bucks, England

Post by LethalSideParting »

Erm... :oops: the risk of sounding stupid (what else is new?), where can we get hold of wincvs? I tried ('couldn't find server') and searches on google (only found wincvs tips, rather than the binary :x ). Thanks for any help, guys!


Posts: 10
Joined: Sat Oct 19, 2002 1:36 pm

Post by H_xNaN »

LethalSideParting wrote:I tried ('couldn't find server')
try again. it's at:

here are the download mirrors:

Ftp mirrors

Europe: (Swiss SunSITE, located in Zurich/Switzerland) ... rs/cvsgui/ (Ludwig-Maximilians-University [D], located in Munich/Germany)
ftp://pisa.pi.informatik.tu-darmstadt.d ... rs/cvsgui/ (Technical University of Darmstadt, located in Darmstadt/Germany) (Technical University of Heilbronn, located in Heilbronn/Germany) (Swedish University Computer Network, located in Sweden) (ICM, Warsaw University, located in Warsaw/Poland) (located in Amsterdam/Netherlands) (, located in Brno/Czech Republic) (Netherlands Unix Users Group, located in Amsterdam/Netherlands)

North America: (SourceForge, located in USA) (Linux Boxen/Unified Consulting, Inc., located in Oakbrook, IL/USA) (, located in San Jose, CA/USA)

Asia: (Australia/AARNet, located in Australia) (PanworldNet IDC/Panworld Networks, located in Korea)

Posts: 2
Joined: Wed Oct 23, 2002 1:14 am

Post by gslyons »

I had the same problem with, but I was able to drill through sourceforge and find it. Only problem is that it keeps on GPF'g on me. I hate windowsjavascript:emoticon(':x')
Mad. As soon as I replace my dead hdd an dreload linux, I'll be a much happier boy...

Post Reply