Blender 2.5 Beta

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
philman401
Posts: 0
Joined: Sat Mar 07, 2009 7:36 am

Blender 2.5 Beta

Post by philman401 »

I got it and unfortunately it crashes when I open the user preference :(

adrian
Posts: 21
Joined: Fri Oct 18, 2002 1:31 pm

Post by adrian »

Yes me too.
I have the 32 bit (blender-2.53-beta-linux-glibc27-i686) version running on slackware 13.1.
If I change the "user preferences" then save as "default". I get the following error:-

Code: Select all

./blender: symbol lookup error: ./blender: undefined symbol: gzopen64 
gzopen64 - Is this part of a 64bit zlib?

Any help will be appreciated.

adrian
Posts: 21
Joined: Fri Oct 18, 2002 1:31 pm

Post by adrian »

Ok, I sorted it.
Download zlib 1.2.5 http://www.zlib.net/.
Make a static version

Code: Select all

./configure --static
then

Code: Select all

make
and put the libz.a & libz.so.1.2.5 file in your blender and lib folder
I tried a full install but it screwed up midori and firefox, had to reinstall zlib 1.2.3.

philman401
Posts: 0
Joined: Sat Mar 07, 2009 7:36 am

Post by philman401 »

adrian wrote:Ok, I sorted it.
Download zlib 1.2.5 http://www.zlib.net/.
Make a static version

Code: Select all

./configure --static
then

Code: Select all

make
and put the libz.a & libz.so.1.2.5 file in your blender and lib folder
I tried a full install but it screwed up midori and firefox, had to reinstall zlib 1.2.3.
lol i do not know anything about any of that, and I can't even open the user pref :( just hangs right after i click the file>user pref and it crashes.

EDIT: Okay i can access the user preferences by changing one of the windows to UP, but crashes when i try to access it from the File menu. And I am able to save defaults with ctrl+U.

And i think i know the exact bug, it's when blender tries to make a new window. I have tried a test render to new window and it crashes. It works fine when i render in image editor or full screen.

double_dose
Posts: 0
Joined: Thu Jun 18, 2009 8:34 am

Post by double_dose »

philman401 wrote: lol i do not know anything about any of that, and I can't even open the user pref :( just hangs right after i click the file>user pref and it crashes.

EDIT: Okay i can access the user preferences by changing one of the windows to UP, but crashes when i try to access it from the File menu. And I am able to save defaults with ctrl+U.

And i think i know the exact bug, it's when blender tries to make a new window. I have tried a test render to new window and it crashes. It works fine when i render in image editor or full screen.
Despite this topic's last post being in 2010, I wanted to add that this happens for me on versions 2.57, 2.58, and 2.59. I repeated the solution and render window and file menu problems in version 2.59.

Versions 2.49b, 2.56, 2.57, 2.58, and 2.59 are all on my system.

There was another problem related with having multiple versions on the same system: when choose "open with" and browse for the correct version to run the *.blend extension with, the icon is not given, and it continues to open *.blend with version 2.49b.

As a workaround for this, I renamed the 2.59 "blender.exe" to blender2_49.exe" and did the "open with" procedure. Then the icon appeared in the following list (however it was at the bottom and still just named "blender"). The *.blend files were correctly associated at that point, and I could even rename the "blender2_59.exe" back to "blender.exe" and the icon for version 2.59 remained in the association list. Though that solved the association issue, I don't know if it is related to the current problem.

There was a bug report that I submitted to Blender before finding this post, and developers think it has something to do with my chipset, since it was 2009 since it was updated. Toshiba hasn't put out a later version, and the generic ones that I tried from Microsoft prompts and redirects me to Toshiba during installation.

If anyone knows why the user preferences issue is happening, please let me know.

Thanks.

Post Reply