Building tuhopuu2 under windows with gcc

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

alien-xmp
Posts: 0
Joined: Sun Apr 06, 2003 2:22 pm
Location: Wellington, New Zealand
Contact:

Post by alien-xmp »

cd tuhopuu2
then cvs update. :)

Autotools look OK... newer than mine.

Etna
Posts: 0
Joined: Sat Mar 29, 2003 1:18 pm

Post by Etna »

Always the same error.
i've updated tuhopuu, but i always can't compile that.
What's your procedure to compile Blender-Tuhopuu under Linux?
My libs= gcc 3.2.3, glibc-2.3.2, glib-1.2.10 and glib-2.2.2

anyway, i can compile official blender


Please help me


Here a print:

Blender_guardedalloc.la intern/bmfont/libblender_BMF.la intern/container/libblender_CTR.la intern/memutil/libblender_MEM.la intern/iksolver/libblender_IK.la intern/moto/libblender_MT.la intern/SoundSystem/libsoundsystem.la -lpython2.2 -lm -lGLU -lGL -lopenal -lvorbisfile -lvorbis -logg -lesd -lsmpeg -lutil -lSDL -lutil -ljpeg -lpng -lpthread -ldl -lstdc++ -lz -lfreetype -lz -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread -L/usr/X11R6/lib -L/usr/X11R6/lib -lXext -lX11 -lm
mkdir .libs
gcc -g -O2 -funsigned-char -I/usr/include/freetype2 -I/usr/include/SDL -D_REENTRANT -o blender None -Wl,-rpath -Wl,/usr/lib -L/usr/lib/python2.2/config source/.libs/libblender_source.al intern/bsp/.libs/libblender_BSP.al intern/decimation/.libs/libblender_LOD.al intern/ghost/.libs/libblender_GHOST.al intern/string/.libs/libblender_STR.al intern/guardedalloc/.libs/libblender_guardedalloc.al intern/bmfont/.libs/libblender_BMF.al intern/container/.libs/libblender_CTR.al intern/memutil/.libs/libblender_MEM.al intern/iksolver/.libs/libblender_IK.al intern/moto/.libs/libblender_MT.al intern/SoundSystem/.libs/libsoundsystem.al -lpython2.2 -lm /usr/lib/libGLU.so -L/usr/lib -L/usr/X11R6/lib -lSM -lICE -lXmu -lXt -lXi -ldl -lpthread -lGL -lopenal /usr/lib/libvorbisfile.so -lm /usr/lib/libvorbis.so -lm /usr/lib/libogg.so -lm /usr/lib/libsmpeg.so -lpthread -lpthread -lsupc++ -lpthread -lutil -lm -L/usr/kde/3.1/lib -ldl -lpthread -lm -ldl -lutil /usr/lib/libjpeg.so -lpng -lpthread -ldl -lstdc++ -lz /usr/lib/libfreetype.so -lz -lz /usr/lib/libSDL.so -lm -ldl -lartsc -lpthread /usr/lib/libesd.so /usr/lib/libaudiofile.so -lm -lvga -ldl -lpthread -lXext -lX11 -lm
gcc: None: No such file or directory
make[2]: *** [blender] Erreur 1
make[2]: Leaving directory `/tmp/blender-2.28c'
make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory `/tmp/blender-2.28c'
make: *** [all] Erreur 2

alien-xmp
Posts: 0
Joined: Sun Apr 06, 2003 2:22 pm
Location: Wellington, New Zealand
Contact:

Post by alien-xmp »

gcc -g -O2 -funsigned-char -I/usr/include/freetype2 -I/usr/include/SDL -D_REENTRANT -o blender None -Wl,-rpath -Wl,/usr/lib -L/usr/lib/python2.2/config source/.libs/libblender_source.al intern/bsp/.libs/libblender_BSP.al intern/decimation/.libs/libblender_LOD.al...

The problem is that "None" creeping in.
Could you please:

grep None config.log
grep None Makefile

?

I compile like this:
# ls
bf-blender
BF-BLENDER
DEBUG
extern
tuhopuu2
TUHOPUU2
# cd tuhopuu2
# cvs -z3 update -Pd
# ./bootstrap
# cd ../TUHOPUU2
# CFLAGS="-pipe -ffast-math -O3 -march=pentium3 -mmx -msse -mfpmath=sse -fomit-frame-pointer" CXXFLAGS=$CFLAGS ../tuhopuu2/configure --enable-gameblender --enable-i18n --with-ftgl=/home/kester/blender-src/extern/ftgl --with-ode=/home/kester/blender-src/extern/ode --with-openal=/home/kester/blender-src/extern/openal
# nice make

Actually I have a makefile that automates all that, and only bootstraps and configures when necessary. I also build a debug build.

Etna
Posts: 0
Joined: Sat Mar 29, 2003 1:18 pm

Post by Etna »

i didn't retry..
I've noticed it used automake.1.4 by default, so i changed this, i didn't get error when bootstrap/automake anyway compilation stop at same error.

i print config.log:
configure:11143: result: None
am_cv_python_ldflags=None
PYTHON_LDFLAGS='None'


From Makefile:
PYTHON_LDFLAGS = -L/usr/lib/python2.2/config None



thanks for your help

Etna
Posts: 0
Joined: Sat Mar 29, 2003 1:18 pm

Post by Etna »

Okay, it's okay

i've succeeded.

alleluja

Post Reply