is this a bug?

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
Haunt_House
Posts: 24
Joined: Tue Oct 22, 2002 9:03 am

is this a bug?

Post by Haunt_House » Thu Oct 02, 2003 11:30 pm

Before I commit that to the bug tracker, I need some reassurance.

The picture below was made by rendering a number of bars, aspect ratio 1:1. Afterwards I put a plane before the bars, covering the lower half of the image. I shadelessly textured this plane with the picture that had been taken before. I used win as texture coordinates.

So my question is:

Since it is a wintexture and no other setting has changed, shouldn't the bars appear straight, rather than having this edge, where the winmapped plane ends and the real bars begin?

thanks in advance

http://www.people.freenet.de/haunt_hous ... wintex.jpg


Haunt_House

paradox
Posts: 2
Joined: Fri Oct 18, 2002 7:07 am
Contact:

Post by paradox » Fri Oct 03, 2003 5:51 am

I'm not sure either if it is an error. But it may have something to do with perspective view of the camera. The bars are shown in perspective and the texture is flat, so maybe the camera reads the 2 differently. Maybe try using ortho mode in the camera. I'm just trying to figure out why and may be way off base.
Paradox

Haunt_House
Posts: 24
Joined: Tue Oct 22, 2002 9:03 am

Post by Haunt_House » Fri Oct 03, 2003 5:47 pm

Well, I don't think that a wintexture is (or should be) affected by perspective.

And actually it's the very same picture and resolution.

Btw: I Think, the distortions would be more regular if it had something to do with perspective.

To me, it looks like the wintexture has to map more precisely. Maybe some kind of rounding error.

The problem is that this prevents Blender from doing some fine tricks.

Haunt_House

Post Reply