How to activate the F11 and F12 keys on a Mac laptop

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

Post Reply
ivarstone
Posts: 7
Joined: Sat Jan 26, 2013 7:38 pm

How to activate the F11 and F12 keys on a Mac laptop

Post by ivarstone » Sat Jan 26, 2013 7:54 pm

Hi Guys,
I have been having difficulty activating my F11 and F12 keys on my Macbook pro laptop. The operating system is OSX 10.6.8. This means I can't undo my renders.
I have gone into Blenders user preferences and set emulate numpad and continuous grab/and I am selecting with left click, however the function keys are not working right. Even when I hold down the function key and click F11 it still does not undo a render. I would be so grateful if anyone can help!!!!!
Thanks a million, stoneyivar :?

stiv
Posts: 3645
Joined: Tue Aug 05, 2003 7:58 am
Location: 45N 86W

Post by stiv » Sun Jan 27, 2013 10:39 pm

Usually when this happens, either the window manager or the operating system is grabbing the keys before blender can see them. The fix is to un-assign or re-assign the keys outside of blender. Doing this is a platform-specific task.

ivarstone
Posts: 7
Joined: Sat Jan 26, 2013 7:38 pm

How to activate the F11 and F12 keys on a Mac laptop

Post by ivarstone » Mon Jan 28, 2013 12:40 pm

stiv wrote:Usually when this happens, either the window manager or the operating system is grabbing the keys before blender can see them. The fix is to un-assign or re-assign the keys outside of blender. Doing this is a platform-specific task.

Thanks Stiv for getting back. I will follow up on your advice. Many thanks!

ikester
Posts: 1
Joined: Sat Feb 16, 2013 3:12 am

Post by ikester » Sat Feb 16, 2013 3:15 am

Try pressing the function key with F11 and F12. It's the one labeled 'fn'.

It works for me with fn+F11 and fn+F12.

ivarstone
Posts: 7
Joined: Sat Jan 26, 2013 7:38 pm

Post by ivarstone » Sat Feb 23, 2013 2:24 pm

ikester wrote:Try pressing the function key with F11 and F12. It's the one labeled 'fn'.

It works for me with fn+F11 and fn+F12.

Thanks for the tip. Nothing seems to work for me with this issue.
However, it's no big deal to use the Render drop down menu.
Cheers :lol:

mouse1999
Posts: 1
Joined: Fri Aug 23, 2013 1:07 pm
Location: Austin, TX

Post by mouse1999 » Fri Aug 23, 2013 1:11 pm

Hi @ivarstone - when you press F12, is it showing your mission control screen? I had to go into my settings and unassign my F11 and F12 keyboard shortcuts to solve this issue - is working for me now.
ivarstone wrote:
ikester wrote:Try pressing the function key with F11 and F12. It's the one labeled 'fn'.

It works for me with fn+F11 and fn+F12.

Thanks for the tip. Nothing seems to work for me with this issue.
However, it's no big deal to use the Render drop down menu.
Cheers :lol:

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests