Recommended ATI reg settings for Radeon 9800 users etc

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

johnnygray
Posts: 0
Joined: Tue Mar 02, 2004 12:40 am

Recommended ATI reg settings for Radeon 9800 users etc

Post by johnnygray »

hi first post, so i'll be quick.

have noticed a number of people suffering with the latest Catalyst ATI drivers, (4.2? etc) in relation to Blenders performance OpenGl, startup, distorting, corruption etc.

a number of people have mentioned the 'control panel' not really giving you the access to real features you need to optimize for good blender use? and that older (3.5?) versions of the ATI control panel tended to give you a bit more experimentive freedom in terms of your settings?

this is just a thread that i think people should get involved with, should they want to. i don't think the fault is with the current 4.2 ATI drivers, it's the lack of 'control' in the control panel (4.2).

so.

from what i'm aware of, the main opngl killers (in terms of performance hit) are to do with (1) Anti-aliasing (in particular, FullscreenAnti-aliasing) and something called (2) Anisotropic filtering.

from ATI's point of view, these factors could be implemented under the Smoothvision Engine 2.0, or such, and perhaps are not meant to be easily turned off. (being for games etc).

i did a little experiment.
backed up the reg (as any sensible folk would) and took a look in the registry for the settings the ATI control panel doesn't give, for Example .1 How to properly disable Anti-aliasing. In NVidis NVIEW software, you get various settings, 4,2,1,application preference or '0' OFF. Would i be right in thinking, that although you can set it to 'application prefence' in the ATI control panel (4.2), this doesn't actually kill it. It just leaves it up to Blender ( or what ever application) to decide? and of, course i've i've feeling there's nothing 'written' into blender to turn it off, by default?

no, thought not. :)

so along with the two criteria, 'ANISO' and 'ANTIALIAS', i found quite a few registry entries. you should make sure they're associated with the Video card in the registry area, just to make sure, i.e called video, ati, opengl, D3D (and not something else!). Most of the parts i found had either 1's (indicating ACTIVE/ON) next to them, or alternatively 2's (In relation to sample points for Anti-aliasing).

i have set some very basic anti-aliasing and anisotropic filtering settings to '0', or OFF, in both Ati, opengl and D3d setting areas. after restarting, i have ran through a few models in Wings3d and Blender. No problems noticed, seemed a bit snappier. Blender loaded up a lot quicker, menu's snappier, Wings3d seemed to handle a few bigger polygon models 15,000 up with a fair degree of ease.

a few things in the registry i'm not so sure of, and would be good for others to comment on.

oglsmooth? 0 or 1, ON off? does this relate to SmoothVision, or anti-aliasing?
oglmode? performance mode? i had mine set in the ATI console to MAX performance. it is indicated as being 2 in the registry (?)
vsync 0,1? waitforvsync 0,1?

others also relate to D3D: d3Dsmooth etc, but that's not really a worry.

if anyone has had any experience tinkering under the hood, and beyond having to use older drivers+panels, that would be helpful.

as i say, building up a registry-database of what is safe to tweak would be cool for ATI's. specially the TYAN TACHYEON 9800 pro, i've got. it's a nice card.

win Xp Pro
tyan MPX board, 2 X MP2200s
1 gig ram
Tyan (Radeon) Tachyeon 9800 pro.

Wings 0.98.19c
Blender. 2.32 (latest)

no probs found so far.
comments welcome.
j

Apollux
Posts: 0
Joined: Sun Mar 02, 2003 4:27 am
Location: Santo Domingo, Dominican Republic

Post by Apollux »

Over the Blender forum at CGTalk we have an ATI Radeon 9500 (Catalyst 4.2) user having a lot of troubles with Blender.. I just fordwarded this thread to him.

Hopefully, now he will be able to solve his problems and contribute some user feedback on the subject.

z3r0_d
Posts: 289
Joined: Wed Oct 16, 2002 2:38 am
Contact:

Post by z3r0_d »

the settings in the ati control panel have failed to slow down blender further than the existing bug

antialiasing makes things display wrong (don't have a pic) and the smartshader effects apparently are applied on redraw, and not just to the active viewport (so as you work in one window another will be further and further corrupted by reapplying the shader), but no amount of setting changing will make blender not slow down to be unusuable

however, it appears 2.25 doesn't slow down as much, and 2.23 at all. If this is the case it ought to be possible to fix blender to either not exploit these bugs, or just fix blender in general (it may not be wholly ati's fault)

johnnygray
Posts: 0
Joined: Tue Mar 02, 2004 12:40 am

Post by johnnygray »

hi z3r0_d,

the point i wanted to make was that the ATI panel doesn't seem capable of actually helping Blender run more smoothly or efficiently.

sure, you can set opengl 'anitialiasing' to application preference, but this does not 'TURN OFF' the feature completely.
as i mentioned in my registry settings the opengl settings for anisotropic filtering and antialiasing remained at '1' (ON) regardless of what ever i did in the latest ATI control panel.

i believe the older 3.5 ATI control panel may have given you more 'options', i.e more control over your opengl settings. these settings are not featured in 4.2 (the version i have).

i believe there is nothing wrong with the latest ATI driver. You just to need to tweak a few things in the registry (WIN) or whatever equivilant OS.
i tweaked things like oglaniso, or oglFSAA etc to '0', rather than '1' (that number, to my knowledge of binary means ON! this is not meant to be on!

i think you need to experiment with the resgistry settings for the card, under video, opengl, D3D settings etc, to get the best results for Blender.

My version of Blender feels a bit quicker. it certainly loads more quickly than before.
hope this helps.

(remember, always back up the registry prior to any changes).
j.

ton
Site Admin
Posts: 350
Joined: Wed Oct 16, 2002 12:13 am
Contact:

Post by ton »

Hey Johnnygray,

Nice piece of research you did!

I've also heard Blender 2.23 (and older) doesn't have the bad behaviour, which is at least a clue we can do something... the 2.23 release was the last one using Glut, before we switched to our own windowing library (Ghost).

Now we just need someone with this h/w an driver setup, who already can build Blender, to do some experiments!

Ran13
Posts: 0
Joined: Thu Mar 04, 2004 6:19 pm

Post by Ran13 »

Most, if not all, of the registry settings for the ATI drivers are accessible by using the "Rage3DTweak" app available here:

http://www.rage3d.com/index.php?node=r3dtweak

However, nothing I can do STOPS the problem, only delays the inevitable.

Here's some relavant info from the rage3D forums:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
4. well, this is just Blender related, as i'm using this 3d app, and it is drawing all menues horribly slow using catalyst 3+.. i found it's wrong implementation of hardvare overlay panes, and simple solution is to make your radeon convert to fireglx1 using rivatuner - opengl then just rocks, and no problem at all with apps. Bad thing is, you loose dx9, so i'd suggest creating 2 hardware profiles - one for gaming using radeon mode, and one for apps, using fireglx1. Maybe if you tweak it enough, you just find the opengl driver file from fireglx1 and possibly it would work in radeon mode too.. i didn't have time to look into this yet.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Compiling Blender gave me this message trying to start it:

FATAL: fglX11FreeBuffer: firegl_FreeBuffer() failed!
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Also, whenever I launch Blender, the console reports a GHOST error ..."Invalid GHOST window" or somesuch...I'm at work so I can't relate the exact message as I have an NVidia 5200 FX here that runs Blender just fine.

It seems that there are a couple of problems going on...one having to do the the "gl_FreeBuffer" function in Blender (Blender problem?...if it's not freeing memory correctly than wouldn't gradual slowdown be a symptom?...perhaps this is aproblem with the GHOST library and not blender itself?), and another with faulty implementation of hardware overlays (ATI problem?).

Hope you guys figure this one out soon. Having messed with Blender here at work, it's sure has come a long way since NaN first released it. I'd like to use it, but as it stands, I cannot figure out a workaround for the gradual slowdown of the interface.

z3r0_d
Posts: 289
Joined: Wed Oct 16, 2002 2:38 am
Contact:

Post by z3r0_d »

ton wrote:Now we just need someone with this h/w an driver setup, who already can build Blender, to do some experiments!
sounds like a good place for me to volunteer myself

I was planning on installing cygwin anyway
Ran13 wrote:~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Compiling Blender gave me this message trying to start it:

FATAL: fglX11FreeBuffer: firegl_FreeBuffer() failed!
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Also, whenever I launch Blender, the console reports a GHOST error ..."Invalid GHOST window" or somesuch...I'm at work so I can't relate the exact message as I have an NVidia 5200 FX here that runs Blender just fine.

It seems that there are a couple of problems going on...one having to do the the "gl_FreeBuffer" function in Blender (Blender problem?...if it's not freeing memory correctly than wouldn't gradual slowdown be a symptom?...perhaps this is aproblem with the GHOST library and not blender itself?), and another with faulty implementation of hardware overlays (ATI problem?).
would that be in linux? My SuSE 8.2 system did that until I installed the 2.4.20 kernel (from .19)

it also did it with the ut2003 demo and tuxracer, and when the ode tests quit and ... bunches of places

the Ghost errors I see too, but I don't have anything really to say about them

Ran13
Posts: 0
Joined: Thu Mar 04, 2004 6:19 pm

Post by Ran13 »

would that be in linux? My SuSE 8.2 system did that until I installed the 2.4.20 kernel (from .19)
I just re-checked the thread that I got that info from and, yes, he was compiling Blender for Linux. So, that's a linux specific thing I guess (I'm not a programmer), ...but the repeating GHOST window errors might be a clue to what the problem is.

Doesn't Maya use hardware overlays for their interface and for Artisan effects? No problem with MayaPLE on the same machine.

viktorivar
Posts: 4
Joined: Wed Oct 16, 2002 9:55 pm

Post by viktorivar »

I get "GHOST event error - invalid window - win: (different nr. everytime) 010320D0" when I close a renderwindow in Blender 2.32.

I have a old ATI Rage Pro card.

viktorivar

ton
Site Admin
Posts: 350
Joined: Wed Oct 16, 2002 12:13 am
Contact:

Post by ton »

afaik the Ghost error is harmless, an event lagging, calling a window which doesn't exist anymore. Should be fixed once, but it doesn't happen on my current dev environment (OSX).

The gl_FreeBuffer() is not part of the entire code base in Blender, so I don't know... here drivers and opengl libs take part I guess.

(quote:) "I found it's wrong implementation of hardvare overlay panes"

Blender doesn't use overlay planes. Menus are just simply drawn in the frontbuffer. This is opengl compliant, but apparantly not well supported anymore...

A profile for someone who could fix this:
- can repeat the error as reported
- has basic knowledge of opengl & glut

You can mail me directly too (ton at blender.org) and/or attend the coders channel at irc.freenode.net, #blendercoders

Ran13
Posts: 0
Joined: Thu Mar 04, 2004 6:19 pm

Post by Ran13 »

This is opengl compliant, but apparantly not well supported anymore...
I've been poking around on various OGL/GLUT programming sites and the general concensus there is that the OGL 2D pipe has never been optimal for consumer class video cards and is, in general, only well implemented (read: fast) on workstation class hardware/drivers. Also, consumer class hardware is optimized to use the "normal" method of writing everything to the back buffer then doing a buffer swap. From what I can gather, writing directly to the front buffer (especially when double buffering is enabled...which I asume it is for the 3D window at least) on consumer class graphics cards is not optimal on any mfr's card, but ATI seems to have the most problems with it.

from http://users.frii.com/martz/oglfaq/performance.htm
Why are glDrawPixels() and glReadPixels() so slow?

While performance of the OpenGL 2D path (as its called) is acceptable on many higher-end UNIX workstation-class devices, some implementations (especially low-end inexpensive consumer-level graphics cards) never have had good 2D path performance. One can only expect that corners were cut on these devices or in the device driver to bring their cost down and decrease their time to market. When this was written (early 2000), if you purchase a graphics device for under $500, chances are the OpenGL 2D path performance will be unacceptably slow.

If your graphics system should have decent performance but doesn’t, there are some steps you can take to boost the performance.

First, all glPixelTransfer() state should be set to their default values. Also, glPixelStore() should be set to its default value, with the exception of GL_PACK_ALIGNMENT and GL_UNPACK_ALIGNMENT (whichever is relevant), which should be set to 8. Your data pointer will need to be correspondingly double- word aligned.

Second, examine the parameters to glDrawPixels() or glReadPixels(). Do they correspond to the framebuffer layout? Think about how the framebuffer is configured for your application. For example, if you know you're rendering into a 24-bit framebuffer with eight bits of destination alpha, your type parameter should be GL_RGBA, and your format parameter should be GL_UNSIGNED_BYTE. If your type and format parameters don't correspond to the framebuffer configuration, it's likely you'll suffer a performance hit due to the per pixel processing that's required to translate your data between your parameter specification and the framebuffer format.

Finally, make sure you don't have unrealistic expectations. Know your system bus and memory bandwidth limitations.
From John Spitzer, Appkication Engineer at NVidia, in this article on OGL performance:
http://216.239.41.104/search?q=cache:yL ... n&ie=UTF-8
Avoid front-and-back rendering like the plague!

Instead, render to back, then to front
A possible alternative would be to use a pbuffer to render the GUI ofscreen before swapping to the the front buffer:
http://developer.nvidia.com/object/PBuf ... en%20.html


Don't know if any of that will help. As a simple mesh monkey, I'm in WAY over my head! :)

Ran13
Posts: 0
Joined: Thu Mar 04, 2004 6:19 pm

Post by Ran13 »

UPDATE:

New ATI Catalyst v4.3 drivers still exhibit the slowdown problem w/ Blender.

Apollux
Posts: 0
Joined: Sun Mar 02, 2003 4:27 am
Location: Santo Domingo, Dominican Republic

Post by Apollux »

This was posted by Ton a few days ago on the Developer's Mail List

¨Hi all,

ATI dev support will send me:

> 1- RADEON 9800 XT 256MB AGP
> 1- RADEON 9700 PRO 128MB AGP
> 1- RADEON 9600 XT 128MB AGP

This because I was bothering them with the bad results ATI cards give
with Blender recently, especially regarding their latest drivers.
My idea is, that when active developers here use ATI (as well) we might
get insight in:

- what exactly goes wrong
- if it's possible to code a bypass
- if it's possible to tweak settings for the drivers to make it run
smooth, to add to our support section.

Developers here feeling competent for such testing, and/or developers
with urgent need for a new 3D card can contact me. I'll ship them the
card for free. :)

-Ton-¨

A2597
Posts: 0
Joined: Mon Feb 24, 2003 7:42 pm

Post by A2597 »

YES!!! Hopefully that will mean they FIX this bloody bug! I've been contacting ATI after EVERY driver reelease wince 3.9 (Last ones that do NOT have the slowdown) begging them to fix this, but never happened....

them shipping cards to Ton is great!
The man with his head stuck in the Blender.

thoro
Posts: 15
Joined: Thu Oct 17, 2002 10:20 am
Location: Berlin, Germany
Contact:

Post by thoro »

Hehe, cool - I bothered (or feedbacked) them as well :D

I hope that there will be a solution - I just built a new system from scratch - it's based on an Athlon XP 3400+ with 1GB RAM and ... an ATI Radeon 9800 XT - great machine, but I still have to use my 2 year old notebook for Blender :cry:

Post Reply