Blender 2.32 (BF) on Unix (Mac OS X 10.3.3)

General discussion about the development of the open source Blender

Moderators: jesterKing, stiv

cekuhnen
Posts: 303
Joined: Mon Jan 13, 2003 11:04 pm

Post by cekuhnen » Thu Apr 01, 2004 9:37 pm

ok many monkey with around 288000 v slow down blender so bad that switching between modes takes some seconds.

but also at 7920 v selecting polygones and moving them is slower than doing that with 3960 v!!!

with around 16000 its getting slower and slower. moving points is slow. rotating the cam is faster!

pretty sad to see that.

might it be a solutoin for you to use layers? wasnt blender also limited to a special amount of polygones two version ago?

claas

JoOngle
Posts: 158
Joined: Sat Jan 24, 2004 4:12 pm
Contact:

Post by JoOngle » Sat Apr 03, 2004 1:21 am

Yes ...that is sad :(

But hopefully someone would fix it at some point :?:

Layers is a temporary solution. And yes...I use layers for
all my work weither it's 900.000 poly scene or 25 K scene.

But...sometimes with sophisticated film work it's not unusual
for the characters to hit 30 K for a single character with clothes
and normally that's not even an issue on the PC....
but on the Mac it slows down to a horrible state where it's
simply a nightmare to work with. This shouldn't be with
a superfast computer that at "least" equal the PC desktop with
all the trimmings.

Anyway - thanks for paying attention to this, now all
we can hope for is a fix.

/JoOngle

cekuhnen
Posts: 303
Joined: Mon Jan 13, 2003 11:04 pm

Post by cekuhnen » Sat Apr 03, 2004 1:53 am

i could image that aqua anyway soaks opengl power and than comes blender as well.

but i build a moce comples one and huh you are right it gets difficult to work with!

claas

xype
Posts: 140
Joined: Tue Oct 15, 2002 10:36 pm

Post by xype » Sat Apr 03, 2004 1:36 pm

First, have you tried ATi's newest drivers, under http://www.ati.com/support/drivers/mac/ ... plays.html ? The Radeon Display utilities also allow for application-specific tweaking of the OpenGL driver, maybe changing a setting or two there could make things faster.

Secondly, the speed has nothing to do with Cocoa or Aqua, for that matter.
OpenGL is made of C libraries, so using Carbon is just as fast. Cocoa can bring you some OS X features that Carbon can't, but that breaks cross-platformness quite fast.
Aqua, or rather Quartz Extreme uses OpenGL, true, but the moment an OpenGL application is running as the "active" application (the one "in front" where the user interaction happens) all of Quartz's OpenGL stuff is swapped out. Which means that the front-most application gets all the video card memory and GPU resources it wants. Apple would be stupid to not implement that ;o).

Going to full-screen would increase performance by at least 50% and once someone implements that, there should be a noticeable improvement. Also ATi is trying to update their OS X drivers more frequently now, so checking their website for updates is a good thing to do.

wavk
Posts: 255
Joined: Wed Oct 16, 2002 9:58 am
Location: The Netherlands
Contact:

Post by wavk » Sat Apr 03, 2004 3:06 pm

Hi xype,

that's just the problem, there are no drivers for the apple notebooks. The link you gave is just for the desktop models.

Money_YaY!
Posts: 876
Joined: Wed Oct 23, 2002 2:47 pm

Post by Money_YaY! » Sat Apr 03, 2004 4:43 pm


Money_YaY!
Posts: 876
Joined: Wed Oct 23, 2002 2:47 pm

Post by Money_YaY! » Sat Apr 03, 2004 4:57 pm

Michaelv:
Optimization on the scons build method is nonexsistant for darwin. I added

extra_flags = ['-pipe', '-fPIC', '-funsigned-char', '-ffast-math', '-mcpu=7450', '-mtune=7450']

, '-ffast-math', '-mcpu=7450', '-mtune=7450' are the additions.

and

release_flags = ['-O3']

to the if sys.platform =='darwin' section and it speeded things up nicely.

To find the correct machine type to add to -mcpu= and -mtune= use machine at the command line:
Last login: Sun Mar 28 09:38:52 on ttyp4
Welcome to Darwin!
[PowerBookG4 10:17:43am michaelv ] ~% machine
ppc7450 you'll get something like this.
Or you can just use the generic -mcpu=powerpc assuming you have a powerpc

For compiling the gameengine I added this to the SConscript file in solid:

elif sys.platform=='linux2' or sys.platform=='linux-i386':
defines += ['NDEBUG']
cflags += ['-O2']
elif sys.platform == 'darwin':
cflags += ['-O3', '-ffast-math', '-mcpu=7450', '-mtune=7450']
This adds the same optimizations to solid as the rest of the code.




Hi, I have been trying to use this for a week now. Can ypu give any insight whyI can nt get it to work :D Can you post a simple copy and paste of the config file that you edited ?

cekuhnen
Posts: 303
Joined: Mon Jan 13, 2003 11:04 pm

Post by cekuhnen » Sat Apr 03, 2004 6:04 pm

as far as i know are most mac without retail ati cards.
this cards are NOT the same ati sells!
they are based on the same tech but apple tells ati
what to change and tweak and so they do!

so the retail drivers should not be used with the cards
shipped by apple!!!

this does not mean it can never work but we had hard times with
this when we worked with cards and drivers...

claas

JoOngle
Posts: 158
Joined: Sat Jan 24, 2004 4:12 pm
Contact:

Post by JoOngle » Sun Apr 04, 2004 2:57 am

it works with most 3d-games in Apple...and they all run OpenGL

I don't see why it wouldnt work for Blender.
But as it is now...blender is horribly slow with OpenGL.
As slow as Blender would be with Microsoft's own Soft-OpenGL driver
without hardware accelleration....

...as a matter of fact & study...excactly as slow... O.o

Go figure...

xype
Posts: 140
Joined: Tue Oct 15, 2002 10:36 pm

Post by xype » Sun Apr 04, 2004 3:18 pm

It's not that bad, sofware OpenGL would work quite slower than what OS X gives you, stop talking rubbish.

Fullscreen is not the same as kiosk mode, and I guess adding fullscreen would be done with AGL's functions.

lukep
Posts: 210
Joined: Sun Apr 04, 2004 1:39 pm

Post by lukep » Wed Apr 07, 2004 11:59 pm

JoOngle wrote:it works with most 3d-games in Apple...and they all run OpenGL

I don't see why it wouldnt work for Blender.
But as it is now...blender is horribly slow with OpenGL.
Hey, Are you kidding ?

I'm working on a 650 k Vertices scene just now with a G4 867 Mhz notebook which has an old ATI card, and it's still useable. And I have a 2nd monitor with a different resolution and frequency hooked on too.

There is a delay when switching from shaded to mesh mode but that's quite normal. And yes, it's slower than a 5k scene.

Now, a notebook card PC or Mac is always slower than a desktop one.

from ATI website :
*******
Display drivers and multimedia applications for notebooks with ATI graphics solutions are available for download from your Notebook manufacturer.

The display driver supplied with a given notebook has been customized for:

the built-in flat panel display
any other graphics or video options installed in that specific computer.

As a result of these customizations, ATI Customer Care is unable to offer drivers for notebooks.
*****

What that really means, is that the notebook card is slower (battery length) than the full flanged desktop one.

V3nomX
Posts: 36
Joined: Sun Mar 28, 2004 11:25 am

Post by V3nomX » Sun Apr 11, 2004 4:43 pm

could it be possible to launch blender in full sreen from the terminal?

Money_YaY!
Posts: 876
Joined: Wed Oct 23, 2002 2:47 pm

Post by Money_YaY! » Mon Apr 12, 2004 11:35 pm

V3nomX wrote:could it be possible to launch blender in full sreen from the terminal?
if you launch just the core blender in terminal it will go almost full screen.

V3nomX
Posts: 36
Joined: Sun Mar 28, 2004 11:25 am

Post by V3nomX » Wed Apr 14, 2004 8:04 pm

and how do you launch the core from terminal?

wavk
Posts: 255
Joined: Wed Oct 16, 2002 9:58 am
Location: The Netherlands
Contact:

Post by wavk » Wed Apr 14, 2004 8:35 pm

V3nomX,

open ternimal and browse to the dir where blender is.
cd blender.app
cd Contents
cd MacOS
./blender

that's it,

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests